在线检测未来函数

飞狐乘风显示能量K线主图指标公式

来源:Internet,编辑:股旁网,2016-03-22

TYX3:=MA(REF(HHV((C+L+O+H)/4,30),1),3);
tyx4:=MA((C+L+O+H)/4,13);
TYX5:=EMA((C+L+O+H)/4,21);
{空心红}
STICKLINE(C<TYX5 AND C>O,H,L,0.1,1),COLORred;
STICKLINE(C<TYX5 AND C>O,C,O,8,1),COLORred;
{深绿}
STICKLINE(C<TYX5 AND C<O,h,l,0.1,0),COLOR009900;
STICKLINE(C<TYX5 AND C<O,C,O,8,0),COLOR005500;
STICKLINE(C<TYX5 AND C<O,C,O,6,0),COLOR005a00;
STICKLINE(C<TYX5 AND C<O,C,O,5,0),COLOR006600;
STICKLINE(C<TYX5 AND C<O,C,O,4,0),COLOR006b00;
STICKLINE(C<TYX5 AND C<O,C,O,3,0),COLOR007700;
STICKLINE(C<TYX5 AND C<O,C,O,1,0),COLOR007b00;
{蓝}
STICKLINE(C>TYX5 AND C<O,H,L,0.1,0),COLORFFAA22;
STICKLINE(C>TYX5 AND C<O,C,O,8,0 ),COLORFF7700;
STICKLINE(C>TYX5 AND C<O,C,O,6,0 ),COLORFF8811;
STICKLINE(C>TYX5 AND C<O,C,O,5,0 ),COLORFFAA22;
STICKLINE(C>TYX5 AND C<O,C,O,4,0 ),COLORFFBB33;
STICKLINE(C>TYX5 AND C<O,C,O,3 ,0 ),COLORFFDD44;
STICKLINE(C>TYX5 AND C<O,C,O,1 ,0 ),COLORFFFF55;
{黄}
STICKLINE(C>TYX5 AND C>O,H,L,0.1,0 ),COLOR00CCFF;
STICKLINE(C>TYX5 AND C>O,C,O,8,0 ),COLOR00AAFF;
STICKLINE(C>TYX5 AND C>O,C,O,6,0 ),COLOR00BBFF;
STICKLINE(C>TYX5 AND C>O,C,O,5,0 ),COLOR00CCFF;
STICKLINE(C>TYX5 AND C>O,C,O,4,0 ),COLOR00DDFF;
STICKLINE(C>TYX5 AND C>O,C,O,3,0 ),COLOR00EEFF;
STICKLINE(C>TYX5 AND C>O,C,O,1,0 ),COLOR00FFFF;
{粉红}
STICKLINE(C>TYX4 AND C>O,H,L,0.1,0),COLORAA00AA;
STICKLINE(C>TYX4 AND C>O,C,O,8,0 ),COLORFF11FF;
STICKLINE(C>TYX4 AND C>O,C,O,6,0 ),COLORFF33FF;
STICKLINE(C>TYX4 AND C>O,C,O,5,0 ),COLORFF44FF;
STICKLINE(C>TYX4 AND C>O,C,O,4,0 ),COLORFF55FF;
STICKLINE(C>TYX4 AND C>O,C,O,3,0 ),COLORFF66FF;
STICKLINE(C>TYX4 AND C>O,C,O,2,0 ),COLORFF77FF;
STICKLINE(C>TYX4 AND C>O,C,O,1,0 ),COLORFF88FF;
{亮灰}
STICKLINE(C>TYX4 AND C<O,H,L,0.1,0),COLORWHITE;
STICKLINE(C>TYX4 AND C<O,C,O,8,0),COLOR555555;
STICKLINE(C>TYX4 AND C<O,C,O,6,0),COLOR777777;
STICKLINE(C>TYX4 AND C<O,C,O,5,0),COLOR999999;
STICKLINE(C>TYX4 AND C<O,C,O,4,0),COLORAAAAAA;
STICKLINE(C>TYX4 AND C<O,C,O,3,0),COLORBBBBBB;
STICKLINE(C>TYX4 AND C<O,C,O,2,0),COLORcccccc;
STICKLINE(C>TYX4 AND C<O,C,O,1,0),COLORdddddd;
STICKLINE(C>TYX4 AND C<O,C,O,0.1,0),COLOReeeeee;
{深红}
STICKLINE(C>TYX3 AND C>O,h,l,0.5,0),COLOR0000dd;
STICKLINE(C>TYX3 AND C>O,C,O,8,0),COLOR000099;
STICKLINE(C>TYX3 AND C>O,C,O,6,0),COLOR0000aa;
STICKLINE(C>TYX3 AND C>O,C,O,5,0),COLOR0000bb;
STICKLINE(C>TYX3 AND C>O,C,O,4,0),COLOR0000cc;
STICKLINE(C>TYX3 AND C>O,C,O,3,0),COLOR0000dd;
STICKLINE(C>TYX3 AND C>O,C,O,2,0),COLOR0000ee;
STICKLINE(C>TYX3 AND C>O,C,O,1,0),COLOR0000ff;
{涨跌停K线}
STICKLINE(HIGH=LOW and CLOSE=OPEN and (CLOSE/REF(CLOSE,1))>1.048,HIGH,LOW,9,0) ,COLORRED;
STICKLINE(HIGH=LOW and CLOSE=OPEN and (REF(CLOSE,1)/CLOSE)>1.048,HIGH,LOW,9,0) ,COLOR00FF00;
{突破}
STICKLINE(REF(count(C<TYX3,5)=5,1) AND C>TYX3 AND C>O,C,O,2,0),COLOR00CCFF;
海面:MA(C,60),COLORFFFFFF,LINETHICK0;
乘风:MA(C,8),COLORYELLOW,LINETHICK0;
破浪:EMA(C,21),LINETHICK2,COLORMAGENTA;
PARTLINE(破浪>海面,海面),COLORFFFFFF;
PARTLINE(乘风>=破浪,乘风),COLORYELLOW,LINETHICK1;
PARTLINE(乘风>破浪 AND 乘风<=REF(乘风,1),乘风),COLORCYAN,LINETHICK1;
PARTLINE(破浪<=REF(破浪,1),破浪),COLORGREEN,LINETHICK2;
AA:=COUNT(CROSS(EMA(C,21),MA(C,8)),30)=1;
BB:=COUNT(CROSS(EMA(C,21),MA(C,60)),30)=1;
CC:=REF(BARSLAST(AA AND BB),1);
DD:=CC AND CROSS(MA(C,8),EMA(C,21));
DRAWTEXT(DD,(LOW * 0.99),'←乘风'),COLOR80FFFF;

飞狐乘风显示能量K线主图指标公式

 

相关文章