在线检测未来函数

同花顺最牛强中强主图指标公式

来源:Internet,编辑:股旁网,2016-03-28

{能够说明:1.粗橙色线是强势线; 2.黄色线为次强势线; 3.白色线为次弱势线; 4.粗绿色线为弱势线。 5.当股价呈黄色K图时,为强势股! 6.当股价呈粉红色K图时,为特强股,即强中强股! 7.当股价呈蓝色K图时,为特弱股。 8.出现“买”“加码”时,买入。 9.出现B点时,买入。 10.出现空框K图或大于二分之一空框K图时 ,酌情卖出。}

强势:MA(LOW,20)*1.2,color0080ff,linethick3;
次强势:MA(LOW,20)*1.1,coloryellow;
次弱势:MA(HIGH,20)*0.9,colorwhite;
弱势:MA(HIGH,20)*0.8,colorgreen,linethick3;
ZD:=(C-REF(C,1))/REF(C,1)*100;
HDZF:=(HHV(H,20)-C)/(HHV(H,20)-LLV(L,20));
趋势强度:=IF(C>次强势,IF(C>强势,4,3),IF(C>次弱势 AND C<次强势,2,IF(C<弱势,0,1)));
STICKLINE(趋势强度=0,H,L,6,1),colorblue;
STICKLINE(趋势强度=1,H,L,6,1),colorgreen;
STICKLINE(趋势强度=2,H,L,6,1),colorgray;
STICKLINE(趋势强度=3,H,L,6,1),coloryellow;
STICKLINE(趋势强度=4,H,L,6,1),colormagenta;
STICKLINE(趋势强度=0,C,O,5,0),colorblue;
STICKLINE(趋势强度=1,C,O,5,0),colorgreen;
STICKLINE(趋势强度=2,C,O,5,0),colorgray;
STICKLINE(趋势强度=3,C,O,5,0),coloryellow;
STICKLINE(趋势强度=4,C,O,5,0),colormagenta;
走势:CLOSE,colorred,LINETHICK1;
买进价:=((C-REF(MA(C,6),1))/6+MA(C,6))*1.004;
买进条件:=CROSS(C,买进价) AND 买进价>REF(买进价,1);
DRAWTEXT(买进条件,L-0.02,'. 买↑'),colorwhite,LINETHICK2;
STICKLINE(买进条件,H,L,0,1),colorwhite,LINETHICK2;
STICKLINE(买进条件,O,C,2,0),colorwhite,LINETHICK2;
加码价:=((C-REF(MA(C,18),1))/18+MA(C,18))*1.004;
加码条件:=CROSS(C,加码价) AND 加码价>REF(加码价,1);
DRAWTEXT(加码条件,L-0.02,'. 加码'),coloryellow,LINETHICK2;
STICKLINE(加码条件,H,L,0.5,1),coloryellow,LINETHICK2;
STICKLINE(加码条件,O,C,2,0),coloryellow,LINETHICK2;
短:(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4,NODRAW;
M:=(短-REF(短,1))/REF(短,1)*1000;
IF(短>REF(短,1),短,DRAWNULL),colorred,LINETHICK1;
IF(短<REF(短,1),短,DRAWNULL)COLOR00BB00,LINETHICK1;
长:MA(C,30),NODRAW;
IF(长>REF(长,1),长,DRAWNULL),coloryellow,LINETHICK1;
IF(长<REF(长,1),长,DRAWNULL),colorblue,LINETHICK1;
中:MA(C,60),NODRAW;
IF(中>REF(长,1),中,DRAWNULL),colorcyan,LINETHICK1;
IF(中<REF(长,1),中,DRAWNULL),colormagenta,LINETHICK1;
C3:=REF(C,1);
涨停:=IF((C-C3)*100/C3>=(10-0.01*100/C3),1,0);
STICKLINE(涨停,OPEN,CLOSE,2.5,0),coloryellow;
跌停:=IF((C3-C)*100/C3>=(10-0.01*100/C3),1,0);
STICKLINE(跌停,OPEN,CLOSE,2.5,0),colorblue;
VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;
DRAWICON(VAR19,L*1,7);
ma5:=MA(C,5);
ma13:=MA(C,13);
ma21:=MA(C,21);
ma34:=MA(C,34);
ma55:=MA(C,55);
ma89:=MA(C,89);
DRAWTEXT_FIX(1,0.01,0.82,0,'《神赚庄指标·》指标·做股要做强势股·系特殊专用强势股指标。--'),colorred;
///////底顶部BS背离///////
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
DRAWTEXT(CROSS(FF,MA15),(LOW * 0.99),'.底背买'),colorred;
{DRAWICON(CROSS(FF,MA15),(LOW * 0.99),7); }
RSI1:=((SMA(MAX((CLOSE - (REF(CLOSE,1))),0),3,1) / SMA(ABS((CLOSE - (REF(CLOSE,1)))),3,1))* 100);
DRAWTEXT(CROSS(88,RSI1) AND (MA(C,3))>(EMA(C,3)) ,(HIGH + 0.3),'.顶背卖'),colorgreen;
{DRAWICON(CROSS(88,RSI1) AND (MA(C,3))>(EMA(C,3)) ,(HIGH + 0.3),8); }
AA:=(HHV(HIGH,20) - (2 * ATR));
BB:=CROSS(CLOSE,REF(HHV(HIGH,55),1));
SSS:=CROSS(MIN(MA(CLOSE,13),AA),CLOSE);
BBB:=BARSLAST(BB);
SSSB:=BARSLAST(SSS);
B1:=((BBB = 0) AND (REF(SSSB,1) < REF(BBB,1)));
B1B:=BARSLAST(B1);
B2:=((((BB = 1) AND (B1B < SSSB)) AND (B1B > 0)) AND (COUNT(BB,SSSB) < 3));
B2B:=BARSLAST(B2);
B3:=((((BB = 1) AND (B2B < B1B)) AND (COUNT(BB,SSSB) < 4)) AND (COUNT(BB,SSSB) > 2));
DRAWTEXT((B1 = 1),(LOW - 0.6),'.跟进'),coloryellow;
DRAWTEXT((B2 = 1),(LOW - 0.6),'.加码'),COLORFFAAFF;////////////////研发////////,nodraw////

同花顺最牛强中强主图指标公式

 

相关文章