在线检测未来函数

通达信MACD+CCI指标公式

来源:Internet,编辑:股旁网,2016-03-31

dif:(ema(C,12)-ema(C,26))/ema(C,26)*100;
DEA:ema(DIF,9);
MACD:2*(DIF-DEA),COLORSTICK;
CCI1:=(EMA(C,14)-C)/(AVEDEV(C,14)*0.3);
CCI2:=(EMA(C,28)-C)/(AVEDEV(C,28)*0.3);
CCI3:=(EMA(C,42)-C)/(AVEDEV(C,42)*0.3);
CCI4:=(EMA(C,56)-C)/(AVEDEV(C,56)*0.3);
CCI5:=(EMA(C,70)-C)/(AVEDEV(C,70)*0.3);
CCI6:=(EMA(C,84)-C)/(AVEDEV(C,84)*0.3);
JCI:=(CCI1+CCI2+CCI3+CCI4+CCI5+CCI6)/6;
DCI:=MAX(CCI1,MAX(CCI2,MAX(CCI3,MAX(cci4,MAX(CCI5,CCI6)))));
XCI:=MIN(CCI1,MIN(CCI2,MIN(CCI3,MIN(cci4,MIN(CCI5,CCI6)))));
CCI:EMA(ema(EMA(ema(EMA(EMA(IF(CCI1>=DCI,(JCI+(DCI-XCI)*0.382),(JCI+6*DCI)/7),3),2),2),2),2),2);

通达信MACD+CCI指标公式

 

相关文章