在线检测未来函数

同花顺神仙三线主图指标公式

来源:Internet,编辑:股旁网,2016-04-04

A:=MA(CLOSE,17)+ABS(MA(CLOSE,17)-REF(MA(CLOSE,17),1));
B:=MA(CLOSE,17)+MA(CLOSE,17)-REF(MA(CLOSE,17),1);
分水岭:IF(MA(CLOSE,17)<B,B,MA(CLOSE,17)),COLORFF00FF,LINETHICK2;
操作线:分水岭-(EMA(C,3)-分水岭),COLOR00FFFF,LINETHICK2;
PM:MA(C,5),colorwhite,LINETHICK2;
IF(PM>REF(PM,1),PM,DRAWNULL),colorred,LINETHICK2;
IF(PM=REF(PM,1),PM,DRAWNULL),colorred;
IF(PM<REF(PM,1),PM,DRAWNULL),colorred,LINETHICK2;
S:=(PM>操作线);
DD:=分水岭<REF(分水岭,1);
IF(DD,分水岭,DRAWNULL),COLOR00FF00,LINETHICK2;
IF(S,分水岭,DRAWNULL),COLOR00FF00,POINTDOT,LINETHICK4;
DRAWICON(CROSS(分水岭,操作线),分水岭-0.1,1);
A1:=BARSLAST(REF(CROSS("MACD.DIF","MACD.DEA"),1));
B1:=REF(C,A1+1)>C AND REF("MACD.DIF",A1+1)<"MACD.DIF"AND CROSS("MACD.DIF","MACD.DEA");
DRAWTEXT(B1>0,L-0.02,'★ M'),COLOR00FFFF;
A2:=BARSLAST(REF(CROSS("KDJ.K","KDJ.D"),1));
B2:=REF(C,A2+1)>C AND REF("KDJ.K",A2+1)<"KDJ.K"AND CROSS("KDJ.K","KDJ.D");
DRAWTEXT(B2>0,L-0.10,'◎ K'),COLORFF00FF;
A3:=BARSLAST(REF(CROSS("RSI.RSI1","RSI.RSI2"),1));
B3:=REF(C,A3+1)>C AND REF("RSI.RSI1",A3+1)<"RSI.RSI1"AND CROSS("RSI.RSI1","KRSI.RSI2");
DRAWTEXT(B3>0,L-0.18,'◆ R'),COLOR0000FF;
C1:=BARSLAST(REF(CROSS("MACD,DEA","MACD.DIF"),1));
D1:=REF(C,C1+1)<C AND REF("MACD.DIF",C1+1)>"MACD.DIF"AND
CROSS("MACD.DEA","MACD.DIF");
DRAWTEXT(D1>0,H+0.16,'★ M'),COLOR00FF00;
C2:=BARSLAST(REF(CROSS("KDJ,D","KDJ.K"),1));
D2:=REF(C,C2+1)<C AND REF("KDJ.K",C2+1)>"KDJ.K"AND CROSS("KDJ.D","KDJ.K");
DRAWTEXT(D2>0,H+0.08,'◎ K'),COLORFFFFCC;
C3:=BARSLAST(REF(CROSS("RSI.RSI2","RSI.RSI1"),1));
D3:=REF(C,C3+1)<C AND REF("RSI.RSI1",C3+1)>"RSI.RSI1"AND CROSS("RSI.RSI2","KRSI.RSI1");
DRAWTEXT(D3>0,H+0.04,'◆ R'),COLORFF9900;

同花顺神仙三线主图指标公式

 

相关文章