在线检测未来函数

通达信猎人KDJ指标公式

来源:Internet,编辑:股旁网,2016-04-07

N:=9;
M1:=3;
M2:=3;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:SMA(RSV,M1,1);
D:SMA(K,M2,1);
J:3*K-2*D;
100;
DRAWICON(J>100,J,2);
-10;
DRAWICON(J<-8,J,1);
介入:IF(K<10,100,0),COLORRED;
GD:=HHVBARS(H,20);
DD1:=FINDLOWBARS(L,GD+1,20,1);
C1:=REF(C,GD);
C2:=REF(C,DD1+1);
ZF:=(C1-C2)/C2*100;
GZ:=REF(ZF,GD);
DF:=(C-REF(C,GD+1))/REF(C,GD+1)*100;
A:=EVERY(MACD.DIF>MACD.DEA,GD);
A11:=EVERY(L<REF(L,1),GD);
A2:=L<MA(C,20) AND MIN(C,O)>MA(C,20);
A3:=REF(MACD.DIF,1)<MACD.DIF AND REF(MACD.DIF,1)<REF(MACD.DIF,2);
A4:=REF(DF,1)<-8.5 AND GZ>20;
XG:=A AND REF(A11,1) AND REF(A2,1) AND A3 AND A4;
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
YXF:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);
加仓:FILTER(YXF=1,5);
STICKLINE(加仓,0,28,1.5,0),COLORRED;
MA2:=EMA(C,2);
MA5:=EMA(C,5);
MA13:=EMA(C,13);
MA34:=EMA(C,34);
MA55:=EMA(C,55);
MA120:=EMA(C,89);
YCXN:=MA5>=REF(MA5,1);
H1:=MAX(MAX(MA5,MA13),MA34);
L1:=MIN(MIN(MA5,MA13),MA34);
HHV(HIGH,10)/LLV(LOW,10)<1.25
AND REF(CLOSE,1)<(LLV(LOW,15)+(HHV(HIGH,15)-LLV(LOW,15))*0.9)
AND C>O AND DYNAINFO(4)>0
AND CLOSE>=HHV(HIGH,10)
AND H1<C AND REF(C,1)<L1 AND YCXN AND MA2>REF(MA2,1);
MA1:=MA(CLOSE,5);
MA22:=MA(CLOSE,10);
MASC:=CROSS(MA22,MA1);
DIF:=(EMA(CLOSE,12)-EMA(CLOSE,26))*100;
VUR0:=(((((2 * OPEN) + HIGH) + LOW) + (3 * CLOSE)) / 7);
VUR1:=(CAPITAL * VUR0);
VUR2:=(SMA(AMOUNT,10,1) / 1000);
VUR3:=MA((CLOSE * 3),5);
VUR4:=((((VUR2 * (CLOSE * 3)) / VUR3) * 1) / 10);
VUR5:=((((VUR2 * (OPEN * 3)) / VUR3) * 1) / 10);
VUR6:=((((VUR2 * (HIGH * 3)) / VUR3) * 1) / 10);
VUR7:=((((VUR2 * (LOW * 3)) / VUR3) * 1) / 10);
VUR8:=(((((2 * VUR5) + VUR6) + VUR7) + (3 * VUR4)) / 7);
VUR9:=EMA(DMA(EMA(VUR4,2),(SUM(VOL,1) * VUR8)),2);
VURA:=EMA((VUR1 - VUR9),1);
VU1:=IF((VURA > REF(VURA,1)),((VURA - REF(VURA,1)) * 15 / 1000),0);
VU2:=IF((VURA < REF(VURA,1)),((VURA - REF(VURA,1)) * 15 / 1000),0);
VU3:=SUM(VU1,15);
VU4:=EMA(VU3,10);
VU5:=REF(VU4,1);
VU6:=EMA(CLOSE,13);
VU7:=(VU6 < REF(VU6,1));
VU8:=(VU7 AND CROSS(VU4 > VU5,0.5));
VU9:=(SUM(VU2,21) * (0 - 1));
VUA:=EMA(EMA(VU9,5),8);
VUB:=REF(VUA,1);
进:=VU5;
出:=VUB;
XG1:出>进 AND VU8;

通达信猎人KDJ指标公式

 

相关文章