在线检测未来函数

通达信修改的成交量指标公式

来源:Internet,编辑:股旁网,2016-04-08

{使用说明:量柱上方.粉红色是三十日天量,黄色是六十日天量,绿色是一百日天量,蓝色是一年天量,量柱下方,粉红色是三十日地量,黄色是六十日地量,绿色是一百天地量,蓝色是一年地量,黄点是是当天总成交量的一半,黄点在红色处说明买多,在绿色处说明卖多。}

REFDATE(VOL,DATE),COLORFFFF00,LINETHICK1,DOTLINE;{收盘价水平线};
成交(亿):AMOUNT/100000000,POINTDOT;
VAR1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
买盘:IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE<OPEN,VAR1*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)),COLORRED,POINTDOT ;
卖盘:-IF(CLOSE>OPEN,0-VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-VAR1*(HIGH-LOW),0-VOL/2)),COLORGREEN,POINTDOT;
主动买盘:=IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE<OPEN,VAR1*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)),COLORRED,POINTDOT;
主动卖盘:=IF(CLOSE>OPEN,0-VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-VAR1*(HIGH-LOW),0-VOL/2)),COLOR00FF00,POINTDOT;
主买占%:主动买盘/VOL*100,NODRAW;
主卖占%:-主动卖盘/VOL*100,NODRAW;
净买:(买盘-卖盘),COLORRED,NODRAW;
A:=PERIOD;
N:=IF(A=0,1,IF(A=1,5,IF(A=2,15,IF(A=3,30,IF(A=4,60,IF(A=5,240,DRAWNULL))))));
M:=IF(N=1,IF(MOD(FROMOPEN,1)=0,1,
MOD(FROMOPEN,1)),IF(N=5,IF(MOD(FROMOPEN,5)=0,5,
MOD(FROMOPEN,5)),IF(N=15,IF(MOD(FROMOPEN,15)=0,15,
MOD(FROMOPEN,15)),IF(N=30,IF(MOD(FROMOPEN,30)=0,30,
MOD(FROMOPEN,30)),IF(N=60,IF(MOD(FROMOPEN,60)=0,60,
MOD(FROMOPEN,60)),IF(N=240,FROMOPEN,DRAWNULL))))));
倍率:主动买盘/ABS(主动卖盘),COLORCYAN,NODRAW;
成交:=VOL,POINTDOT;
主力持仓:EMA(100*(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)),3),COLORFF00FF;
获利比例:((WINNER(CLOSE))*(100)),COLORRED;
换手率:HSL,NODRAW;
五换:SUM(换手率,5),NODRAW;
十换:SUM(换手率,10),NODRAW;
量比:V/REF(V,1),COLORWHITE,NODRAW;
STICKLINE(VOL>0,VOL,0,3,0),COLOR006600;
STICKLINE(VOL>0,VOL,0,2,0),COLOR009900;
STICKLINE(VOL>0,VOL,0,1.1,0),COLOR00CC00;
STICKLINE(VOL>0,VOL,0,0.4,0),COLOR00FF00;
STICKLINE(买盘>0,0,买盘,3,0),COLOR000066;
STICKLINE(买盘>0,0,买盘,2,0),COLOR000099;
STICKLINE(买盘>0,0,买盘,1.1,0),COLOR0000CC;
STICKLINE(买盘>0,0,买盘,0.4,0),COLOR0000FF;
VAR2:=1*AMOUNT;
MA1:=1*MA(AMOUNT,5);
MA2:=1*MA(AMOUNT,10);
三十日天量:=HHV(VAR2,30)=VAR2;
六十日天量:=HHV(VAR2,60)=VAR2;
百日天量:=HHV(VAR2,100)=VAR2;
一年天量:=HHV(VAR2,250)=VAR2;
STICKLINE(三十日天量,VOL,VOL*0.9,1.6,0),COLORFF00FF;
STICKLINE(六十日天量,VOL,VOL*0.9,1.6,0),COLORYELLOW;
STICKLINE(百日天量,VOL,VOL*0.9,1.6,0),COLORFFFFFF;
STICKLINE(一年天量,VOL,VOL*0.9,1.6,0),COLORFF0000;
三十日地量:=LLV(VAR2,30)=VAR2;
六十日地量:=LLV(VAR2,60)=VAR2;
百日地量:=LLV(VAR2,100)=VAR2;
一年地量:=LLV(VAR2,250)=VAR2;
STICKLINE(三十日地量,0,20000,0.2,0),COLORC08000;
STICKLINE(六十日地量,0,20000,0.2,0),COLORYELLOW;
STICKLINE(百日地量,0,20000,0.2,0),COLORFFFFFF;
STICKLINE(一年地量,0,20000,0.2,0),COLORFF0000;
DRAWTEXT_FIX(ISLASTBAR ,0.0,0,0, '量柱上方'),COLOR0080FF;
DRAWTEXT_FIX(ISLASTBAR ,0.04,0,0,'三十日天量'),COLORFF00FF;
DRAWTEXT_FIX(ISLASTBAR ,0.09,0,0,'六十日天量'),COLOR00FFFF;
DRAWTEXT_FIX(ISLASTBAR ,0.14,0,0,'一百日天量'),COLORFFFFFF;
DRAWTEXT_FIX(ISLASTBAR ,0.19,0,0,'一年天量'),COLORFF0000;
DRAWTEXT_FIX(ISLASTBAR ,0.0,0.15,0, '量柱下方'),COLOR0080FF;
DRAWTEXT_FIX(ISLASTBAR ,0.04,0.15,0,'三十日地量'),COLORC08000;
DRAWTEXT_FIX(ISLASTBAR ,0.09,0.15,0,'六十日地量'),COLOR00FFFF;
DRAWTEXT_FIX(ISLASTBAR ,0.14,0.15,0,'一百日地量'),COLORFFFFFF;
DRAWTEXT_FIX(ISLASTBAR ,0.19,0.15,0,'一年地量'),COLORFF0000;
V5:MA(VOL,5),COLOR0000FF,LINETHICK2;
V10:MA(VOL,10),COLOR00FFFF,LINETHICK2;
中间价:VOL/2,LINETHICK4,POINTDOT,COLOR00FFFF;

通达信修改的成交量指标公式

 

相关文章