在线检测未来函数

通达信KDJ全背离指标公式

来源:Internet,编辑:股旁网,2016-04-11

DRAWGBK(C>0, RGB(1,1,1),RGB(1,1,1),0,'0',0);
STICKLINE(C>0,120,120,28,-1)COLORBLACK;
STICKLINE(C>0,100,100,28,-1)COLOR000080;
STICKLINE(C>0,80,80,28,-1)COLOR000080;
STICKLINE(C>0,50,50,28,-1)COLOR000080;
STICKLINE(C>0,20,20,28,-1)COLOR000080;
STICKLINE(C>0,0,0,28,-1)COLOR000080;
STICKLINE(C>0,-20,-20,28,-1)COLORBLACK;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:SMA(RSV,3,1)COLORCYAN;
D:SMA(K,3,1)COLORYELLOW;
J:3*K-2*D,COLORMAGENTA;
{K值,D值,J值的背离}
{------------------------------------------------------------------------------}
N:=5;
{}
J底背:REF(C,BARSLAST(REF(FILTER(BACKSET(REF(KDJ.J,N)=LLV(KDJ.J,2*N+1),N+1),N) AND KDJ.J=LLV(KDJ.J,N+1),1))+1)>C AND
REF(KDJ.J,BARSLAST(REF(FILTER(BACKSET(REF(KDJ.J,N)=LLV(KDJ.J,2*N+1),N+1),N) AND KDJ.J=LLV(KDJ.J,N+1),1))+1)<KDJ.J AND
FILTER(BACKSET(REF(KDJ.J,N)=LLV(KDJ.J,2*N+1),N+1),N) AND KDJ.J=LLV(KDJ.J,N+1),COLORWHITE,NODRAW;
DRAWLINE(FILTER(BACKSET(REF(KDJ.J,N)=LLV(KDJ.J,2*N+1),N+1),N) AND KDJ.J=LLV(KDJ.J,N+1),KDJ.J,FILTER(J底背>0,5),KDJ.J,0),
COLORWHITE,DOTLINE;
DRAWTEXT(J底背,KDJ.J,'J底背'),COLORLIMAGENTA;
J顶背:REF(C,BARSLAST(REF(FILTER(BACKSET(REF(KDJ.J,N)=HHV(KDJ.J,2*N+1),N+1),N) AND KDJ.J=HHV(KDJ.J,N+1),1))+1)<C AND
REF(KDJ.J,BARSLAST(REF(FILTER(BACKSET(REF(KDJ.J,N)=HHV(KDJ.J,2*N+1),N+1),N) AND KDJ.J=HHV(KDJ.J,N+1),1))+1)>KDJ.J AND
FILTER(BACKSET(REF(KDJ.J,N)=HHV(KDJ.J,2*N+1),N+1),N) AND KDJ.J=HHV(KDJ.J,N+1),COLORGREEN,NODRAW;
DRAWLINE(FILTER(BACKSET(REF(KDJ.J,N)=HHV(KDJ.J,2*N+1),N+1),N) AND KDJ.J=HHV(KDJ.J,N+1),KDJ.J,FILTER(J顶背>0,5),KDJ.J,0),
COLORGREEN,DOTLINE;
DRAWTEXT(J顶背,KDJ.J,'J顶背'),COLORMAGENTA;
{------------------------------------------------------------------------------}
K底背:REF(C,BARSLAST(REF(FILTER(BACKSET(REF(KDJ.K,N)=LLV(KDJ.K,2*N+1),N+1),N) AND KDJ.K=LLV(KDJ.K,N+1),1))+1)>C AND
REF(KDJ.K,BARSLAST(REF(FILTER(BACKSET(REF(KDJ.K,N)=LLV(KDJ.K,2*N+1),N+1),N) AND KDJ.K=LLV(KDJ.K,N+1),1))+1)<KDJ.K AND
FILTER(BACKSET(REF(KDJ.K,N)=LLV(KDJ.K,2*N+1),N+1),N) AND KDJ.K=LLV(KDJ.K,N+1),COLORWHITE,NODRAW;
DRAWLINE(FILTER(BACKSET(REF(KDJ.K,N)=LLV(KDJ.K,2*N+1),N+1),N) AND KDJ.K=LLV(KDJ.K,N+1),KDJ.K,FILTER(K底背>0,5),KDJ.K,0),
COLORWHITE,DOTLINE;
DRAWTEXT(K底背,KDJ.K,'K底背'),COLORWHITE;
K顶背:REF(C,BARSLAST(REF(FILTER(BACKSET(REF(KDJ.K,N)=HHV(KDJ.K,2*N+1),N+1),N) AND KDJ.K=HHV(KDJ.K,N+1),1))+1)<C AND
REF(KDJ.K,BARSLAST(REF(FILTER(BACKSET(REF(KDJ.K,N)=HHV(KDJ.K,2*N+1),N+1),N) AND KDJ.K=HHV(KDJ.K,N+1),1))+1)>KDJ.K AND
FILTER(BACKSET(REF(KDJ.K,N)=HHV(KDJ.K,2*N+1),N+1),N) AND KDJ.K=HHV(KDJ.K,N+1),COLORGREEN,NODRAW;
DRAWLINE(FILTER(BACKSET(REF(KDJ.K,N)=HHV(KDJ.K,2*N+1),N+1),N) AND KDJ.K=HHV(KDJ.K,N+1),KDJ.K,FILTER(K顶背>0,5),KDJ.K,0),
COLORGREEN,DOTLINE;
DRAWTEXT(K顶背,KDJ.K,'K顶背'),COLORLIBLUE;
{------------------------------------------------------------------------------}
D底背:REF(C,BARSLAST(REF(FILTER(BACKSET(REF(KDJ.D,N)=LLV(KDJ.D,2*N+1),N+1),N) AND KDJ.D=LLV(KDJ.D,N+1),1))+1)>C AND
REF(KDJ.D,BARSLAST(REF(FILTER(BACKSET(REF(KDJ.D,N)=LLV(KDJ.D,2*N+1),N+1),N) AND KDJ.D=LLV(KDJ.D,N+1),1))+1)<KDJ.D AND
FILTER(BACKSET(REF(KDJ.D,N)=LLV(KDJ.D,2*N+1),N+1),N) AND KDJ.D=LLV(KDJ.D,N+1),COLORWHITE,NODRAW;
DRAWLINE(FILTER(BACKSET(REF(KDJ.D,N)=LLV(KDJ.D,2*N+1),N+1),N) AND KDJ.D=LLV(KDJ.D,N+1),KDJ.D,FILTER(D底背>0,5),KDJ.D,0),
COLORWHITE,DOTLINE;
DRAWTEXT(D底背,KDJ.D,'D底背'),COLORYELLOW;
D顶背:REF(C,BARSLAST(REF(FILTER(BACKSET(REF(KDJ.D,N)=HHV(KDJ.D,2*N+1),N+1),N) AND KDJ.D=HHV(KDJ.D,N+1),1))+1)<C AND
REF(KDJ.D,BARSLAST(REF(FILTER(BACKSET(REF(KDJ.D,N)=HHV(KDJ.D,2*N+1),N+1),N) AND KDJ.D=HHV(KDJ.D,N+1),1))+1)>KDJ.D AND
FILTER(BACKSET(REF(KDJ.D,N)=HHV(KDJ.D,2*N+1),N+1),N) AND KDJ.D=HHV(KDJ.D,N+1),COLORGREEN,NODRAW;
DRAWLINE(FILTER(BACKSET(REF(KDJ.D,N)=HHV(KDJ.D,2*N+1),N+1),N) AND KDJ.D=HHV(KDJ.D,N+1),KDJ.D,FILTER(D顶背>0,5),KDJ.D,0),
COLORGREEN,DOTLINE;
DRAWTEXT(D顶背,KDJ.D,'D顶背'),COLOR4080FF;
{以下是金叉死叉背离}
{}
A2:=BARSLAST(REF(CROSS(K,D),1));
B2:=REF(C,A2+1)>C AND REF(K,A2+1)<K AND CROSS(K,D);
DRAWTEXT((B2>0),-10,'_金叉底背'),COLORLIRED;
STICKLINE((B2>0),-10,50,0,-1)COLORLIRED;
{DRAWLINE((B2>0),K,B2,K,0),COLORLIRED,DOTLINE;}{金叉底背画线};
{}
C2:=BARSLAST(REF(CROSS(D,K),1));
D2:=REF(C,C2+1)<C AND REF(K,C2+1)>K AND CROSS(D,K);
DRAWTEXT((D2>0),110,'_死叉顶背'),COLORLICYAN;
STICKLINE((D2>0),110,50,0,-1)COLORLICYAN;
{DRAWLINE((D2>0),K,D2,K,0),COLORGREEN,DOTLINE;}{死叉顶背画线};

通达信KDJ全背离指标公式

 

相关文章