在线检测未来函数

通达信黑马王子黃金柱主图指标公式

来源:Internet,编辑:股旁网,2016-04-12

B1:=MA(CLOSE,1);
B2:=SMA(SMA(SMA(B1,2,1),2,1),2,1) ;
SMA2:=MA(B2,5) ;
DRAWBAND(B2,RGB(180,0,180),SMA2,RGB(256,100,100));
X:=21;
TTY:=H;
AAT:=REF(TTY,X)=HHV(TTY,2*X+1);
BBT:=FILTER(AAT,X);
CCT:=BACKSET(BBT,X+1);
HD10T:=FILTER(CCT,X);
AA1T:=REF(TTY,X)=LLV(TTY,2*X+1);
BB1T:=FILTER(AA1T,X);
CC1T:=BACKSET(BB1T,X+1);
LD10T:=FILTER(CC1T,X);
三日不破:=MIN(MIN(L,REF(L,1)),REF(L,2))>=REF(L,3);
三日量缩:=(MAX(MAX(V,REF(V,1)),REF(V,2))<REF(V,3));
三日价涨A:=C>=REF(C,1);
三日价涨B:=C<REF(C,1);
三日价涨C:=MIN(MIN(C,REF(C,1)),REF(C,2))>=REF(L,3);
TIM:=IF(DATE<1140214,1,0);
缩倍柱:=(VOL*1.95<=REF(VOL,1))*TIM;
百日低量:=(VOL=LLV(VOL,100))*TIM;
倍量柱:=C>REF(C,1)*1.04 AND (VOL>=1.9*REF(VOL,1))*TIM;
四日前倍量柱:=(REF(VOL,3)>1.9*REF(VOL,4))*TIM;
四日前高量柱:=(REF(VOL,3)>=REF(VOL,4) AND REF(VOL,3)<1.9*REF(VOL,4) AND 三日量缩)*TIM;
前三引用不成立:=COUNT(REF(四日前倍量柱,1) AND (REF(三日不破,1) OR REF(三日价涨C,1)),3)=0 AND COUNT(REF(四日前高量柱,1) AND
(REF(三日不破,1) OR REF(三日价涨C,1)),3)=0;
倍量黄金柱:=四日前倍量柱 AND 三日量缩 AND 三日不破 AND 三日价涨A AND 前三引用不成立;
高量黄金柱:=四日前高量柱 AND 三日量缩 AND 三日不破 AND 三日价涨A AND 前三引用不成立;
黄金柱:=倍量黄金柱 OR 高量黄金柱;
次倍量黄金柱:=NOT(黄金柱) AND 四日前倍量柱 AND 三日量缩 AND 三日不破 AND 三日价涨B AND 前三引用不成立;
次高量黄金柱:=NOT(黄金柱) AND 四日前高量柱 AND 三日量缩 AND 三日不破 AND 三日价涨B AND 前三引用不成立;
次黄金柱:=次倍量黄金柱 OR 次高量黄金柱;
准倍量黄金柱:=NOT(黄金柱 OR 次黄金柱) AND 四日前倍量柱 AND ((三日量缩 AND 三日价涨C) OR (COUNT(倍量柱,3)>=1 AND 三日不破))
AND 前三引用不成立;
准高量黄金柱:=NOT(黄金柱 OR 次黄金柱) AND 四日前高量柱 AND (三日量缩 AND 三日价涨C) AND 前三引用不成立;
准黄金柱:=准倍量黄金柱 OR 准高量黄金柱;
倍量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱) AND 四日前倍量柱 AND 三日不破 AND 三日价涨A AND 前三引用不成立;
高量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱) AND 四日前高量柱 AND 三日不破 AND 三日价涨A AND 前三引用不成立;
将军柱:=倍量将军柱 OR 高量将军柱;
次倍量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱 OR 将军柱) AND 四日前倍量柱 AND 三日不破 AND 三日价涨B AND 前三引用不成立;
次高量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱 OR 将军柱) AND 四日前高量柱 AND 三日不破 AND 三日价涨B AND 前三引用不成立;
次将军柱:=次倍量将军柱 OR 次高量将军柱;
准倍量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱 OR 将军柱 OR 次将军柱) AND 四日前倍量柱 AND 三日价涨C AND 前三引用不成立;
准高量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱 OR 将军柱 OR 次将军柱) AND 四日前高量柱 AND 三日价涨C AND 前三引用不成立;
准将军柱:=准倍量将军柱 OR 准高量将军柱;
BACKSET100:=BACKSET(黄金柱 OR 次黄金柱 OR 准黄金柱 OR 将军柱 OR 次将军柱 OR 准将军柱,4);
FILTER100:=FILTER(BACKSET100,3);
BACKSET101:=BACKSET(黄金柱,4);
FILTER101:=FILTER(BACKSET101,3);
BACKSET102:=BACKSET(次黄金柱,4);
FILTER102:=FILTER(BACKSET102,3);
BACKSET103:=BACKSET(准黄金柱,4);
FILTER103:=FILTER(BACKSET103,3);
BACKSET104:=BACKSET(将军柱,4);
FILTER104:=FILTER(BACKSET104,3);
BACKSET105:=BACKSET(次将军柱,4);
FILTER105:=FILTER(BACKSET105,3);
BACKSET106:=BACKSET(准将军柱,4);
FILTER106:=FILTER(BACKSET106,3);
{重绘K线}
DRAWKLINE(H,O,L,C);
{重绘K线 显示大阳\大阴\涨停\跌停\假阴,适用于通达信}
RC1:=REF(C,1);
涨停率10:=10-1/RC1;{178448-WEN98编写}
涨停率5:=5-1/RC1;
比前涨率:=(C-RC1)*100/RC1;
比前跌率:=(RC1-C)*100/RC1;
ST:=NAMELIKE('ST') OR NAMELIKE('*ST');
涨停:= IF(ST, (比前涨率>=涨停率5), (比前涨率>=涨停率10));
本日涨率:=(C-O)*100/O;
本日跌率:=(O-C)*100/O;
STICKLINE((H-RC1)*100/RC1>=涨停率10,H,MAX(C,O),1,0),COLORYELLOW;{涨停后回落}
STICKLINE((RC1-L)*100/RC1>=涨停率10,L,MIN(C,O),1,0),COLORBLUE;{跌停后回升}
跌停:= IF(NAMELIKE('ST'), (比前跌率>=涨停率5), (比前跌率>=涨停率10));
STICKLINE(跌停,O,C,2,0),COLORLIBLUE;
大阳线:=C>O AND (比前涨率>=涨停率5 OR 本日涨率>=涨停率5)
AND 比前涨率<涨停率10 AND 涨停=0;
STICKLINE(大阳线,O,C,1,0),COLORFF99FF;
大阴线:=C<O AND (比前跌率>=涨停率5 OR 本日跌率>=涨停率5)
AND 比前跌率<涨停率10 AND 跌停=0;
STICKLINE(大阴线,O,C,1,0),COLOR006633;
{假阴柱}
假阴:=C<O AND C>REF(C,1);
STICKLINE(假阴,O,C,1,0),COLORRED;
{假阳柱}
假阳:=C>O AND C<REF(C,1);
STICKLINE(假阳,O,C,1,0),COLORGREEN;
{涨停}
AAAA:=CLOSE/REF(C,1)>=1.09;
STICKLINE(AAAA,O,C,1,0),COLORYELLOW;
STICKLINE(AAAA,L,H,1,0),COLORYELLOW;
{跌停}
STICKLINE(CLOSE<REF(CLOSE,1)*0.9015 AND CLOSE=LOW,CLOSE,OPEN,1,0),COLORBLUE;
DRAWTEXT(FILTER101,LOW*0.986,'↖黄金柱'),COLORYELLOW;
STICKLINE(FILTER101,OPEN,CLOSE,0.5,0),COLORYELLOW;
DRAWTEXT(FILTER102,LOW*0.986,'↖次黄'){,COLORFF00FF},COLORYELLOW;
STICKLINE(FILTER102,OPEN,CLOSE,0.5,0),COLORYELLOW;
DRAWTEXT(FILTER103,LOW*0.986,'↖准黄'),COLORFF00FF{,COLORYELLOW};
STICKLINE(FILTER103,OPEN,CLOSE,0.5,0),COLORYELLOW;
DRAWTEXT(FILTER104,LOW*0.986,'↖将军柱'),COLORRED;
STICKLINE(FILTER104,OPEN,CLOSE,0.5,0),COLORYELLOW;
DRAWTEXT(FILTER105,LOW*0.986,'↖次将'),COLORFF00FF{,COLORYELLOW};
STICKLINE(FILTER105,OPEN,CLOSE,0.5,0),COLORYELLOW;
DRAWTEXT(FILTER106,LOW*0.986,'↖准将'),COLORFF00FF{,COLORYELLOW};
STICKLINE(FILTER106,OPEN,CLOSE,0.5,0),COLORYELLOW;
立桩量:=VOL=HHV(VOL,40) AND VOL>1.9*REF(VOL,1);
立桩量三日突破:=IF(BARSLAST(立桩量)=1 AND CLOSE>REF(HIGH,1),1,IF(BARSLAST(立桩量)=2 AND CLOSE>REF(HIGH,2),1,IF(BARSLAST(立桩
量)=3 AND CLOSE>REF(HIGH,3),1,0)));
立桩量三日不破:=BARSLAST(立桩量)=3 AND REF(LOW,3)<=MIN(MIN(C,REF(C,1)),REF(C,2));
BACKSET300:=BACKSET(立桩量三日不破,4);
BACKSET301:=BACKSET(立桩量三日突破,4);
立桩量成立:=FILTER(BACKSET300,3) AND BACKSET301 AND 立桩量;
DRAWTEXT(立桩量成立,HIGH,'←立柱'),COLORGREEN;
MA5:=MA(CLOSE,5);
MA10:=MA(CLOSE,10);
MA30:=MA(CLOSE,30);
MA60:=MA(CLOSE,60);
MA120:=MA(CLOSE,120);
MA240:=MA(CLOSE,240);
AA1:=BARSLAST(MA60>MA30 AND (MA30=MA10 OR MA30>MA10));
BB1:=REF(COUNT(C<MA60,AA1)=AA1,1);
CC1:=CROSS(C,MA60) AND VOL>MA(VOL,5) AND (C-REF(C,1))/REF(C,1)*100>3;
芙蓉出水:=BB1 AND CC1;
DRAWTEXT(芙蓉出水,H,'芙蓉出水'),COLORFF00FF;
STICKLINE(芙蓉出水,H,L,0.1,0),COLORFF00FF;
STICKLINE(芙蓉出水,O,C,1.1,1),LINETHICK2,COLORFF00FF;
MA1:=MA(CLOSE,5);
MA2:=MA(CLOSE,10);
MA3:=MA(CLOSE,20);
ZJ:=AMOUNT/10000;
TM:=V-MA(V,10);
一穿三:=MA1>O AND MA2>O AND MA3>O AND MA1<C AND MA2<C AND MA3<C AND CLOSE>OPEN ;
DRAWTEXT(一穿三,L,'一穿三'),COLORFF00FF;
STICKLINE(一穿三,OPEN,CLOSE,1.1,0),COLORFF00FF;
{不会画线可以让显示}
{K1:=SUMBARS(FILTER104,1);
STICKLINE(K1,REF(L,K1-2),REF(L,K1-2),3,-1),COLORYELLOW;
STICKLINE(K1,REF(L,K1-1),REF(L,K1-1),3,-1),COLORGREEN;
K2:=SUMBARS(FILTER101,1);
STICKLINE(K2,REF(L,K2-2),REF(L,K2-2),3,-1),COLORYELLOW;};

通达信黑马王子黃金柱主图指标公式

 

相关文章