在线检测未来函数

同花顺主力顶底趋势指标公式

来源:Internet,编辑:股旁网,2016-04-19

A1:=(((2 * CLOSE) + HIGH) + LOW) / 4;
A2:=LLV(LOW,34);
A3:=HHV(HIGH,34);
A4:=EMA((((A1 - A2) / (A3 - A2)) * 100),13);
A5:=EMA(((0.667 * (REF(A4,1))) + (0.333 * A4)),2);
A6:=(HHV(HIGH,9)) - (LLV(LOW,9));
A7:=(HHV(HIGH,9)) - CLOSE;
A8:=CLOSE - (LLV(LOW,9));
A9:=((A7 / A6) * 100) - 70;
A10:=((CLOSE - (LLV(LOW,60))) / ((HHV(HIGH,60)) - (LLV(LOW,60)))) * 100;
A11:=SMA(((A8 / A6) * 100),3,1);
A12:=(SMA(A11,3,1)) - (SMA(A9,9,1));
A13:=IF((A12 > 100),(A12 - 100),0);
操作线:EMA((((A1 - A2) / (A3 - A2)) * 100),5),coloryellow,LINETHICK2;
趋势线:EMA(操作线,13),colorgreen,LINETHICK2;
主力加仓:STICKLINE(操作线>趋势线,操作线,趋势线,3,0),colorred;
主力减仓:STICKLINE(操作线<(REF(操作线,1)),操作线,趋势线,3,0),coloryellow;
主力出货:STICKLINE(操作线<趋势线,操作线,趋势线,3,0),colorblue;
弱势反弹:STICKLINE(操作线<趋势线 AND 操作线>(REF(操作线*0.95,1)),操作线,趋势线,3,0),COLORF0F000;
加仓:0,colorred;
震仓:0,coloryellow;
出货:0,colorblue;
反弹:0,COLORF0F000;
Q2:=(CLOSE-LLV(LOW, 18))/(HHV(HIGH, 18)-LLV(LOW, 18))*100;
Q3:=SMA(Q2, 9, 1);
Q4:=SMA(Q3, 3, 1);
VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
VAR12:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF (ZIG(3,22),2)<=REF(ZIG(3,22),3);
VAR14:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF (ZIG(3,22),2)>=REF(ZIG(3,22),3);
VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF (ZIG(3,51),2)<=REF(ZIG(3,51),3);
VAR16:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF (ZIG(3,51),2)>=REF(ZIG(3,51),3);
VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF (ZIG(3,72),2)<=REF(ZIG(3,72),3);
VAR18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF (ZIG(3,72),2)>=REF(ZIG(3,72),3);
VAR10:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);
买入:(VAR11+VAR13+VAR15+VAR17)*10,COLORFF00FF,LINETHICK2;
卖出:(VAR12+VAR14+VAR16+VAR18)*-10+100,COLOR00FF00,LINETHICK2;

同花顺主力顶底趋势指标公式

 

相关文章