在线检测未来函数

通达信CCI全背离指标公式

来源:Internet,编辑:股旁网,2016-04-17

{背景}
DRAWGBK(C>0, RGB(1,1,1),RGB(1,1,1),0,'0',0);
STICKLINE(C>0,-100,100,28,0)COLOR000840;
STICKLINE(C>0,200,200,28,-1)COLOR000080;
STICKLINE(C>0,100,100,28,-1)COLOR000080;
STICKLINE(C>0,-2.5,2.5,28,0)COLOR000080;
STICKLINE(C>0,-100,-100,28,-1)COLOR000080;
STICKLINE(C>0,-200,-200,28,-1)COLOR000080;
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14)),STICK;{CCI柱线}
趋势线:EXPMA(CCI,4.5),COLORFF8000,NODRAW;{CCI的5天EMA}
DRAWBAND(CCI,RGB(128,0,0),趋势线,RGB(0,128,0));
STICKLINE(CCI>=0,0,CCI,0,-1),COLORLIRED;{红柱}
STICKLINE(CCI<0,0,CCI,0,-1),COLORLIBLUE;{绿柱}
{CCI}
{TYP:=(HIGH+LOW+CLOSE)/3;}
CCI值:(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14)),COLORYELLOW,LINETHICK1;{CCI线}
DRAWTEXT(ISLASTBAR,CCI值,' ←CCI'),COLORYELLOW;
{CCI背离}
N:=5;
CCI底背:=REF(C,BARSLAST(REF(FILTER(BACKSET(REF(CCI,N)=LLV(CCI,2*N+1),N+1),N) AND CCI=LLV(CCI,N+1),1))+1)>C AND
REF(CCI,BARSLAST(REF(FILTER(BACKSET(REF(CCI,N)=LLV(CCI,2*N+1),N+1),N) AND CCI=LLV(CCI,N+1),1))+1)<CCI AND
FILTER(BACKSET(REF(CCI,N)=LLV(CCI,2*N+1),N+1),N) AND CCI=LLV(CCI,N+1),COLORWHITE,NODRAW;
DRAWLINE(FILTER(BACKSET(REF(CCI,N)=LLV(CCI,2*N+1),N+1),N) AND CCI=LLV(CCI,N+1),CCI,FILTER(CCI底背>0,5),CCI,0),
COLORWHITE,DOTLINE;
DRAWTEXT(CCI底背,CCI,'底背'),COLORWHITE;
CCI顶背:=REF(C,BARSLAST(REF(FILTER(BACKSET(REF(CCI,N)=HHV(CCI,2*N+1),N+1),N) AND CCI=HHV(CCI,N+1),1))+1)<C AND
REF(CCI,BARSLAST(REF(FILTER(BACKSET(REF(CCI,N)=HHV(CCI,2*N+1),N+1),N) AND CCI=HHV(CCI,N+1),1))+1)>CCI AND
FILTER(BACKSET(REF(CCI,N)=HHV(CCI,2*N+1),N+1),N) AND CCI=HHV(CCI,N+1),COLORGREEN,NODRAW;
DRAWLINE(FILTER(BACKSET(REF(CCI,N)=HHV(CCI,2*N+1),N+1),N) AND CCI=HHV(CCI,N+1),CCI,FILTER(CCI顶背>0,5),CCI,0),
COLORGREEN,DOTLINE;
DRAWTEXT(CCI顶背,CCI,'顶背'),COLORGREEN;
{趋势线的背离}
趋势线底背:=REF(C,BARSLAST(REF(FILTER(BACKSET(REF(趋势线,N)=LLV(趋势线,2*N+1),N+1),N) AND 趋势线=LLV(趋势线,N+1),1))+1)>C AND
REF(趋势线,BARSLAST(REF(FILTER(BACKSET(REF(趋势线,N)=LLV(趋势线,2*N+1),N+1),N) AND 趋势线=LLV(趋势线,N+1),1))+1)<趋势线 AND
FILTER(BACKSET(REF(趋势线,N)=LLV(趋势线,2*N+1),N+1),N) AND 趋势线=LLV(趋势线,N+1),COLORWHITE,NODRAW;
DRAWLINE(FILTER(BACKSET(REF(趋势线,N)=LLV(趋势线,2*N+1),N+1),N) AND 趋势线=LLV(趋势线,N+1),趋势线,FILTER(趋势线底背>0,5),趋势线,0),
COLORWHITE,DOTLINE;
DRAWTEXT(趋势线底背,趋势线,'趋势底背'),COLORFF80FF;
趋势线顶背:=REF(C,BARSLAST(REF(FILTER(BACKSET(REF(趋势线,N)=HHV(趋势线,2*N+1),N+1),N) AND 趋势线=HHV(趋势线,N+1),1))+1)<C AND
REF(趋势线,BARSLAST(REF(FILTER(BACKSET(REF(趋势线,N)=HHV(趋势线,2*N+1),N+1),N) AND 趋势线=HHV(趋势线,N+1),1))+1)>趋势线 AND
FILTER(BACKSET(REF(趋势线,N)=HHV(趋势线,2*N+1),N+1),N) AND 趋势线=HHV(趋势线,N+1),COLORGREEN,NODRAW;
DRAWLINE(FILTER(BACKSET(REF(趋势线,N)=HHV(趋势线,2*N+1),N+1),N) AND 趋势线=HHV(趋势线,N+1),趋势线,FILTER(趋势线顶背>0,5),趋势线,0),
COLORGREEN,DOTLINE;
DRAWTEXT(趋势线顶背,趋势线,'趋势顶背'),COLORFF8000;
{面积背离}
JC:= 0-CCI;
绿柱面积:=IF(CCI<0,SUM(CCI,BARSLAST(JC<0)),0);
红柱面积:=IF(CCI>0,SUM(CCI,BARSLAST(JC>0)),0);
本次最低价:=LLV(L,BARSLAST(JC<0));
本次最高价:=HHV(H,BARSLAST(JC>0));
X1:=IF (CCI<0,BARSLAST(CROSS(CCI,0)),0);
前次绿柱面积:=REF(绿柱面积,X1+1);
前次最低价:=REF(本次最低价,X1+1);
Y1:=IF((绿柱面积<0 AND ABS(绿柱面积)<ABS(前次绿柱面积) AND 本次最低价<前次最低价 ),1,0);
RS1:= CCI<0 AND REF(CCI,1)<0 AND C<前次最低价
AND ABS(绿柱面积)<ABS(前次绿柱面积) AND ABS(CCI)<ABS(REF(CCI,1));
底背驰:= IF (CROSS(CCI,0),REF(Y1,1),0);
DRAWTEXT(底背驰,LLV(CCI,5),'←面积底背'),COLORLIRED;
X2:=IF (CCI>0,BARSLAST(CROSS(0,CCI)),0);
前次红柱面积:=REF(红柱面积,X2+1);
前次最高价:=REF(本次最高价,X2+1);
Y2:=IF((红柱面积>0 AND 红柱面积<前次红柱面积 AND 本次最高价>前次最高价 ),1,0);
RS2:= CCI>0 AND REF(CCI,1)>0 AND C>前次最高价 AND ABS(红柱面积)<ABS(前次红柱面积) AND ABS(CCI)<ABS(REF(CCI,1));
顶背驰:= IF (CROSS(0,CCI),REF(Y2,1),0);
DRAWTEXT(顶背驰,HHV(CCI,5),'←面积顶背'),COLORCYAN;

通达信CCI全背离指标公式

 

相关文章