在线检测未来函数

通达信量价MACD金叉指标公式

来源:Internet,编辑:股旁网,2016-04-18

{均线}
JINCHA1:=CROSS(C,MA(C,5));
YANG:=CLOSE>OPEN;
{成交量}
FANGLIANG:=V>REF(V,1);
{OBV能量}
VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);
OBV:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0);
T1:=HHV(OBV,60);
T2:=REF(T1,1);
OBVXG:=OBV>T2;
{MACD}
DIF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=2*(DIF-DEA);
MACD2:=MACD>REF(MACD,1) AND MACD>0;
JINCHA2:=CROSS(DIF,DEA);
{量价MACD金叉}
量价MACD金叉:JINCHA1 AND FANGLIANG AND JINCHA2 AND OBVXG AND MACD2 AND YANG,COLORRED,NODRAW;
STICKLINE(量价MACD金叉,0,3,1,0),COLORRED;
DRAWTEXT(量价MACD金叉,2,'---金叉'),COLORYELLOW;

通达信量价MACD金叉指标公式

 

相关文章