在线检测未来函数

通达信凤凰成交量指标公式

来源:Internet,编辑:股旁网,2016-04-20

DRAWGBK(O>0,RGB(33,47,58),RGB(0,0,0),0,'02',0),LINETHICK2;
N1:=STRCAT(CON2STR(YEAR,0),' 年 ');
Y:=STRCAT(CON2STR(MONTH,0),' 月 ');
R:=STRCAT(CON2STR(DAY,0),' 日 ');
SJ:=STRCAT(STRCAT(N1,Y), R);
DRAWTEXT_FIX(C>0,0.68,0,0,SJ);
VOLUME:VOL,VOLSTICK;
主力启动线:MA(VOLUME,5),COLORRED,LINETHICK2;
主力洗盘线:MA(VOLUME,35),COLORE8E8E8,LINETHICK2;
资金异动线:MA(VOLUME,135),COLORBLUE,LINETHICK2;
DRAWICON(CROSS(主力启动线,主力洗盘线),主力启动线,11);
DRAWICON(CROSS(主力启动线,资金异动线),主力启动线,9);
DRAWICON(CROSS(主力洗盘线,资金异动线),主力洗盘线,18);
出击:STICKLINE(CROSS(主力启动线,资金异动线) OR ((主力洗盘线 > 资金异动线) AND CROSS(主力启动线,主力洗盘线)),0,VOL,2,0),COLORYELLOW;
启动:STICKLINE(主力启动线>REF(主力启动线,1) AND (CROSS(VOL,主力启动线) AND (REF(VOL,1)<REF(资金异动线,1) AND REF(VOL,2)<REF(资金异动线,2))),0,VOL,3,0),COLORGREEN;
V1:=CLOSE/REF(CLOSE,3)>=1.1;
V2:=BACKSET(V1,2);
V3:=REF(CLOSE,3)*1.1;
V4:=CROSS(C,V3);
OK:STICKLINE((V2 AND COUNT(V2,2)=1),VOL,0,5,0),COLORRED;
COND:(CROSS(主力启动线,资金异动线) OR ((主力洗盘线 > 资金异动线) AND CROSS(主力启动线,主力洗盘线)))
OR (主力启动线>REF(主力启动线,1) AND (CROSS(VOL,主力启动线) AND (REF(VOL,1)<REF(资金异动线,1) OR REF(VOL,2)<REF(资金异动线,2))))
OR (V2 AND COUNT(V2,2)=1),LINETHICK0;
H_L:=0.1*CONST(HHV(VOL,240));
V100:= V<=LLV(V,100)*1.2 AND V>0 AND BARSCOUNT(V)>=100;
百日地量群:=COUNT(V100,5)>=3;
DRAWTEXT(FILTER(百日地量群,4),V+3*H_L,'地量群'),COLORGRAY;
长阴短柱:=C/REF(C,1)<=0.96 AND V<HHV(V,30)/1.9;
DRAWTEXT(长阴短柱 ,V+1.6*H_L,'!'),COLORLICYAN;
获利比例:WINNER(C)*100,NODRAW;
DRAWTEXT_FIX(ISLASTBAR,0.5,0.5,0,STRCAT('获利比例:',CON2STR(获利比例,2)));
N:=120;
获利盘90均线:MA(COST(90),N);
获利盘50均线:MA(COST(50),N);
获利盘30均线:MA(COST(30),N);
获利盘10均线:MA(COST(10),N);
STICKLINE(V/REF(V,1)>2,V,0,3,0),COLORYELLOW;
STICKLINE(V/REF(V,1)>=6,V,0,3,0),COLORRED;
预定黄金柱: DRAWICON(REF(V,2)>=REF(V,3)*1.99 AND REF(C,2)>REF(O,2) AND
REF(V,2)=HHV(V,3) AND C/REF(C,2) >=1.0995 AND REF(L,2)=LLV(L,3),V,1);
缩量:COUNT(CLOSE>REF(CLOSE,1),2)=2 AND COUNT(VOL<REF(VOL,1),2)=2;
STICKLINE(缩量,0,V,1,0),COLORGREEN; DRAWTEXT(缩量,VOL+3000,'缩量'),COLORGREEN;
T:=DYNAINFO(8)>0; VO:VOL=LLV(VOL,100) AND T; 地量柱:T AND VO,COLORBLUE;
STICKLINE(地量柱,0,V,1,0),COLORBLUE; DRAWTEXT(地量柱,VOL+3000,'芝麻地量'),COLORBLUE;
BLZ:=VOL>REF(V,1)*1.9; BLZ1:=VOL<REF(LLV(VOL,13),1);
BLZ2:=VOL<REF(LLV(VOL,55),1);
STICKLINE(BLZ,0,V,1,0),COLORYELLOW; 倍量柱:BLZ,COLORYELLOW;
DRAWTEXT(倍量柱,VOL+3000,'倍'),COLORYELLOW; HJZ:=(3*C+H+L+O)/6;
HJZ2:=(8*HJZ+7*REF(HJZ,1)+6*REF(HJZ,2)+5*REF(HJZ,3)+4*REF(HJZ,4)+3*REF(HJZ,5)+2*REF(HJZ,6)+REF(HJZ,8))/36;
HJZ3:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>HJZ2 AND C>O;
黄金柱:FILTER(HJZ3,5),STICK,COLORRED,LINETHICK4; STICKLINE(黄金柱,0,V,1,0),COLORRED;
DRAWTEXT(黄金柱,VOL+10000,'黄'),COLORRED;
价涨量缩:缩量,COLORGREEN;
FLZ:=V>REF(V,1)*0.98 AND V<REF(V,1)*1.02,LINETHICK0;
STICKLINE(FLZ,0,V,1,0),COLORMAGENTA; DRAWTEXT(FLZ,VOL+3000,'平'),COLORMAGENTA;
平量柱:FLZ,COLORMAGENTA;
量柱:V/CAPITAL*100,VOLSTICK;
低量柱:=IF(V=LLV(V,10),9,8);
DRAWTEXT(低量柱>8,量柱*1.01,'凹口'),COLORYELLOW;
高量柱:=IF(V=HHV(V,10),3,2);
并肩平量柱:=IF((V/REF(V,1)>0.95 AND V/REF(V,1)<1.05),7,6);
缩量柱:=IF(V<REF(V,1) AND REF(V,1)<REF(V,2) AND REF(V,2)<REF(V,3),25,35);
梯量柱:=IF(V>REF(V,1) AND REF(V,1)>REF(V,2) AND REF(V,2)>REF(V,3),11,10);
DRAWTEXT(倍量柱>0,量柱*0.99,'倍');
DRAWTEXT(高量柱>2,量柱*0.85,'高');
DRAWTEXT(并肩平量柱>6,量柱*0.7,'平');
DRAWTEXT(梯量柱>10,量柱*0.55,'梯');

通达信凤凰成交量指标公式

 

相关文章