在线检测未来函数

大智慧精华组合主图指标公式

来源:Internet,编辑:股旁网,2016-04-21

N:=5;
Var1:=(2*CLOSE+HIGH+LOW+OPEN)/5;
M1: (EMA(Var1,3)+EMA(Var1,6)+EMA(Var1,12)+EMA(Var1,24))/4,colorFF6633,LINETHICK0,PRECIS2;
M2: EMA(M1,2),PRECIS2,COLOR009900,LINETHICK0;
M3: EMA(M2,2),PRECIS2,COLOR00CC00,LINETHICK0;
M4: EMA(M3,2),PRECIS2,COLOR00FF00,LINETHICK0;
M5: EMA(M4,2),PRECIS2,COLOR00FF99,LINETHICK0;
M6: EMA(M5,2),PRECIS2,COLORCCFF99,LINETHICK0;
M7: EMA(M6,2),PRECIS2,COLOR9900FF,LINETHICK0;
M8: EMA(Var1,2.78)*1.028,colorwhite,LINETHICK2,PRECIS2;
M9: MA(OPEN,3.2)*1.028,coloryellow,LINETHICK2,PRECIS2;
安全线: EMA(CLOSE,55), POINTDOT,LINETHICK0,colorRED,PRECIS2;
PARTLINE(安全线,安全线>=REF(安全线,1),RGB(255,0,0),安全线<=REF(安全线,1),RGB(0,255,0)),POINTDOT,LINETHICK3;
PARTLINE(M1,M1>=REF(M1,1),RGB(255,0,0),M1<=REF(M1,1),RGB(0,255,0)),LINETHICK2;
PARTLINE(M2,M2>=REF(M2,1),RGB(255,0,0),M2<=REF(M2,1),RGB(0,255,0)),LINETHICK1;
PARTLINE(M3,M3>=REF(M3,1),RGB(255,0,0),M3<=REF(M3,1),RGB(0,255,0)),LINETHICK1;
PARTLINE(M4,M4>=REF(M4,1),RGB(255,0,0),M4<=REF(M4,1),RGB(0,255,0)),LINETHICK1;
PARTLINE(M5,M5>=REF(M5,1),RGB(255,0,0),M5<=REF(M5,1),RGB(0,255,0)),LINETHICK1;
PARTLINE(M6,M6>=REF(M6,1),RGB(255,0,0),M6<=REF(M6,1),RGB(0,255,0)),LINETHICK1;
PARTLINE(M7,M7>=REF(M7,1),RGB(255,0,0),M7<=REF(M7,1),RGB(0,255,0)),LINETHICK1;
主筹估算:=EMA(WINNER(c)*70,3);
散筹估算:=EMA((WINNER((c)*1.1)-WINNER((c)*0.9))*70,3);
筹码锁定:=散筹估算-主筹估算 ;
动态底部:=EMA(IF(L<= LLV(l,60),SMA(ABS(L-REF(L,1)),60,1)/SMA(MAX(L-REF(l,1),0),99,1),0)*5,3);
涨:=CROSS(主筹估算,筹码锁定);
强:=CROSS(主筹估算,散筹估算);
STICKLINE(涨,O,C,4,0),COLORYELLOW;
STICKLINE(涨,O,H,0,0),COLORYELLOW;
STICKLINE(涨,L,C,0,0),COLORYELLOW;
STICKLINE(强, O,C,4,0),colormagenta;
STICKLINE(强,O,H,0,0),colormagenta;
STICKLINE(强,L,C,0,0),colormagenta;
STICKLINE(筹码锁定<-50,O,C,4,0),COLORred;
STICKLINE(筹码锁定<-50,O,H,0,0),COLORred;
STICKLINE(筹码锁定<-50,L,C,0,0),COLORred;
A1:=ref(h,N)=hhv(h,2*N+1);
B1:=filter(A1,N);
C1:=backset(B1,N+1);
D1:=filter(C1,n);{高点}
A2:=ref(l,N)=llv(l,2*N+1);
B2:=filter(A2,N);
C2:=backset(B2,N+1);
D2:=filter(C2,N);{低点}
E1:=(ref(llv(l,2*N),1)+ref(hhv(h,2*N),1))/2; E2:=(h+l)/2;{高低点出现在同一K线上时可作取舍}
H1:=(D1 AND not(D2 AND E1>=E2)) OR barstatus=2 OR barscount(c)=1;
L1:=(D2 AND not(D1 AND E1<E2)); H2:=D1 AND not(D2 AND E1>=E2);
X1:=ref(barslast(H1),1)+1; F1:=backset(H1 AND count(L1,X1)>0,llvbars
(if(L1,l,10000),X1));
G1:=F1>ref(F1,1); I1:=backset(G1,2); LD:=I1>ref(I1,1);{过滤后低点}
L2:=LD OR barstatus=2 OR barscount(c)=1;
X2:=ref(barslast(L2),1)+1; F2:=backset(L2 AND count(H2,X2)>0,hhvbars
(if(H2,h,0),X2));
G2:=F2>ref(F2,1); I2:=backset(G2,2); HD:=I2>ref(I2,1);{过滤后高点}
R1:=backset(barstatus=2,barslast(HD)+1); S1:=R1>ref(R1,1); {前一高}
T1:=backset(barstatus=2,barslast(LD)+1); U1:=T1>ref(T1,1); {前一低}
R2:=backset(S1,ref(barslast(HD),1)+2); S2:=R2>ref(R2,1); {前二高}
T2:=backset(U1,ref(barslast(LD),1)+2); U2:=T2>ref(T2,1); {前二低}
T3:=backset(U2,ref(barslast(LD),1)+2); U3:=T3>ref(T3,1); {前三低}
T4:=backset(U3,ref(barslast(LD),1)+2); U4:=T4>ref(T4,1); {前四低}
R3:=backset(S2,ref(barslast(HD),1)+2); S3:=R3>ref(R3,1); {前三高}
R4:=backset(S3,ref(barslast(HD),1)+2); S4:=R4>ref(R4,1); {前四高}
短期压力:drawline(S2,h,S1,h,1),Colorred;
短期支撑:drawline(U2,l,U1,l,1),Colorgreen;
中期压力:drawline(S3,h,S2,h,1),Coloryellow;
中期支撑:drawline(U3,l,U2,l,0),Colorgreen;
长期压力:drawline(S4,h,S3,h,1),COLORwhite;
长期支撑:drawline(U4,l,U3,l,0),Colorgreen;
DRAWICON(S1,H*1.01,10);
DRAWICON(S2,H*1.01,10);
DRAWICON(S3,H*1.01,10);
DRAWICON(S4,H*1.01,10);
DRAWICON(U1,L*0.99,9);
DRAWICON(U2,L*0.99,9);
DRAWICON(U3,L*0.99,9);
DRAWICON(U4,L*0.99,9);
if DISPSTATUS=2 then aaa:=BARPOS;
if DISPSTATUS=1 then bbb:=BARPOS;
ddd:=aaa-bbb;
if DISPSTATUS=2 then aaa:=BARPOS;
if DISPSTATUS=1 then bbb:=BARPOS;
ddd:=aaa-bbb;
hh:=hhv(h,ddd);;
ll:=llv(l,ddd);
e:=(hh-ll)/100;
RH:=H-L;
R:=DYNAINFO(13)*100;
反压线:HHV(FORCAST(C,9),18),coloree8fff,linethick1;
gj:=if(c=INDEXC,(INDEXC+INDEXh+INDEXl+INDEXO)/4,AMOUNT/(v+0.01)/100);
明日阻力:=l+(gj-l)+(c-l);
明日支撑:=l+(c-gj);
今日阻力:=REF(明日阻力 , 1);
今日支撑:=REF(明日支撑 , 1);
STICKLINE(BARSTATUS=2 and c>=今日阻力,今日阻力,今日阻力,30,0),Color0000FF;
STICKLINE(BARSTATUS=2 and c<今日阻力,今日阻力,今日阻力,30,0),Color00FF00;
STICKLINE(BARSTATUS=2 and c>=今日支撑,今日支撑,今日支撑,30,0),ColorFF00FF;
STICKLINE(BARSTATUS=2 and c<今日支撑,今日支撑,今日支撑,30,0),ColorFF8800;
DRAWTEXT(BARSTATUS=2 ,hh,'---------------------------------- '),ColorFFFFFF,align2;
DRAWTEXT(BARSTATUS=2 and c>=今日支撑,hh-3*e,' 今日支撑=:'+NUMTOSTRN(今日支撑 ,2)+' ' ),ColorFF00FF,align2;
DRAWTEXT(BARSTATUS=2 and c<今日支撑,hh-3*e,' 今日支撑=:'+NUMTOSTRN(今日支撑 ,2 )+' '),ColorFF8800,align2;
DRAWTEXT(BARSTATUS=2 and c>=今日阻力,hh-7*e,' 今日阻力=:'+NUMTOSTRN(今日阻力 ,2 )+' '),Color0000FF,align2;
DRAWTEXT(BARSTATUS=2 and c<今日阻力,hh-7*e,' 今日阻力=:'+NUMTOSTRN(今日阻力 ,2 )+' '),Color00FF00,align2;
DRAWTEXT(BARSTATUS=2 ,hh-3*e,' 明日阻力=:'+NUMTOSTRN(明日阻力 ,2 )+' '),Coloryellow,align2;
DRAWTEXT(BARSTATUS=2 ,hh-7*e,' 明日支撑=:'+NUMTOSTRN(明日支撑 ,2 )+' '),Coloryellow,align2;
DRAWTEXT(BARSTATUS=2 ,hh-10*e,'---------------------------------- '),ColorFFFFFF,align2;
DRAWTEXT(BARSTATUS=2 and v>ref(v,1) and ma(v,5)>ref(ma(v,5),1),hh-13*e,'今日成交量大于昨日,且有继续增大趋势'+' '),Color8285FF,align2;
DRAWTEXT(BARSTATUS=2 and v<ref(v,1) and ma(v,5)>ref(ma(v,5),1),hh-13*e,'今日成交量小于昨日,但有放大迹象'+' '),Color8285FF,align2;
DRAWTEXT(BARSTATUS=2 and v>ref(v,1)and ma(v,5)<ref(ma(v,5),1),hh-13*e,'今日成交量大于昨日, 但有缩小迹象'+' '),Color8285FF,align2;
DRAWTEXT(BARSTATUS=2 and v<ref(v,1)and ma(v,5)<ref(ma(v,5),1),hh-13*e,'今日成交量小于昨日,且有缩小迹象'+' '),Color8285FF,align2;
A4:=MA(CLOSE,20);
A5:=(CLOSE > MA(CLOSE,5));
A6:=(MA(CLOSE,5) > MA(CLOSE,10));
A7:=(CLOSE > MA(CLOSE,10));
A8:=(MA(CLOSE,5) > MA(CLOSE,20));
A9:=(CLOSE > MA(CLOSE,20));
A10:=REF(A4,1);
A11:=(A4 > A10);
AVX:=(((((IF(A5,10,(0 - 10)) + IF(A6,10,(0 - 10))) + IF(A7,10,(0 - 10))) + IF(A8,10,(0 - 10))) + IF(A9,10,(0 - 10))) + IF(A11,10,(0 - 10)));
DSLX:=(CLOSE / INDEXC);
DSLX1:=MA(DSLX,5);
DSLX2:=MA(DSLX,10);
V1:=MA(VOL,5);
V2:=MA(VOL,10);
mc:=REF(c,1);
TJTS1:=BARSTATUS=2 and c<200;
TJTS2:=BARSTATUS=2 and c>200;
T := BARSLAST(DISPSTATUS=1)+1;
HHg := HHV(H, T);
ddg := LLV(L, T);
{Hk := LL-HH; G12 := LL-HK*1.55; }
k2:=hhv(h*1.03,barslast(DISPSTATUS=1)+1);
DRAWTEXT(TJTS1 and ((CROSS(AVX,1) AND (V1 >= V2)) AND (DSLX >= DSLX1)) ,k2*0.99,'★该股的量能理想,有明显走强迹象,可以考虑中线进场参与,仓位在2/3左右。 '),ALIGN2,color0000FF,LINETHICK2;
DRAWTEXT(TJTS1 and ((CROSS(AVX,1) AND (V1 < V2)) AND (DSLX >= DSLX1)) ,k2*0.99,'★该股虽然走势趋强,但量能还显不足,可以考虑短线进场,仓位在1/2左右。 '),ALIGN2,color0000FF,LINETHICK2;
DRAWTEXT(TJTS1 and ((CROSS(AVX,1) AND (V1 > V2)) AND (DSLX < DSLX1)) ,k2*0.99,'★该股量价配合良好,但相对其它股票并没有明显走强,可以考虑短线进场,仓位1/2左右。 '),ALIGN2,color0000FF,LINETHICK2;
DRAWTEXT(TJTS1 and ((CROSS(AVX,1) AND (V1 <= V2)) AND (DSLX < DSLX1)) ,k2*0.99,'★该股形态尚可,但量能不足,股票也未完全走强,可以短线参与,仓位1/3左右。 '),ALIGN2,color0000FF,LINETHICK2;
DRAWTEXT(TJTS1 and ((CROSS(1,AVX) AND (V1 >= V2)) AND (DSLX >= DSLX1)) ,k2*0.99,'★该股形态变坏,但走势相对其它股票尚可,重仓者减持大半,清仓者可以观望。 '),ALIGN2,color00FF00,LINETHICK2;
DRAWTEXT(TJTS1 and ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX >= DSLX1)) ,k2*0.99,'★该股随大盘一起下跌,程明显缩量走势,考虑到大盘风险,减持或清仓。 '),ALIGN2,color00FF00,LINETHICK2;
DRAWTEXT(TJTS1 and ((CROSS(1,AVX) AND (V1 >= V2)) AND (DSLX < DSLX1)) ,k2*0.99,'★该股放量下跌,走势明显偏弱,离场观望。 '),ALIGN2,color00FF00,LINETHICK2;
DRAWTEXT(TJTS1 and ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX < DSLX1)) ,k2*0.99,'★该股缩量下跌,走势偏弱,离场观望。 '),ALIGN2,color00FF00,LINETHICK2;
DRAWTEXT(TJTS1 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1)) ,k2*0.99,'★该股形态良好,强势明显,量能充足,可以继续持有。 '),ALIGN2,color00FFFF,LINETHICK2;
DRAWTEXT(TJTS1 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX >= DSLX1)) ,k2*0.99,'★该股上行趋势不变,强势依然,但量能开始转弱,注意风险。 '),ALIGN2,color00FFFF,LINETHICK2;
DRAWTEXT(TJTS1 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX < DSLX1)) ,k2*0.99,'★该股仍然具备上涨潜力,但股性偏弱,可考虑减仓。 '),ALIGN2,color00FFFF,LINETHICK2;
DRAWTEXT(TJTS1 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX < DSLX1)) ,k2*0.99,'★该股走势趋弱,量能不足,减持大部分筹码。 '),ALIGN2,color00FFFF,LINETHICK2;
DRAWTEXT(TJTS1 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1)) ,k2*0.99,'★该股形态不佳,注意成交量的变化,但目前不适合参与。 '),ALIGN2,LINETHICK2;
DRAWTEXT(TJTS1 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX >= DSLX1)) ,k2*0.99,'★该股趋势不明,股价偏弱,注意量能变化,目前不宜参与。 '),ALIGN2,LINETHICK2;
DRAWTEXT(TJTS1 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) AND (DSLX < DSLX1)) ,k2*0.99,'★该股有走强迹象,但量能不足,趋势不明,不适合操作。 '),ALIGN2,LINETHICK2;
DRAWTEXT(TJTS1 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX < DSLX1)) ,k2*0.99,'★该股走势太弱,没有参与价值。 '),ALIGN2,LINETHICK2;
DRAWTEXT(TJTS2 and (CROSS(AVX,1) AND (V1 >= V2)) ,k2*0.99,'★大盘量能理想,有明显走强迹象,可以考虑中线进场参与,仓位在2/3左右, '),ALIGN2,color0000FF;
DRAWTEXT(TJTS2 and (CROSS(AVX,1) AND (V1 >= V2)) ,k2*0.98,'★如前期经过一轮下跌,此时为最佳买点,但如果前期有过一段涨幅则介入需谨慎。 '),ALIGN2,color0000FF,LINETHICK2;
DRAWTEXT(TJTS2 and (CROSS(AVX,1) AND (V1 < V2)) ,k2*0.99,'★大盘虽然走势趋强,但量能还显不足,如果前期经过一轮下跌, '),ALIGN2,color0000FF,LINETHICK2;
DRAWTEXT(TJTS2 and (CROSS(AVX,1) AND (V1 < V2)) ,k2*0.98,' ★可以考虑短线进场,仓位在1/2左右,一旦量能放大可以加仓买入。 '),ALIGN2,color0000FF,LINETHICK2;
DRAWTEXT(TJTS2 and (CROSS(1,AVX) AND (V1 >= V2)) ,k2*0.99,'★大盘形态走坏,重仓者可以减去大部分仓位。 '),ALIGN2,color00FF00,LINETHICK2;
DRAWTEXT(TJTS2 and (CROSS(1,AVX) AND (V1 < V2)) ,k2*0.99,'★大盘缩量调整,注意风险,短线清仓观望。 '),ALIGN2,color00FF00,LINETHICK2;
DRAWTEXT(TJTS2 and (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) ,k2*0.99,'★大盘走势良好,量能理想,可以继续持有强势股。 '),ALIGN2,color00FFFF,LINETHICK2;
DRAWTEXT(TJTS2 and (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) ,k2*0.99,'★大盘形态良好,但量能稍显不足,随时准备减仓。 '),ALIGN2,color00FFFF;
DRAWTEXT(TJTS2 and (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) ,k2*0.99,'★大盘趋势不明,注意成交量变化,目前不适宜进场。 '),ALIGN2,LINETHICK2;
DRAWTEXT(TJTS2 and (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) ,k2*0.99,'★大盘趋势向下,量能萎缩,不适合进场。 '),ALIGN2,LINETHICK2;

大智慧精华组合主图指标公式

 

相关文章