在线检测未来函数

大智慧相思豆主图指标公式

来源:Internet,编辑:股旁网,2016-04-25

tjp:=SLOPE(EMA(CLOSE,2),5)*15+CLOSE;
v2:=ema(tjp,5);v3:=ema(v2,5);v4:=ema(v3,5);
v5:=ema(v4,5);v6:=ema(v5,5);v7:=ema(v6,5);
v8:=ema(v7,5);v9:=ema(v8,5);m:=ema(v9,5);
t1:=BARSLAST(CROSS(c,m));
t2:=BARSLAST(cross(m,c));
STICKLINE(c>m and c>ref(c,t1),ref(c,t1),l*0.99,1,0),colorFFC8FF;
STICKLINE(c<m and c<ref(c,t2),ref(c,t2),h*1.01,1,0),colorffaaae;
STICKLINE(c>m and c<ref(c,t1),ref(c,t1),l,1,0),coloryellow;
STICKLINE(c>m ,ref(c,t1),ref(c,t1),1,0),linethick6,colorred;
STICKLINE(c> m and c< ref(c,t1),ref(c,t1),ref(c,t1),1,0),linethick6,coloryellow;
STICKLINE(c<m ,ref(c,t2),ref(c,t2),1,0),linethick6,colorblue;
ma13:ma(c,13),colorwhite,linethick2;
ma30:ma(c,30),colorff00ff;
ma55:ma(c,55),coloryellow;
ma125:ma(c,125),colorffcccc;
ma250:ma(c,250),colorffcc66;
Var2:=MA(CLOSE, 5);
Var3:=MA(CLOSE, 10);
Var4:=MA(CLOSE, 20);
Var5:=MA(CLOSE, 30);
Var6:=(Var2+Var3+Var4+Var5)/4;
Var7:=(Var6-REF(Var6, 15))/REF(Var6,15)*100;
Var8:=(Var6-REF(Var6, 15))/REF(Var6, 15)*100;
Var9:=EMA(Var7, 8);
ma6:=ma(c,6);
ma18:=ma(c,18);
mjj:=((c-ref(ma6,1))/6+ma6)*1.004;
红豆生南国:IF(cross(c,mjj) and mjj>ref(mjj,1),l,h),COLORWHITE,POINTDOT;
STICKLINE(cross(c,mjj) and mjj>ref(mjj,1),h,l,0,1),colorwhite,linethick2;
STICKLINE(cross(c,mjj) and mjj>ref(mjj,1),o,c,4,1),colorwhite,linethick2;
jmj:=((c-ref(ma18,1))/18+ma18)*1.004;
春来发几枝:IF(cross(c,jmj) and jmj>ref(jmj,1),l,h),coloryellow,POINTDOT;
STICKLINE(cross(c,jmj) and jmj>ref(jmj,1),h,l,0,1),coloryellow,linethick2;
STICKLINE(cross(c,jmj) and jmj>ref(jmj,1),o,c,4,1),coloryellow,linethick2;
A2:=BARSLAST(ref(cross("kdj.k"(9,3,3),"kdj.d"(9,3,3)),1));
B2:=ref(c,A2+1)>c and ref("kdj.k"(9,3,3),A2+1)<"kdj.k"(9,3,3) and cross("kdj.k"(9,3,3),"kdj.d"(9,3,3));
A3:=BARSLAST(ref(cross("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));
B3:=ref(c,A3+1)>c and ref("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) and cross("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
愿君摘一撷:if(B2 AND B3,l,h),color0099ff,pointdot;
STICKLINE(B2 AND B3,h,l,0,1),color0099ff,linethick2;
STICKLINE(B2 AND B3,o,c,4,1),color0099ff,linethick2;
ss1:=(LOW+HIGH+CLOSE*2)/4;
ss2:= MA(ss1,4);
ss3:=HHV(ss2,10);
ss4:=ma(ss3,3);
ss5:=1.25*ss4-0.25*ss3;
kki:=if(ss5>ss3,ss3,ss5);
ff1:=LLV(ss2,10);
ff2:=ma(ff1,3);
ff3:=1.25*ff2-0.25*ff1;
kkj:=if(ff3<ff1,ff1,ff3);
zdhm:=cross(c,kkj) and cross(c,ma13) and cross(c,kki);
zhm:=cross(c,ma13) and cross(c,kki);
此物最相思:if(zdhm or zhm,l,h),colorff00ff,pointdot;
STICKLINE(zdhm or zhm,h,l,0,1),colorff00ff,linethick2;
STICKLINE(zdhm or zhm,o,c,4,1),colorff00ff,linethick2;
CSAR:=SAR(10,2,20);
TJ1:=BACKSET(SARTURN(10,2,20)<>0,2);
TJ2:=REF(TJ1,1);
if(CSAR>=H,CSAR,0),circledot,color00ff00;
if(CSAR<=L,CSAR,0),circledot,color0000ff;
if(TJ2,CSAR,0),circledot,color00ffff;
红涨:(c>m) ,colorred;
黄洗:(c> m and c< ref(c,t1)),coloryellow;
蓝跌:(c<m),colorblue ;
粉走:(Var7<1*REF(Var7, 1) AND Var9>1*REF(Var9, 1)),COLORF00FF0;
绿逃:(Var7<1*REF(Var7, 1)),COLOR00FF00;

大智慧相思豆主图指标公式

 

相关文章