在线检测未来函数

通达信琪新短线主图指标公式

来源:Internet,编辑:股旁网,2016-04-29

年:=YEAR,NODRAW;
月:=MONTH,NODRAW;
星期:=WEEKDAY,NODRAW;
日1:=DATETODAY(DATE);
上市日:=REF(DATE,TOTALBARSCOUNT-CURRBARSCOUNT);
自然日:=日1-DATETODAY(上市日)+1;
ZB:=(自然日-REF(自然日,1))!=星期-REF(星期,1)
OR TOTALBARSCOUNT-CURRBARSCOUNT=0;
本周第几天:=BARSLAST(ZB)+1;
本月第几天:=BARSLAST(年*100+月!=REF(年*100+月,1))+1;
MA1:=REF(C,本周第几天);
MA2:=REF(MA1,本周第几天);
MA3:=REF(MA2,本周第几天);
MA4:=REF(MA3,本周第几天);
五周价:=(C+MA1+MA2+MA3+MA4)/5;五周:=REFDATE(五周价,DATE),COLORFF00AA,LINETHICK2;
五日:MA(C,5),COLORGREEN,LINETHICK1;
IF(C>=MA(C,5),MA(C,5),DRAWNULL),COLORRED,LINETHICK4;
周线:REFDATE(五周价,DATE),COLORFF00AA,LINETHICK2;
涨停:ZTPRICE(REF(C,1),0.1),COLORYELLOW,NODRAW;跌停:DTPRICE(REF(C,1),0.1),COLORGREEN,NODRAW;
止赢:REF(C,1)*1.02,COLORFF00FF,NODRAW;止损:REF(C,1)*0.98,COLORGREEN,NODRAW;

通达信琪新短线主图指标公式

 

相关文章