在线检测未来函数

同花顺金凤凰指标公式

来源:Internet,编辑:股旁网,2016-05-06

xopen:=(REF(O,1)+REF(C,1))/2;
xclose:=CLOSE;
xhigh:=MAX(HIGH,xopen);
xlow:=MIN(LOW,xopen);
volality:=MA(xhigh-xlow,8);
凰线:MA(xclose,5)+volality/2;
凤线:MA(xclose,5)-volality/2;
bu:=CROSS(xclose,凰线);
sel:=CROSS(凤线,xclose);
var1:=BARSLAST(bu);
var2:=BARSLAST(sel);
DRAWICON(REF(var1,1)>var2 AND var1=0,xlow,7),align1,valign0;
DRAWICON(REF(var2,1)>var1 AND var2=0,xhigh,8),align1,valign2;
STICKLINE(xclose>xopen AND var1<var2,xclose,xopen ,8,0 ),colorred;
STICKLINE(xclose>xopen AND var1<var2,xhigh,xclose ,0.5,0 ),colorred;
STICKLINE(xclose>xopen AND var1<var2,xopen,xlow ,0.5,0 ),colorred;
STICKLINE(xclose<=xopen AND var1<var2,xclose,xopen ,8,0 ),coloryellow;
STICKLINE(xclose<=xopen AND var1<var2,xhigh,xopen ,0.5,0 ),coloryellow;
STICKLINE(xclose<=xopen AND var1<var2,xclose,xlow ,0.5,0 ),coloryellow;
STICKLINE(xclose<=xopen AND var1>var2,xclose ,xopen ,8,0 ),colorgreen;
STICKLINE(xclose<=xopen AND var1>var2,xopen ,xhigh ,0.5,0 ),colorgreen;
STICKLINE(xclose<=xopen AND var1>var2,xclose,xlow ,0.5,0 ),colorgreen;
STICKLINE(xclose>xopen AND var1>var2,xclose ,xopen ,8,0 ),colorblue;
STICKLINE(xclose>xopen AND var1>var2,xclose,xhigh ,0.5,0 ),colorblue;
STICKLINE(xclose>xopen AND var1>var2,xopen,xlow ,0.5,0 ),colorblue;

同花顺金凤凰指标公式

 

相关文章