在线检测未来函数

大智慧彩色成交量指标公式

来源:Internet,编辑:股旁网,2016-05-09

量:IF(C>200,VOL/1000000,vol/100),linethick0;
亿:AMOUNT/100000000, linethick0;
换手率:VOL/CAPITAL*100,linethick0,PRECIS2;
振幅:((H-L)/L)*100,linethick0,PRECIS2;
量比:VOL/DYNAINFO(38),linethick0,colorffff00,PRECIS2;
流通: CAPITAL/1000000,linethick0;
业绩: FINANCE2(3),linethick0;
净资产: FINANCE2(4),linethick0;
var1:=high-low;
var2:=ABS(open-close );
var3:=high-if(close>open,close,o);
var4:=if(close>open,o,close)-low;
var5:=(var2/var1)*vol;
var6:=(var3/var1)*vol;
var7:=(var4/var1)*vol;
var8:=IF(VOL/CAPITAL>0.001,1,EXP(ABS(LOG(VOL/CAPITAL*100))));
var9:=(c-ma(c,5))/ma(c,5)*100;
var10:=ma(c,5)>ma(c,10) and ma(c,10)>ma(c,30) and ma(c,30)>ma(c,60);
var11:=ma(c,5)<ma(c,10) and ma(c,10)<ma(c,30) ;
var12:=100*(1-WINNER(C)){套劳筹码};
var13:=100*WINNER(C){获利盘筹码};
多头:stickline(c>ma(c,30),0,vol,8,1),colorred;
空头:stickline(c<ma(c,30),0,vol,8,1),colorgreen;
上攻:stickline(var5>=var6 and var5>=var7 AND C>O,0,var5,8,0),colorred;
下攻:stickline(var5>=var6 and var5>=var7 and c<o,0,var5,8,0),colorgreen;
上探:stickline(var6>VAR5 and var6>var7,0,var6,8,0),COLORCYAN;
下探:stickline(var7>var5 and var7>var6,0,var7,8,0),colorff6600;
相对地量:stickline(var8>2 and vol<ma(vol,5)/2,0,vol,2.5,0),color00ffff;
drawtext(var8>2 and v<ma(v,5)/2,v*3,'地量'),color00ffff;
放量:stickline(vol>ma(vol,5)*1.5,vol,vol+vol*0.03,8,0),colorwhite;
V1:=H-L;
V2:=ABS(O-C);
V3:=H-IF(C>O,C,O);
V4:=IF(C>O,O,C)-L;
V5:=V2/V1*V;
V6:=V3/V1*V;
V7:=V4/V1*V;
M5:MA(V,5),colorwhite;
M10:MA(V,10),coloryellow;
V8:=IF(V/CAPITAL>0.001,1,EXP(ABS(LOG(V/CAPITAL*100))));
M5,COLORWhite;
M10,COLORYellow;
金指:Ema(if(l<=llv(l,30),1,0),3)*2*V,Colorwhite,Linethick2;
RSV1:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
K1:=SMA(RSV1,3,1);
D1:=SMA(K1,3,1);
J1:=3*K1-2*D1;
RSV:=(C-LLV(L,26))/(HHV(H,26)-LLV(L,26))*100;
K:=SMA(RSV, 6, 1);
D:=SMA(K, 3, 1);
J:=3*K-2*D;
LC:=REF(C,1);
XA:=IF(CROSS(J1,J) AND J<20,-1,0)+IF(CROSS(J,J1) AND J>80,1,0);
TYP:=(H+L+C)/3;
CCJ:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14))/2;
RSI1:=SMA(MAX(C-LC, 0), 6, 1)/SMA(ABS(C-LC), 6, 1)*100;
K2:=EMA((C-LLV(L,36))/(HHV(H,36)-LLV(L,36))*100, 9);
XB:=IF(CCJ>100 AND K2>50 AND C>O, 0.5, 0)+IF(RSI1>80 AND K2>50 AND C>O, 0.5, 0);
RSV3:=(C-LLV(L,100))/(HHV(H,100)-LLV(L,100))*100;
K13:=SMA(RSV3, 21, 1);
D13:=SMA(K1, 3, 1);
J13:=3*K13-2*D13;
XC:=IF(J13>80 AND RSI1>85, 0.5, 0);
警戒:V*(XA+XB+XC>0),Color009000,linethick2;
选股:If(V5>ma(v,5)*2 and V5>=V6 and V5>=V7 and c>o or v>ma(V,5)*3,V/2,0),colorred,Linethick2;
DrawIcon(Cross(M5,M10),100,1);
DrawIcon(Cross(M10,M5),100,2),VALIGN0;
DrawIcon(Cross(4000,金指),100,4),VALIGN1;

大智慧彩色成交量指标公式

 

相关文章