在线检测未来函数

大智慧稳赢全息主图指标公式

来源:Internet,编辑:股旁网,2016-05-10

流通:=C*CAPITAL*VOLUNIT/100000000;
总股本:=FINANCE2(35)/10000;
流通盘大小:=FINANCE2(37)/10000;
当前股价或指数:=C;
换手率:=SUM(VOL,1)*100/CAPITAL;
主营收入同比:=FINANCE2(11);
净利润同比增长:=FINANCE2(10);
净资产收益率:=FINANCE2(5);
毛利润率:=FINANCE2(12);
市盈率:=DYNAINFO(39);
净利润率:=FINANCE2(33)/FINANCE2(27)*100;
每股经营现金流:=FINANCE2(6);
DRAWTEXTABS(20,5,STKLABEL+' '+STKNAME),LINETHICK3,Colorred;
DRAWTEXTABS(180,5,'市盈率:'+市盈率+' '),LINETHICK3,Color00FF05;
DRAWTEXTABS(500,5,extrastring('评级')),LINETHICK1,ColorFF00FF,ALIGN1;
DRAWTEXTABS(20,30,'总股本:'+总股本+'亿 '),LINETHICK1,Color00FF00;
DRAWTEXTABS(180,30,'流通盘大小:'+流通盘大小+'亿 '),LINETHICK1,Color00FF00;
DRAWTEXTABS(20,50,'主营收入同比增长:'+主营收入同比+'%'),LINETHICK1,ColorFFFF00;
DRAWTEXTABS(180,50,'净利润同比增长:'+净利润同比增长+'%'),LINETHICK1,ColorFFFF00;
DRAWTEXTABS(320,50,'净资产收益率:'+净资产收益率+'% '),LINETHICK1,ColorFFFF00;
DRAWTEXTABS(20,70,'主营销售毛利润率:'+毛利润率+'% '),LINETHICK1,ColorFFFF00;
DRAWTEXTABS(180,70,'净利润率:'+净利润率+'% '),LINETHICK1,ColorFFFF00;
DRAWTEXTABS(320,70,'每股经营现金流:'+每股经营现金流+'元'),LINETHICK1,ColorFFFF00;
varC:=SMA(MAX(C-REF(C,1),0),6,1)/SMA(ABS(C-REF(C,1)),6,1)*100;
DRAWICON(CROSS(82,varC),HIGH,2);
DRAWTEXT(CROSS(84,varC),H*1.01,'逃顶'),COLORYELLOW ;
DP:=(INDEXC-REF(INDEXC,1))/REF(INDEXC,1);
GG:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1);
VAR1:=IF(DP>0.01,0.9,IF(DP<-0.05,1,1.2));
VAR2:=VAR1*(GG-DP)*100;
核心拉力:=SUM(VAR2,5);
DRAWICON(核心拉力>REF(核心拉力,1) AND REF(核心拉力,1)<REF(核心拉力,2) AND REF(核心拉力,1)<-6,l,1);
成本:COST(50),colorgreen,linethick2;
ma5:ma(c,5),color399c7f,linethick2;
ma10:ma(c,10),colore66878,linethick2;
ma20:ma(c,20),colorwhite,linethick2;
ma120:ma(c,120),colorffcccc,linethick2;
ma250:ma(c,250),colorffcc66,linethick2;
乖离线:=((c-ref(ma20,1))/20+ma20)*1.20;
tt1:=cross(ma20,ma120) and cross(ma20,ma250) and v>ref(v,1);
tt2:=ma20>ref(ma20,2) and v>ref(v,1) and cross(c,ma20);
STICKLINE(TT1,l,l-0.09,4,0),coloryellow;
DRAWTEXT(TT1,l-0.13,'金叉'),coloryellow;
STICKLINE(cross(c,ma120) and cross(c,ma250) and cross(c,ma20),l,l-0.09,4,0),coloryellow;
DRAWTEXT(cross(c,ma120) and cross(c,ma250) and cross(c,ma20),l-0.13,'并线开花'),coloryellow;
STICKLINE(tt2,l,l-0.09,4,0),coloryellow;
DRAWTEXT(tt2,l-0.13,'买点1'),coloryellow;
STICKLINE(cross(c,乖离线),h,h+0.09,4,0),color00ff00;
DRAWTEXT(cross(c,乖离线) ,h+0.13,'卖点'),color00ff00;
STICKLINE(ma250>=ref(ma250,1) and ma20>=ref(ma20,1) and cross(c,ma250),l,l-0.09,4,0),colorffcc66;
DRAWTEXT(ma250>=ref(ma250,1) and ma20>=ref(ma20,1) and cross(c,ma250),l-0.13,'牛象'),colorffcc66;
STICKLINE(ma120>=ref(ma120,1) and cross(c,ma20) and cross(c,ma120) and v>ref(v,1),l,l-0.09,4,0),colorff00ff;
DRAWTEXT(ma120>=ref(ma120,1) and cross(c,ma20) and cross(c,ma120) and v>ref(v,1),l-0.13,'买点2'),colorff00ff;

大智慧稳赢全息主图指标公式

 

相关文章