在线检测未来函数

通达信KDJ日周同显指标公式

来源:Internet,编辑:股旁网,2016-05-13

N:=1;
日K:KDJ.K,COLORWHITE;
日D:KDJ.D,COLORYELLOW;
日J:KDJ.J,COLORMAGENTA;
周K:=KDJ.K#WEEK,NODRAW;
周D:=KDJ.D#WEEK,NODRAW;
周J:=KDJ.J#WEEK,NODRAW;
金叉:=CROSS(日K,日D) AND (日D<40 OR 日D>60);
周金叉:=CROSS(周K,周D) AND (周D<40 OR 周D>60);
共振:=(周金叉 AND 日金叉);
STICKLINE(共振,-30,100,3,0),COLORLIRED;
DRAWTEXT((周金叉 AND 日金叉),-5,' 日周共振'),COLORYELLOW;
DRAWTEXT((周金叉 AND 日金叉),5,' K D J'),COLORYELLOW;
DRAWICON((周金叉 AND 日金叉),-5,5);
STICKLINE(日K>=日D,-15,-10,3,0),COLORLIRED;
STICKLINE(日K< 日D,-15,-10,3,0),COLORLIBLUE;
STICKLINE(周K>=周D,-20,-25,3,0),COLORLIRED;
STICKLINE(周K< 周D,-20,-25,3,0),COLORLIBLUE;
DRAWTEXT(ISLASTBAR,-12,'__日KDJ'),COLORWHITE;
DRAWTEXT(ISLASTBAR,-22,'__周KDJ'),COLORWHITE;
{RSI彩条}
LC1:=REF(CLOSE,1);
RSI11:=SMA(MAX(CLOSE-LC1,0),6,1)/SMA(ABS(CLOSE-LC1),6,1)*100,NODRAW;
RSI22:=SMA(MAX(CLOSE-LC1,0),12,1)/SMA(ABS(CLOSE-LC1),12,1)*100,NODRAW;
DRAWBAND(RSI11,RGB(150,0,0),RSI22,RGB(0,0,150));
RSI1:SMA(MAX(CLOSE-LC1,0),6,1)/SMA(ABS(CLOSE-LC1),6,1)*100,COLOR000096;
RSI2:SMA(MAX(CLOSE-LC1,0),12,1)/SMA(ABS(CLOSE-LC1),12,1)*100,COLOR000096;
IF(RSI1>RSI2,DRAWNULL,RSI1),COLOR960000;
IF(RSI1>RSI2,DRAWNULL,RSI2),COLOR960000;
{KDJ底背离和顶背离}
A2:=BARSLAST(REF(CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),1));
B2:=REF(C,A2+1)>C AND REF("KDJ.K"(9,3,3),A2+1)<"KDJ.K"(9,3,3) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));{KDJ底背}
C2:=BARSLAST(REF(CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3)),1));
D2:=REF(C,C2+1)<C AND REF("KDJ.K"(9,3,3),C2+1)>"KDJ.K"(9,3,3) AND CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3));{KDJ顶背}
DRAWICON((B2>0),日J,1);
DRAWTEXT((B2>0),日J,' KDJ底背'),COLORWHITE;
DRAWICON((D2>0),日J,2);
DRAWTEXT((D2>0),日J,' KDJ顶背'),COLORGREEN;
{RSI底背离和顶背离}
A3:=BARSLAST(REF(CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));
B3:=REF(C,A3+1)>C AND REF("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) AND CROSS
("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
C3:=BARSLAST(REF(CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24)),1));
D3:=REF(C,C3+1)<C AND REF("RSI.RSI1"(6,12,24),C3+1)>"RSI.RSI1"(6,12,24) AND CROSS
("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24));
DRAWICON((D3>0),95,2);
DRAWTEXT((D3>0),95,' RSI顶背'),COLORCYAN;
DRAWICON((B3>0),20,1);
DRAWTEXT((B3>0),20,' RSI底背'),COLORRED;
{传统KDJ}
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:SMA(RSV,3,1),COLORWHITE,LINETHICK1;
D:SMA(K,3,1),COLORYELLOW,LINETHICK1;
J:3*K-2*D,COLORMAGENTA,LINETHICK1;
IF1:IF(J<10,J,DRAWNULL),COLORRED,LINETHICK2;
IF2:IF(J>=80,J,DRAWNULL),COLORFF0080,LINETHICK2;
DRAWTEXT(ISLASTBAR,K,' ←K'),COLORWHITE;
DRAWTEXT(ISLASTBAR,D,' ←D'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,J,' ←J'),COLORMAGENTA;

通达信KDJ日周同显指标公式

 

相关文章