在线检测未来函数

通达信东家长波段指标公式

来源:Internet,编辑:股旁网,2016-05-18

N:=34;
A1:=REF(CLOSE,2);
A2:=SMA(MAX(CLOSE-A1,0),7,1)/SMA(ABS(CLOSE-A1),7,1)*100;
A3:=DATE <= 1070615;
A4:=REF(LOW,1);
A5:=SMA(ABS(LOW-A4),3,1)/SMA(MAX(LOW-A4,0),3,1)*100;
A6:=EMA(IF(CLOSE*1.3,A5*10,A5/10),3);
A7:=LLV(LOW,29);
A8:=HHV(A6,37);
A9:=IF(MA(CLOSE,90),1,0);
A10:=EMA(IF(LOW<=A7,(A6+A8*2)/2,0),3)/8888*A9;
A11:=IF(A10>100,100,A10);
STICKLINE(A11,0,A11,6,1) * A3,COLORF00FF0;
CCT:=DYNAINFO(8);
AAA:= FILTER(CCT=0,350) ;
DRAWTEXT(AAA,10,'★此股今日未开盘,不能分析'),COLORFF00FF;
VAR1:=SMA(EMA(((C+L)/2-LLV(L,N))/(HHV((H+C)/2,N)-LLV(L,N))*100,3),7,1)-(13);
RSV:=((HHV(HIGH,N)-CLOSE)/(HHV(HIGH,N)-LLV(LOW,N))*100)-70;
RSV1:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
FATK:=SMA(RSV1,5,1);
绿慢线:SMA(FATK,5,1),LINETHICK2,COLOR00D300;
紫快线:(7*SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*30,4,1)-3*SMA(SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*30,4,1),3,1)-SMA(SMA(SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*30,4,1),3,1),2,1)),COLORBB24DB;
介入:IF(A2<12,10,0),LINETHICK2,COLORWHITE;
B4:DRAWICON((ZIG(3,4)>REF(ZIG(3,4),1)) AND (REF(ZIG(3,4),1)<=REF(ZIG(3,4),2)) AND (REF(ZIG(3,4),2)<=REF(ZIG(3,4),3)),-2,1) ;
S4:DRAWICON((ZIG(3,4)<REF(ZIG(3,4),1)) AND (REF(ZIG(3,4),1)>=REF(ZIG(3,4),2)) AND (REF(ZIG(3,4),2)>=REF(ZIG(3,4),3)),95,15);
DRAWTEXT(ISLASTBAR,80,' ★顺德东家波段致胜版★'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,70,' 买入不急,卖出不贪'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,60,' 不求最低,只要买入正确,不求最高,只要卖出从容'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,50,' 黄线下来可全买,黄线上去可全卖'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,40,' 下买上卖仓位要遵守,全进全出易被套'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,30,' 高抛低吸看吸筹,低位无筹先别买'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,20,' 公式有未来函数,信号时显时灭说明涨跌未稳'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,-7,' EMA'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,-12,' MACD'),COLORYELLOW;
B8:DRAWTEXT(CROSS(ZIG(3,8),REF(ZIG(3,8),1)),5,'+20'),COLORGREEN;
B12:DRAWTEXT(CROSS(ZIG(3,12),REF(ZIG(3,12),1)),10,'+40'),COLORGREEN;
B16:DRAWTEXT(CROSS(ZIG(3,16),REF(ZIG(3,16),1)),15,'+60'),COLORGREEN;
B20:DRAWTEXT(CROSS(ZIG(3,20),REF(ZIG(3,20),1)),20,'+80'),COLORGREEN;
B30:DRAWTEXT(CROSS(ZIG(3,30),REF(ZIG(3,30),1)),25,'+100'),COLORGREEN;
S30:DRAWTEXT(CROSS(REF(ZIG(3,30),1),ZIG(3,30)),67,'-100'),COLORGREEN;
S20:DRAWTEXT(CROSS(REF(ZIG(3,20),1),ZIG(3,20)),72,'-80'),COLORGREEN;
S16:DRAWTEXT(CROSS(REF(ZIG(3,16),1),ZIG(3,16)),77,'-60'),COLORGREEN;
S12:DRAWTEXT(CROSS(REF(ZIG(3,12),1),ZIG(3,12)),82,'-40'),COLORGREEN;
S8:DRAWTEXT(CROSS(REF(ZIG(3,8),1),ZIG(3,8)),88,'-20'),COLORGREEN;
T1:=IF(TIME>093100 AND TIME<145500 ,1,0);
吸筹:A11,COLORLIBLUE;
CA1:=IF( 绿慢线>80 AND S4,1,0);
CA2:=IF( 紫快线<6 AND A2<10 AND B4,1,0);
CA3:=IF(吸筹 >=60 AND B8,1,0);
DDA:=' 短跌';
DRAWTEXT(CA1,95,DDA),COLORGREEN;
DDB:=' 短涨';
DRAWTEXT(CA2,-2,DDB),COLORGREEN;
DDC:='▲';
DRAWTEXT(CA3,3,DDC),COLORRED;
顶:85,COLORWHITE;
大顶:=105,COLOR5AFF9E;

通达信东家长波段指标公式

 

相关文章