在线检测未来函数

通达信波段日线主图指标公式

来源:Internet,编辑:股旁网,2016-05-23

MA3:=MA(C,3);
YTSL:=(3*C+L+O+H)/6;
辰星线:(20*YTSL+19*REF(YTSL,1)+18*REF(YTSL,2)+17*REF(YTSL,3)+16*REF(YTSL,4)+15*REF(YTSL,5)+14*REF(YTSL,6)+13*REF(YTSL,7)+12*REF(YTSL,8)+11*REF(YTSL,9)+10*REF(YTSL,10)+9*REF(YTSL,11)+8*REF(YTSL,12)+7*REF(YTSL,13)+6*REF(YTSL,14)+5*REF(YTSL,15)+4*REF(YTSL,16)+3*REF(YTSL,17)+2*REF(YTSL,18)+REF(YTSL,20))/211,COLORFFFF00;
牵牛线:MA(C,26),COLOR669933;
等待:IF(MA3<=辰星线,牵牛线,DRAWNULL),COLORGREEN,LINETHICK2;
中轨:=MA(C,26);
上轨:=中轨+STD(C,20);
下轨:=中轨-STD(C,20);
上极限:(中轨+2*STD(C,20)),COLORFF937F,LINETHICK2;
下极限:(中轨-2*STD(C,20)),COLORWHITE,LINETHICK2;
急速超跌:=(C-MA(C,34))/MA(C,34)*100<-14;
VAR1:=(C>REF(C,1) AND C>REF(C,2));
VAR2:=(REF(VAR1,1) AND C<=REF(C,1) AND C>=REF(C,2));
VAR3:=(REF(VAR2,1) AND C>=REF(C,1) AND C<=REF(C,2));
VAR4:=(REF(VAR3,1) AND C<=REF(C,1) AND C>=REF(C,2));
VAR5:=(REF(VAR4,1) AND C>=REF(C,1) AND C<=REF(C,2));
VAR6:=(REF(VAR5,1) AND C<=REF(C,1) AND C>=REF(C,2));
VAR7:=(REF(VAR6,1) AND C>=REF(C,1) AND C<=REF(C,2));
VAR8:=(REF(VAR7,1) AND C<=REF(C,1) AND C>=REF(C,2));
VAR9:=(REF(VAR8,1) AND C>=REF(C,1) AND C<=REF(C,2));
VARA:=(REF(VAR9,1) AND C<=REF(C,1) AND C>=REF(C,2));
VARB:=(REF(VARA,1) AND C>=REF(C,1) AND C<=REF(C,2));
VARC:=(REF(VARB,1) AND C<=REF(C,1) AND C>=REF(C,2));
持股:IF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,辰星线,DRAWNULL),COLORRED,POINTDOT,LINETHICK5;
VARD:=(C<REF(C,1) AND C<REF(C,2));
VARE:=(REF(VARD,1) AND C>=REF(C,1) AND C<=REF(C,2));
VARF:=(REF(VARE,1) AND C<=REF(C,1) AND C>=REF(C,2));
VAR10:=(REF(VARF,1) AND C>=REF(C,1) AND C<=REF(C,2));
VAR11:=(REF(VAR10,1) AND C<=REF(C,1) AND C>=REF(C,2));
VAR12:=(REF(VAR11,1) AND C>=REF(C,1) AND C<=REF(C,2));
VAR13:=(REF(VAR12,1) AND C<=REF(C,1) AND C>=REF(C,2));
VAR14:=(REF(VAR13,1) AND C>=REF(C,1) AND C<=REF(C,2));
VAR15:=(REF(VAR14,1) AND C<=REF(C,1) AND C>=REF(C,2));
VAR16:=(REF(VAR15,1) AND C>=REF(C,1) AND C<=REF(C,2));
VAR17:=(REF(VAR16,1) AND C<=REF(C,1) AND C>=REF(C,2));
VAR18:=(REF(VAR17,1) AND C>=REF(C,1) AND C<=REF(C,2));
持币:IF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,辰星线,DRAWNULL),COLORLIGRAY,POINTDOT,LINETHICK5;
VAR19:=((REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1)) AND VAR1);
VAR1A:=((REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1)) AND VARD);
DRAWTEXT(VAR19,L,'←短买'),COLOR33FFCC;
DRAWTEXT(VAR1A,H+0.1,'←离场'),COLORFF99FF;

通达信波段日线主图指标公式

 

相关文章