在线检测未来函数

大智慧庄家运作成本主图指标公式

来源:Internet,编辑:股旁网,2016-05-24

{ N,1,100,30 M,1,300,95}
input:n(30,1,100,1),m(95,1,300,1);
Var1:=AMOUNT/VOL/100;
庄家运作成本: MA(CLOSE,18),colorwhite;
庄家平均成本: EMA(EMA(Var1,2),N),color00ff00;
庄家底仓成本: EMA(EMA(Var1,13),M),colorblue;
无穷成本均线: DMA(CLOSE,VOL/CAPITAL),colorblue;
v1:ema(close,5),coloryellow;
v2:ema(ema(close,29)*1.01,10),colorffcc66;
DRAWICON(cross(v1,v2),v2,1);
v3:ema(close,10),colorff00ff;
v4:ema(ema(close,60)*0.99,10),color0099ff;
DRAWICON(cross(v3,v4),v4,1);
STICKLINE(C>=O,C,O,7,0),COLORRED;
STICKLINE(C>=O,C,O,4,0),COLOR7070ff{B0B0FF};
STICKLINE(C>=O,C,O,2,0),COLORYELLOW;
STICKLINE(C>=O,H,L,0,0),COLORYELLOW;
STICKLINE(C<=O,C,O,7,0),COLORFF2020;
STICKLINE(C<=O,C,O,4,0),COLORFF6600;
STICKLINE(C<=O,C,O,2,0),{COLORCYAN;}colorffcc66;
STICKLINE(C<=O,H,L,0,0),{COLORCYAN}colorffcc66;
Var326:=IF(CLOSE>REF(CLOSE,1),88,0);
Var327:=IF(CLOSE/REF(CLOSE,1)>1.050 AND HIGH/CLOSE<1.010 AND Var326>0, 91, 0);
STICKLINE(Var327>90,L*0.99,L*0.95,4,0),COLORYELLOW;
DRAWTEXT(Var327>90,LOW*0.94,'追涨'),COLORYELLOW;
a:=MA(c,13);
b:=MA(c,26);
盈利金叉:BARSLAST(a<b),PRECIS0,linethick0,Color00FFFF;
流通盘大小:=FINANCE2(37)/1000000*100;
金叉:=barslast(FILTER(CROSS("KD.K","KD.D") and "KD.D"<30,13));
主力吸筹区:=if(金叉>0 and 金叉<61,金叉,0);
DRAWTEXTABS(115,22,'流通盘大小:'+NUMTOSTRN(流通盘大小,2)+'亿'),LINETHICK1,ColorFFFFFC;
DRAWTEXTABS(245,20,'主力建仓天数:'+NUMTOSTRN(主力吸筹区,0)+'天'),ColorFFFFFC,LINETHICK1;
每股收益:=FINANCE2(3);
每股市盈率:=DYNAINFO(39);
每股净资产:=FINANCE2(4);
销售毛利率:=FINANCE2(12);
主营收入同比:=FINANCE2(11);
净利润同比增长:=FINANCE2(10);
流通市值:=C*CAPITAL*VOLUNIT/100000000;
总股本:=FINANCE2(35)/10000;
每股经营现金流:=FINANCE2(6);
获利盘:=WINNER(CLOSE)*100;
套牢盘:=100*(1-WINNER(C));
浮筹比例:=(winner(c*1.1)-winner(c*0.9))/winner(hhv(h,0))*100;
DRAWTEXTABS(245,100,'每股经营现金流:'+每股经营现金流+'元'),LINETHICK1,ColorFFFF00;
DRAWTEXTABS(5,20,'流通市值:'+流通市值+'亿 '),LINETHICK1,Color00FF00;
DRAWTEXTABS(245,5,'总股本:'+总股本+'亿 '),LINETHICK1,Color00FF00;
DRAWTEXTABS(5 ,120,'■筹码分析:'),Color00FFFF;
DRAWTEXTABS(80,120,'获利盘:'+获利盘+'% '),LINETHICK1,Color0000FF;
DRAWTEXTABS(180,120,'套牢盘:'+套牢盘+'% '),LINETHICK1,ColorFF6A00;
DRAWTEXTABS(280,120,'浮筹比例:'+浮筹比例+'% '),LINETHICK1,ColorFFFF00;
DRAWTEXTABS(5,40,'每股收益:'+NUMTOSTRN(每股收益,2)+'元'),ColorFFFFFF;
DRAWTEXTABS(115,40,'每股市盈率:'+NUMTOSTRN(每股市盈率,1)+'倍'),ColorFFFFFF;
DRAWTEXTABS(245,40,'每股净资产:'+NUMTOSTRN(每股净资产,2)+'元'),ColorFFFFFF;
DRAWTEXTABS(5,60,'销售毛利率:'+NUMTOSTRN(销售毛利率,2)+'%'),LINETHICK1,ColorFFFFFF;
DRAWTEXTABS(115,60,'主营收同比增长:'+NUMTOSTRN(主营收入同比,2)+'%'),LINETHICK1,ColorFFFFFF;
DRAWTEXTABS(245,60,'净利润同比增长:'+NUMTOSTRN(净利润同比增长,2)+'%'),LINETHICK1,ColorFFFFFF;
当日换手率:=sum(100*v/capital,1);
DRAWTEXTABS(5,80,'当日换手率: '+NUMTOSTRN(当日换手率,2)+'%'),ColorFFFFFC,LINETHICK1;
五日换手率:=sum(100*v/capital,5);
DRAWTEXTABS(115,80,'5日换手率: '+NUMTOSTRN(五日换手率,2)+'%'),ColorFFFFFC,LINETHICK1;
十日换手率:=SUM(VOL,10)*100/CAPITAL;
DRAWTEXTABS(245,80,'10日换手率: '+NUMTOSTRN(十日换手率,2)+'%'),ColorFFFFFC,LINETHICK1;
DRAWTEXTABS(5,100,'■短期盈利: 盈利金叉:'+NUMTOSTRN(盈利金叉,0)+'天'),Color00FFFF;
DRAWGBKLAST(c>0, STRIP(RGB(0,0,30),RGB(0,0,120),0));{背景}
DRAWTEXTREL(10,5,STKLABEL),LINETHICK4,Colorffff00;
DRAWTEXTREL(140,5,STKNAME),LINETHICK4,Color00ffff;
阻比:=(DYNAINFO(18)-DYNAINFO(19))/(DYNAINFO(18)+DYNAINFO(19))*100;
攻比:=(DYNAINFO(23)-DYNAINFO(22))/(DYNAINFO(23)+DYNAINFO(22))*100;
量比:=DYNAINFO(17);
DRAWTEXTABS(5,155,'量比:'+NUMTOSTRN(量比 ,2)),COLOR00FF00,linethick2;
DRAWTEXTABS(5,175,'攻比:'+NUMTOSTRN(攻比 ,2)),ColorFFFF00,LINETHICK2;
DRAWTEXTABS(5,135,'阻比:'+NUMTOSTRN(阻比 ,2)),COLORRED,linethick2;
DRAWTEXTABS(5,250,'机构评级:'+Extrastring('评级')),Color00FFFF,LINETHICK2;
DRAWTEXTABS(5,225,'板块:'+BKNAME),ColorFFFF00,LINETHICK0;
VAR14:=ZIG(3,13);
DRAWLINE((REF(VAR14,2) > REF(VAR14,1)) and (VAR14 > REF(VAR14,1)),LOW - (LOW)*(0.08),(REF(VAR14,2) < REF(VAR14,1)) and (VAR14 < REF(VAR14,1)),LOW - (LOW)*(0.05),0),Linethick5,Color070084;
DRAWLINE((REF(VAR14,2) > REF(VAR14,1)) and (VAR14 > REF(VAR14,1)),LOW - (LOW)*(0.08),(REF(VAR14,2) < REF(VAR14,1)) and (VAR14 < REF(VAR14,1)),LOW - (LOW)*(0.05),0),Linethick4,Color0000A3;
DRAWLINE((REF(VAR14,2) > REF(VAR14,1)) and (VAR14 > REF(VAR14,1)),LOW - (LOW)*(0.08),(REF(VAR14,2) < REF(VAR14,1)) and (VAR14 < REF(VAR14,1)),LOW - (LOW)*(0.05),0),Linethick3,Color0000B7;
DRAWLINE((REF(VAR14,2) > REF(VAR14,1)) and (VAR14 > REF(VAR14,1)),LOW - (LOW)*(0.08),(REF(VAR14,2) < REF(VAR14,1)) and (VAR14 < REF(VAR14,1)),LOW - (LOW)*(0.05),0),Linethick2,Color0000CD;
DRAWLINE((REF(VAR14,2) > REF(VAR14,1)) and (VAR14 > REF(VAR14,1)),LOW - (LOW)*(0.08),(REF(VAR14,2) < REF(VAR14,1)) and (VAR14 < REF(VAR14,1)),LOW - (LOW)*(0.05),0),Linethick1,Color077BF3;
买:DRAWTEXT((REF(VAR14,2) > REF(VAR14,1)) and (VAR14 > REF(VAR14,1)),LOW - (LOW)*(0.05),'买'),colorred;
卖:DRAWTEXT((REF(VAR14,2) < REF(VAR14,1)) and (VAR14 < REF(VAR14,1)),LOW - (LOW)*(0.03),'卖'),Color66FF00;
{下面是抄盘手B买S卖自选}
{VAR1:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));
VAR2:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));
VAR3:=(100 - MA(((100 * (HHV(HIGH,6) - CLOSE)) / (HHV(HIGH,6) - LLV(LOW,6))),34));
DRAWICON(CROSS(VAR2,MA(VAR3,6)),(LOW * 0.998), 7);
DRAWICON(CROSS(MA(VAR3,6),VAR1),(HIGH * 1.013),8);
DRAWTEXT(CROSS(VAR2,MA(VAR3,6)),(LOW * 0.984),'B '),color4440FF;
DRAWTEXT(CROSS(MA(VAR3,6),VAR1),(HIGH * 1.025),'S '),colorFFFF34;}

大智慧庄家运作成本主图指标公式

 

相关文章