在线检测未来函数

同花顺赤兔阻击指标公式

来源:Internet,编辑:股旁网,2016-05-27

HH:=(20*H+19*REF(H,1)+18*REF(H,2)+17*REF(H,3)+16*REF(H,4)+15*REF(H,5)+14*REF(H,6)
+13*REF(H,7)+12*REF(H,8)+11*REF(H,9)+10*REF(H,10)+9*REF(H,11)+8*REF(H,12)
+7*REF(H,13)+6*REF(H,14)+5*REF(H,15)+4*REF(H,16)+3*REF(H,17)+2*REF(H,18)+
REF(H,20))/210,colorblue,LINETHICK1;
LL:=(20*L+19*REF(L,1)+18*REF(L,2)+17*REF(L,3)+16*REF(L,4)+15*REF(L,5)+14*REF(L,6)
+13*REF(L,7)+12*REF(L,8)+11*REF(L,9)+10*REF(L,10)+9*REF(L,11)+8*REF(L,12)
+7*REF(L,13)+6*REF(L,14)+5*REF(L,15)+4*REF(L,16)+3*REF(L,17)+2*REF(L,18)+
REF(L,20))/210,colorblue,LINETHICK1;
D90H:=EMA(HH,90),colorred,LINETHICK1;
D90L:=EMA(LL,90),colorred,LINETHICK1;
DGH:=(20*H+19*REF(H,1)+18*REF(H,2)+17*REF(H,3)+16*REF(H,4)+15*REF(H,5)+14*REF(H,6)
+13*REF(H,7)+12*REF(H,8)+11*REF(H,9)+10*REF(H,10)+9*REF(H,11)+8*REF(H,12)
+7*REF(H,13)+6*REF(H,14)+5*REF(H,15)+4*REF(H,16)+3*REF(H,17)+2*REF(H,18)+
REF(H,20))/210,colorblue,LINETHICK1;DDL:=(20*L+19*REF(L,1)+18*REF(L,2)+17*REF(L,3)+16*REF(L,4)+15*REF(L,5)+14*REF(L,6)
+13*REF(L,7)+12*REF(L,8)+11*REF(L,9)+10*REF(L,10)+9*REF(L,11)+8*REF(L,12)
+7*REF(L,13)+6*REF(L,14)+5*REF(L,15)+4*REF(L,16)+3*REF(L,17)+2*REF(L,18)+
REF(L,20))/210,colorblue,LINETHICK1;D90C:=D90H-D90L;D90D:=D90H+D90C*2,colorred,LINETHICK1;D90T:=D90L-D90C*2,colorred,LINETHICK1;G0:=(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1+XMA(XMA(H,25),25),LINETHICK1,colorwhite;D0:=XMA(XMA(L,25),25)-(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1,LINETHICK1,colorwhite;DTD:=D0>=D90T AND G0>=D90D;KTD:=G0<=D90D AND D0<=D90T;ZDD:=D0>=D90T AND G0<=D90D;BDD0:=(XMA(XMA(H,60),60)-XMA(XMA(L,60),60))*3+XMA(XMA(H,60),60),LINETHICK2,colorgreen;BDT0:=XMA(XMA(L,60),60)-(XMA(XMA(H,60),60)-XMA(XMA(L,60),60))*3,LINETHICK2,colorgreen;STICKLINE(DTD=1,G0,D0,5,0),COLOR000066;STICKLINE(KTD=1,G0,D0,5,0),COLOR003300;STICKLINE(ZDD=1,G0,D0,5,0),COLOR555555;
ZK1:(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1+XMA(XMA(H,25),25),DOTLINE,colorwhite;
ZD1:XMA(XMA(L,25),25)-(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1,DOTLINE,colorwhite;
STICKLINE(1=1,D90H,D90L,5,0),colorligray;
HD:=DRAWLINE(HIGH>=HHV(HIGH,20),HIGH,LOW<=LLV(LOW,20),HHV(HIGH,4),1),LINETHICK2,colormagenta;
HK:=DRAWLINE(LOW<=LLV(LOW,20),LOW,HIGH>=HHV(HIGH,20),LLV(LOW,4),1),LINETHICK2,colorwhite;
BSB:=EMA((CLOSE+HIGH+LOW)/3,3);
BSM:=EMA(SLOPE((CLOSE+HIGH+LOW)/3,24)*20+(CLOSE+HIGH+LOW)/3,48),POINTDOT,coloryellow;
STICKLINE(BSB>=BSM,LOW,HIGH,0.0,0),colorred;
STICKLINE(BSB>=BSM,CLOSE,OPEN,3,1),colorred;
STICKLINE(BSB<=BSM,LOW,HIGH,0.0,0),colorgreen;
STICKLINE(BSB<=BSM,CLOSE,OPEN,3,1),colorgreen;
白色点多定位1:=L<ZD1 AND H>ZD1;
白色点空定位1:=H>ZK1 AND L<ZK1;
STICKLINE(白色点多定位1=1,L,ZD1,3,0),colorwhite;
STICKLINE(白色点空定位1=1,H,ZK1,3,0),colorwhite;
白色点多定位2:=H<ZD1;
白色点空定位2:=L>ZK1;
STICKLINE(白色点多定位2=1,L,H,0.0,0),colorwhite;
STICKLINE(白色点多定位2=1,C,O,3,0),colorwhite;
STICKLINE(白色点空定位2=1,L,H,0.0,0),colorwhite;
STICKLINE(白色点空定位2=1,C,O,3,0),colorwhite;
多头多定位:=CROSS(ZD1,L) AND DTD=1;
多头平定位:=CROSS(H,ZK1) AND DTD=1 AND ZDD=0;
空头空定位:=CROSS(H,ZK1) AND KTD=1;
空头平定位:=CROSS(ZD1,L) AND KTD=1 AND ZDD=0;
震荡多定位:=CROSS(ZD1,L) AND ZDD=1;
震荡空定位:=CROSS(H,ZK1) AND ZDD=1;
DRAWICON(空头平定位=1,L,5);
DRAWICON(多头平定位=1,H,6);
DRAWICON(多头多定位=1 OR 震荡多定位=1,L,5);
DRAWICON(空头空定位=1 OR 震荡空定位=1,H,6);
DRAWTEXT(ISLASTBAR,ZK1,'卖'),colorgreen;
DRAWTEXT(ISLASTBAR,ZD1,'买'),colorred;
大单动向:=(ZDMR-ZDMC)*10000/SHGZG;
灰色线:=(XMA(XMA(H,60),60)-XMA(XMA(L,60),60))*4+XMA(XMA(H,60),60),LINETHICK2,colorgreen;
绿色线:=(XMA(XMA(H,60),60)-XMA(XMA(L,60),60))*5+XMA(XMA(H,60),60),LINETHICK2,colorgreen;
红色线:=(XMA(XMA(H,60),60)-XMA(XMA(L,60),60))*6+XMA(XMA(H,60),60),LINETHICK2,colorgreen;
冠军线:=(XMA(XMA(H,60),60)-XMA(XMA(L,60),60))*7+XMA(XMA(H,60),60),LINETHICK2,colorgreen;
DRAWTEXT(1=1 AND CURRBARSCOUNT=50,红色线,'【红色:多头趋势,顺势买卖】'),colorred;
DRAWTEXT(1=1 AND CURRBARSCOUNT=50,绿色线,'【绿色:空头趋势,空仓观望】'),colorgreen;
DRAWTEXT(1=1 AND CURRBARSCOUNT=50,灰色线,'【灰色:震荡趋势,投机买卖】'),colorligray;

同花顺赤兔阻击指标公式

 

相关文章