在线检测未来函数

通达信顺势之王指标公式

来源:Internet,编辑:股旁网,2016-05-31

MA5:=MA(CLOSE,5);
MA10:=MA(CLOSE,10);
MA20:=MA(CLOSE,20);
A1:=IF(C>=MA5,1,-1);
A2:=IF(C>=MA10,1,-1);
A3:=IF(C>=MA20,1,-1);
A4:=IF(MA5>=REF(MA5,1),1,-1);
A5:=IF(MA10>=REF(MA10,1),1,-1);
A6:=IF(MA20>=REF(MA20,1),1,-1);
趋势:(A1+A2+A3+A4+A5+A6)/6*100,COLOR00FF00;
主升浪:趋势>=50,COLOR0000FF,POINTDOT,NODRAW;
↓:趋势<50,COLORFFFFFF,POINTDOT,NODRAW;
周期:IF(主升浪,BARSLAST(CROSS(主升浪,0.1))+1,0),COLORFF00FF,POINTDOT,NODRAW;
临界:IF(CROSS(98,趋势),1,0),COLOR00FF00,POINTDOT,NODRAW;
WKQY:=BARSLAST(CROSS(50,趋势))<MIN(BARSLAST(CROSS(趋势,1)),BARSLAST(CROSS(趋势,-1)));
挖坑:BETWEEN(趋势,-1,50) AND WKQY,COLOR00FFFF,POINTDOT,NODRAW;
{以下设置副图显示方式}
DRAWBAND(趋势,RGB(250,0,0),50,RGB(0,0,0));
AA:=IF(挖坑,趋势,50);
DRAWBAND(50,RGB(250,250,0),AA,RGB(0,0,0));
STICKLINE(主升浪,周期*0.8,周期*0.95,3,0),COLOR0000FF;
STICKLINE(主升浪,周期*1.05,周期*1.2,3,0),COLOR0000FF;
STICKLINE(主升浪 AND C<REF(C,1),周期*0.9,周期*1.1,3,1),COLORFFFFFF;
STICKLINE(CROSS(主升浪,0.1),0,100,0,-1),COLOR0000FF;
DRAWTEXT(临界,90,'☆'),COLOR00FF00;
平:0,COLORFFFFFF;
STICKLINE(C>0,50,50,1,0),COLOR000000;
%:趋势,COLOR00FF00;
{以下设置文字提示部分}
DRAWTEXT(CURRBARSCOUNT=60,20,'====★趋势为王.顺势而为!★===='),COLOR0000FF;
DRAWTEXT(CURRBARSCOUNT=58,-30,'■只做主升, 挖坑低吸!'),COLORFFFFFF;
DRAWTEXT(CURRBARSCOUNT=58,-60,'●临界不涨, 逢高离场!'),COLOR00FFFF;

通达信顺势之王指标公式

 

相关文章