在线检测未来函数

通达信五行量化趋势指标公式

来源:Internet,编辑:股旁网,2016-06-03

日线锁定:=(PERIOD==4);
数量:=23;
DMADIF:=MA(C,10)-MA(C,50);
DMAAMA:=MA(DMADIF,10);
DMAX:=DMADIF>DMAAMA;
P01:=DMAX;
DMITR:=EXPMEMA(MAX(MAX(H-L,ABS(H-REF(C,1))),ABS(REF(C,1)-L)),14);
DMIHD:=H-REF(H,1);
DMILD:=REF(L,1)-L;
DMIDMP:=EXPMEMA(IFF(DMIHD>0 AND DMIHD>DMILD,DMIHD,0),14);
DMIDMM:=EXPMEMA(IFF(DMILD>0 AND DMILD>DMIHD,DMILD,0),14);
DMIPDI:=DMIDMP*100/DMITR;
DMIMDI:=DMIDMM*100/DMITR;
DMIX:=DMIPDI>DMIMDI;
P02:=DMIX;
DPODPO:=C-REF(MA(C,20),20/2+1);
DPOMADPO:=MA(DPODPO,6);
DPOX:=DPODPO>DPOMADPO;
P03:=DPOX;
EMVVOLUME:=MA(V,14)/V;
EMVMID:=100*(H+L-REF(H+L,1))/(H+L);
EMVEMV:=MA(EMVMID*EMVVOLUME*(H-L)/MA(H-L,14),14);
EMVMAEMV:=MA(EMVEMV,9);
EMVX:=EMVEMV>EMVMAEMV;
P04:=EMVX;
MACDDIF:=EMA(C,12)-EMA(C,26);
MACDDEA:=EMA(MACDDIF,9);
MACDX:=MACDDIF>MACDDEA;
P05:=MACDX;
TRIXTR:=EMA(EMA(EMA(C,12),12),12);
TRIXTRIX:=(TRIXTR-REF(TRIXTR,1))/REF(TRIXTR,1)*100;
TRIXMATRIX:=MA(TRIXTRIX,9);
TRIXX:=TRIXTRIX>TRIXMATRIX;
P06:=TRIXX;
WVADWVAD:=SUM((C-O)/(H-L)*V,24)/10000;
WVADMAWVAD:=MA(WVADWVAD,6);
WVADX:=WVADWVAD>WVADMAWVAD;
P08:=WVADX;
JSJS:=100*(C-REF(C,5))/(5*REF(C,5));
JSMAJS1:=MA(JSJS,5);
JSX:=JSJS>JSMAJS1;
P09:=JSX;
CYEMAL:=MA(C,5);
CYEMAS:=MA(MA(C,20),5);
CYECYEL:=(CYEMAL-REF(CYEMAL,1))/REF(CYEMAL,1)*100;
CYECYES:=(CYEMAS-REF(CYEMAS,1))/REF(CYEMAS,1)*100;
CYEX:=CYECYEL>CYECYES;
P10:=CYEX;
JLHBVAR1:=(C-LLV(L,60))/(HHV(H,60)-LLV(L,60))*80;
JLHBB:=SMA(JLHBVAR1,7,1);
JLHBVAR2:=SMA(JLHBB,5,1);
JLHBX:=JLHBB>JLHBVAR2;
P11:=JLHBX;
CYCJJJ:=IFF(DYNAINFO(8)>0.01,0.01*DYNAINFO(10)/DYNAINFO(8),DYNAINFO(3));
CYCDDD:=(DYNAINFO(5)<0.01 || DYNAINFO(6)<0.01);
CYCJJJT:=IFF(CYCDDD,1,(CYCJJJ<(DYNAINFO(5)+0.01) && CYCJJJ>(DYNAINFO(6)-0.01)));
CYCCYC1:=IFF(CYCJJJT,0.01*EXPMA(AMOUNT,5)/EXPMA(VOL,5),EMA((HIGH+LOW+CLOSE)/3,5));
CYCCYC2:=IFF(CYCJJJT,0.01*EXPMA(AMOUNT,13)/EXPMA(VOL,13),EMA((HIGH+LOW+CLOSE)/3,13));
CYCX:=CYCCYC1>CYCCYC2;
P12:=CYCX;
BBIBBI:=(MA(C,3)+MA(C,6)+MA(C,12)+MA(C,24))/4;
BBIX:=C>BBIBBI;
P13:=BBIX;
DDITR:=MAX(ABS(H-REF(H,1)),ABS(L-REF(L,1)));
DDIDMZ:=IFF((H+L)<=(REF(H,1)+REF(L,1)),0,MAX(ABS(H-REF(H,1)),ABS(L-REF(L,1))));
DDIDMF:=IFF((H+L)>=(REF(H,1)+REF(L,1)),0,MAX(ABS(H-REF(H,1)),ABS(L-REF(L,1))));
DDIDIZ:=SUM(DDIDMZ,13)/(SUM(DDIDMZ,13)+SUM(DDIDMF,13));
DDIDIF:=SUM(DDIDMF,13)/(SUM(DDIDMF,13)+SUM(DDIDMZ,13));
DDIDDI:=DDIDIZ-DDIDIF;
DDIADDI:=SMA(DDIDDI,30,10);
DDIAD:=MA(DDIADDI,5);
DDIX:=DDIADDI>DDIAD;
P14:=DDIX;
FSLSWL:=(EXPMA(C,5)*7+EXPMA(C,10)*3)/10;
FSLSWS:=DMA(EMA(C,12),MAX(1,100*(SUM(V,5)/(3*CAPITAL))));
FSLX:=FSLSWL>FSLSWS;
P15:=FSLX;
MAMA1:=MA(C,5);
MAMA2:=MA(C,10);
MAXX:=MAMA1>MAMA2;
P16:=MAXX;
EXPEMA1:=EXPMA(C,12);
EXPEMA2:=EXPMA(C,17);
EXPMAX:=EXPEMA1>EXPEMA2 AND EXPEMA1>REF(EXPEMA1,1) AND EXPEMA2>REF(EXPEMA2,1);
P17:=EXPMAX;
PBX1:=(EXPMA(C,4)+MA(C,4*2)+MA(C,4*4))/3;
PBX2:=(EXPMA(C,6)+MA(C,6*2)+MA(C,6*4))/3;
PBXX:=PBX1>PBX2 AND PBX1>REF(PBX1,1) AND PBX2>REF(PBX2,1);
P18:=PBXX;
SARX:=C>SAR(4,2,20);
P19:=SARX;
QLTB:=IFF(H>REF(C,1),H-REF(C,1)+C-L,C-L);
QLTS:=IFF(REF(C,1)>LOW,REF(C,1)-L+H-C,H-C);
QLVOL_:=(QLTB-QLTS)*V/(QLTB+QLTS)/100;
QLVOL_0:=DMA(QLVOL_,0.1);
QLVOL_1:=DMA(QLVOL_,0.05);
QLRES1:=QLVOL_0-QLVOL_1;
QLLON:=SUM(QLRES1,0);
QLLONG:=QLLON;
QLMA1:=MA(QLLON,10);
LONQLX:=QLLONG>REF(QLLONG,1) AND QLMA1>REF(QLMA1,1) AND QLLONG>QLMA1,NODRAW,COLORFFFFFF;
P20:=LONQLX;
QLSTB:=IFF(H>REF(C,1),H-REF(C,1)+C-L,C-L);
QLSTS:=IFF(REF(C,1)>L,REF(C,1)-L+H-C,H-C);
QLSVOL_:=(QLSTB-QLSTS)*V/(QLSTB+QLSTS)/100;
QLSVOL_0:=DMA(QLSVOL_,0.1);
QLSVOL_1:=DMA(QLSVOL_,0.05);
QLSSHORT:=QLSVOL_0-QLSVOL_1;
QLSMA1:=MA(QLSSHORT,10);
SHORTQLX:=QLSSHORT>QLSMA1;
P21:=SHORTQLX;
AMVAMV0:=V*(O+C)/2;
AMVAMV1:=SUM(AMVAMV0,5)/SUM(V,5);
AMVAMV2:=SUM(AMVAMV0,13)/SUM(V,13);
AMVX:=AMVAMV1>AMVAMV2;
P22:=AMVX;
MTMMTM:=C-REF(C,12);
MTMMAMTM:=MA(MTMMTM,6);
MTMX:=MTMMTM>MTMMAMTM;
P23:=MTMX;
ZJTJVAR1:=EMA(EMA(C,9),9);
ZJTJ控盘:=(ZJTJVAR1-REF(ZJTJVAR1,1))/REF(ZJTJVAR1,1)*1000;
YZKPX:=ZJTJ控盘>REF(ZJTJ控盘,1) AND ZJTJ控盘>0;
P24:=YZKPX;
量化趋势:(P01+P02+P03+P04+P05+P06+P08+P09+P10+P11+P12+P13+P14+P15+P16+P17+P18+P19+P20+P21+P22+P23+P24)*(100/数量),NODRAW,COLORRED;
▲35线:35,COLORGREEN;
▲50线:50,COLORYELLOW;
▲80线:80,COLORRED;
STICKLINE(量化趋势>=REF(量化趋势,1),0,量化趋势,3,0),COLORRED;
STICKLINE(量化趋势<REF(量化趋势,1),0,量化趋势,3,0),COLORFFFF00;
STICKLINE(量化趋势>=REF(量化趋势,1),0,量化趋势,3,0),COLOR0000FF;
STICKLINE(量化趋势>=REF(量化趋势,1),0,量化趋势,2.7.5,0),COLOR001BFF;
STICKLINE(量化趋势>=REF(量化趋势,1),0,量化趋势,2.4,0),COLOR0035FF;
STICKLINE(量化趋势>=REF(量化趋势,1),0,量化趋势,2.1,0),COLOR0050FF;
STICKLINE(量化趋势>=REF(量化趋势,1),0,量化趋势,1.8,0),COLOR0062FF;
STICKLINE(量化趋势>=REF(量化趋势,1),0,量化趋势,1.5,0),COLOR007AFF;
STICKLINE(量化趋势>=REF(量化趋势,1),0,量化趋势,1.2,0),COLOR0089FF;
STICKLINE(量化趋势>=REF(量化趋势,1),0,量化趋势,0.9,0),COLOR009CFF;
STICKLINE(量化趋势>=REF(量化趋势,1),0,量化趋势,0.6,0),COLOR00C0FF;
STICKLINE(量化趋势>=REF(量化趋势,1),0,量化趋势,0.3,0),COLOR00EAFF;

通达信五行量化趋势指标公式

 

相关文章