在线检测未来函数

通达信五行量化量能指标公式

来源:Internet,编辑:股旁网,2016-06-03

日线锁定:=(PERIOD==4);
方向成交量:=IFF(CLOSE>=OPEN,VOL,VOL*(-1));
LHLNMID:=(3*CLOSE+OPEN+HIGH+LOW)/6;
LHLN短线:=WMA(LHLNMID,5);
LHLN中线:=WMA(LHLNMID,10);
LHLN多头:=LHLN短线>LHLN中线;
P01:=SUM(方向成交量,1)>0;
P02:=SUM(方向成交量,2)>0;
P03:=SUM(方向成交量,3)>0;
P04:=SUM(方向成交量,4)>0;
P05:=SUM(方向成交量,5)>0;
SUM11:=SUM(方向成交量,11);
SUM12:=SUM(方向成交量,12);
SUM13:=SUM(方向成交量,13);
SUM14:=SUM(方向成交量,14);
SUM15:=SUM(方向成交量,15);
SUM16:=SUM(方向成交量,16);
SUM17:=SUM(方向成交量,17);
SUM18:=SUM(方向成交量,18);
SUM19:=SUM(方向成交量,19);
SUM20:=SUM(方向成交量,20);
P11:=SUM11>0 AND SUM11>REF(SUM11,1);
P12:=SUM12>0 AND SUM12>REF(SUM12,1);
P13:=SUM13>0 AND SUM13>REF(SUM13,1);
P14:=SUM14>0 AND SUM14>REF(SUM14,1);
P15:=SUM15>0 AND SUM15>REF(SUM15,1);
P16:=SUM16>0 AND SUM16>REF(SUM16,1);
P17:=SUM17>0 AND SUM17>REF(SUM17,1);
P18:=SUM18>0 AND SUM18>REF(SUM18,1);
P19:=SUM19>0 AND SUM19>REF(SUM19,1);
P20:=SUM20>0 AND SUM20>REF(SUM20,1);
MAZJ05:=MA(方向成交量,5);
MAZJ10:=MA(方向成交量,10);
MAZJ15:=MA(方向成交量,15);
MAZJ20:=MA(方向成交量,20);
MA01:=MAZJ05>MAZJ10;
MA02:=MAZJ05>MAZJ15;
MA03:=MAZJ05>MAZJ20;
MA04:=MAZJ10>MAZJ15;
MA05:=MAZJ10>MAZJ20;
MA06:=MAZJ15>MAZJ20;
基准线1:=EMA(EMA(EMA(EMA(IFF(方向成交量>=0,方向成交量,0),20),2),2),2);
基准线6:=基准线1*6;
ZJDL10:=IFF(方向成交量>基准线6,10,IFF(方向成交量<=基准线6 AND 方向成交量>0,10*方向成交量/基准线6,0));
短线总量:=SUM(方向成交量,3);
短线总量10:=EMA(短线总量,10);
短线总量60:=EMA(短线总量,60);
短线总量20:=EMA(短线总量,20);
短线总量30:=EMA(短线总量,30);
CZD01:=短线总量>短线总量10;
CZD02:=短线总量20>短线总量30;
CZD03:=短线总量10>短线总量60;
总权:=53;
量化量能X:=EMA(EMA(100*(P01*2+P02*2+P03*5+P04*2+P05*2+P11*1+P12*1+P13*1+P14*1+P15*1+P16*1+P17*1+P18*1+P19*1+P20*1+
MA01*2+MA02*2+MA03*1+MA04*1+MA05*1+MA06*1+ZJDL10+CZD01*5+CZD02*4+CZD03*3)/总权,2),2),NODRAW,COLORRED;
量化量能XX:=IFF(LHLN多头,量化量能X*1.2,量化量能X);
量化量能:WMA(IFF(量化量能XX>=100,100,量化量能XX),3),NODRAW,COLORRED;
▲35线:35,COLORGREEN;
▲50线:50,COLORYELLOW;
▲80线:80,COLORRED;
STICKLINE(量化量能>=REF(量化量能,1),0,量化量能,3,0),COLORRED;
STICKLINE(量化量能<REF(量化量能,1),0,量化量能,3,0),COLORFFFF00;
STICKLINE(量化量能>=REF(量化量能,1),0,量化量能,3,0),COLOR0000FF;
STICKLINE(量化量能>=REF(量化量能,1),0,量化量能,2.7.5,0),COLOR001BFF;
STICKLINE(量化量能>=REF(量化量能,1),0,量化量能,2.4,0),COLOR0035FF;
STICKLINE(量化量能>=REF(量化量能,1),0,量化量能,2.1,0),COLOR0050FF;
STICKLINE(量化量能>=REF(量化量能,1),0,量化量能,1.8,0),COLOR0062FF;
STICKLINE(量化量能>=REF(量化量能,1),0,量化量能,1.5,0),COLOR007AFF;
STICKLINE(量化量能>=REF(量化量能,1),0,量化量能,1.2,0),COLOR0089FF;
STICKLINE(量化量能>=REF(量化量能,1),0,量化量能,0.9,0),COLOR009CFF;
STICKLINE(量化量能>=REF(量化量能,1),0,量化量能,0.6,0),COLOR00C0FF;
STICKLINE(量化量能>=REF(量化量能,1),0,量化量能,0.3,0),COLOR00EAFF;

通达信五行量化量能指标公式

 

相关文章