在线检测未来函数

通达信MACD不同玩法指标公式

来源:Internet,编辑:股旁网,2016-06-06

AJ1:=0.211916*C+0.192951*REF(C,1)+0.158082*REF(C,2)+0.122217*REF(C,3)+0.091137*REF(C,4)+0.066337
*REF(C,5)+0.047475*REF(C,6)+0.033564*REF(C,7)+0.023519*REF(C,8)+0.016373*REF(C,9)+0.011344
*REF(C,10)+0.007832*REF(C,11)+0.005395*REF(C,12)+0.00371*REF(C,13)+0.002549*REF(C,14)+0.001751
*REF(C,15)+0.001203*REF(C,16)+0.000826*REF(C,17)+0.000568*REF(C,18)+0.000391*REF(C,19)+0.000269
*REF(C,20);
YYU:=AJ1+0.000185*REF(C,21)+0.000128*REF(C,22)+0.000088*REF(C,23)+0.000061*REF(C,24)+0.000042
*REF(C,25)+0.000029*REF(C,26)+0.00002*REF(C,27)+0.000014*REF(C,28)+0.000009*REF(C,29)+0.000006
*REF(C,30)+0.000003*REF(C,31)+0.000002*REF(C,32)+0.000001*REF(C,33)+0.000001*REF(C,34);
X00:=C;
X01:=0.7522406533*X00+0.3609454219*REF(X00,1)-0.03309329629*REF(X00,2)-
0.04241822779*REF(X00,3)-0.026737249*REF(X00,4)-0.007010041271*REF(X00,5)-
0.002652859952*REF(X00,6)-0.0008415042966*REF(X00,7)-0.0002891931964*REF
(X00,8)-0.0000956265934*REF(X00,9)-0.0000321286052*REF(X00,10)-
0.0000106773454*REF(X00,11)-0.0000035457562*REF(X00,12)-0.0000011670713*REF
(X00,13);
X02:=0.7522406533*X01+0.3609454219*REF(X01,1)-0.03309329629*REF(X01,2)-
0.04241822779*REF(X01,3)-0.026737249*REF(X01,4)-0.007010041271*REF(X01,5)-
0.002652859952*REF(X01,6)-0.0008415042966*REF(X01,7)-0.0002891931964*REF
(X01,8)-0.0000956265934*REF(X01,9)-0.0000321286052*REF(X01,10)-
0.0000106773454*REF(X01,11)-0.0000035457562*REF(X01,12)-0.0000011670713*REF
(X01,13);
X03:=0.7522406533*X02+0.3609454219*REF(X02,1)-0.03309329629*REF(X02,2)-
0.04241822779*REF(X02,3)-0.026737249*REF(X02,4)-0.007010041271*REF(X02,5)-
0.002652859952*REF(X02,6)-0.0008415042966*REF(X02,7)-0.0002891931964*REF
(X02,8)-0.0000956265934*REF(X02,9)-0.0000321286052*REF(X02,10)-
0.0000106773454*REF(X02,11)-0.0000035457562*REF(X02,12)-0.0000011670713*REF
(X02,13);
AA:=((EMA((((EMA(X01,22)+EMA(X01,23))+EMA(X01,24))/3),2))+(EMA((((EMA
(X01,24)+EMA(X01,25))+EMA(X01,26))/3),2))+(EMA((((EMA(X01,26)+EMA(X01,27))
+EMA(X01,28))/3),2))+(EMA((((EMA(X01,28)+EMA(X01,29))+EMA(X01,30))/3),2))+
(EMA((((EMA(X01,30)+EMA(X01,31))+EMA(X01,32))/3),2))+(EMA((((EMA(X01,32)+EMA
(X01,33))+EMA(X01,34))/3),2)))/6;
BB1:=(X01*5+X02*3+X03*1)/9;
主升线:EMA(AA,10)-EMA(YYU,22);
DIF:EMA(BB1+SLOPE(BB1,10),10)-EMA(YYU+SLOPE(YYU,22),22),COLORWHITE;
DEA:EMA(DIF+SLOPE(DIF,6),6),COLORGREEN;
SDEA:=REF(HHV(DEA,BARSLAST(CROSS(DEA,DIF))+1),1),COLORMAGENTA;
BDEA:=REF(LLV(DEA,BARSLAST(CROSS(DIF,DEA))+1),1),COLORAAAA00;
XMACD1:2*(DIF-DEA),COLORSTICK;
RSI5:=((SMA(MAX((CLOSE - REF(CLOSE,1)),0),5,1) / SMA(ABS((CLOSE - REF(CLOSE,1))),5,1)) * 100);
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
NEWVOL:=(RSI5 - WR10);
回调买:=(AV + NEWVOL);
XGT:=CROSS(回调买,0) AND DIF>主升线;
BIAS1 :=(CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*100;
BIAS2 :=(CLOSE-MA(CLOSE,1))/MA(CLOSE,1)*100;
DRAWICON(CROSS(BIAS1,BIAS2) AND DIF>主升线 AND XMACD1>REF(XMACD1,1),DIF,7);

通达信MACD不同玩法指标公式

 

相关文章