在线检测未来函数

通达信超强MACD指标公式

来源:Internet,编辑:股旁网,2016-06-14

SHORT:=12;LONG:=26;MID:=9;
D1:=EMA(C,3)-EMA(C,8);
D2:=EMA(O,3)-EMA(O,8);
D3:=EMA(H,3)-EMA(H,8);
D4:=EMA(L,3)-EMA(L,8);
STICKLINE(D1>=D2,D1,D2,3,0),COLOR0055AA;
STICKLINE(D1<=D2,D1,D2,3,0),COLOR006600;
STICKLINE(D1>=D2,D1,D2,2,0),COLOR0077CC;
STICKLINE(D1>=D2,D1,D2,1,0),COLOR0099DD;
STICKLINE(D1>=D2,D3,D4,0,0),COLOR00BBFF;
STICKLINE(D1<=D2,D1,D2,2,0),COLOR009900;
STICKLINE(D1<=D2,D1,D2,1,0),COLOR00BB00;
STICKLINE(D1<=D2,D3,D4,0,0),COLOR00EE00;
DIF:EMA(CLOSE,SHORT)-EMA(CLOSE,LONG),COLORCYAN,LINETHICK1;
DEA:EMA(DIF,MID),COLOR66CC00,LINETHICK1;
TJ1:EMA(DEA,4),COLOR999933,LINETHICK1;
TJ2:=EMA(DIF,17),COLORBLUE,LINETHICK1;
MACD:(DIF-DEA)*2,COLORSTICK;
IF(DIF>REF(DIF,1),DIF,DRAWNULL),COLORWHITE,LINETHICK2;
IF(DEA>REF(DEA,1),DEA,DRAWNULL),COLORRED,LINETHICK2;
IF(TJ1>REF(TJ1,1),TJ1,DRAWNULL),COLORMAGENTA,LINETHICK2;
{IF(TJ2>REF(TJ2,1),TJ2,DRAWNULL),COLORWHITE,LINETHICK3;}
0,COLORGRAY,LINETHICK1;

通达信超强MACD指标公式

 

相关文章