在线检测未来函数

大智慧寂寞线主图指标公式

来源:Internet,编辑:股旁网,2016-06-16

VAR0:=BKNAME;
DRAWTEXTABS(10,2,STKLABEL + ' ' + STKNAME + ' ' + VAR0),COLORYELLOW;
VAR1:='◆ 大事提醒 ◆ ';
VAR2:='时间';
VAR3:=F10FIND(VAR2,F10FIND(VAR1,1)) + 80;
DRAWTEXTABS(0,25,'' + F10TEXT(VAR3,80)),COLORYELLOW;
VAR4:='时间 ';
VAR5:=F10FIND(VAR4,F10FIND(VAR1,1)) + 135;
DRAWTEXTABS(336,25,'' + F10TEXT(VAR5,28)),COLORYELLOW;
VAR6:=EMA(CLOSE,7);
VAR7:=EMA(CLOSE,21);
STICKLINE(CLOSE >= OPEN,CLOSE,OPEN,8,0),COLOR000055;
STICKLINE(CLOSE >= OPEN,CLOSE,OPEN,6.5,0),COLOR000075;
STICKLINE(CLOSE >= OPEN,CLOSE,OPEN,5,0),COLOR000095;
STICKLINE(CLOSE >= OPEN,CLOSE,OPEN,3.5,0),COLOR0000B5;
STICKLINE(CLOSE >= OPEN,CLOSE,OPEN,2,0),COLOR0000D5;
STICKLINE(CLOSE >= OPEN,HIGH,LOW,0.5,0),COLOR0000F5;
STICKLINE(CLOSE < OPEN,CLOSE,OPEN,8,0),COLOR303000;
STICKLINE(CLOSE < OPEN,CLOSE,OPEN,6.5,0),COLOR404000;
STICKLINE(CLOSE < OPEN,CLOSE,OPEN,5,0),COLOR505000;
STICKLINE(CLOSE < OPEN,CLOSE,OPEN,3.5,0),COLOR606000;
STICKLINE(CLOSE < OPEN,CLOSE,OPEN,2,0),COLOR707000;
STICKLINE(CLOSE < OPEN,HIGH,LOW,0.5,0),COLOR808000;
操盘线:VAR6,COLORWHITE;
VAR8:=VAR7;
PARTLINE(VAR8,VAR8 > REF(VAR8,1),RGB(255,0,0),VAR8 < REF(VAR8,1),RGB(0,255,0),1,RGB(0,0,255)),LINETHICK2;
总股本(亿):FINANCE2(35)/10000,LINETHICK0,COLORYELLOW;
流通(亿):FINANCE2(37)/10000,LINETHICK0,COLORWHITE;
VAR9:=CROSS(VAR6,VAR7);
DRAWICON(VAR9,LOW * 0.99,7),ALIGN1;
VAR10:=CROSS(VAR7,VAR6);
DRAWICON(VAR10,HIGH * 1.01,8),ALIGN1;
VAR11:="大额日线.主力#DAY";
VAR12:="大额日线.特买#DAY";
VAR13:="大额日线.特卖#DAY";
VAR14:="大额日线.大买#DAY";
VAR15:="大额日线.大卖#DAY";
VAR16:="大额日线.中买#DAY";
VAR17:="大额日线.中卖#DAY";
VAR18:="大额日线.小买#DAY";
VAR19:="大额日线.小卖#DAY";
VAR20:="大额日线.超大比#DAY";
VAR21:="大额日线.大户比#DAY";
VAR22:="大额日线.中户比#DAY";
VAR23:="大额日线.散户比#DAY";
VAR24:="大额日线.主力比#DAY";
VAR25:=VAR18 - VAR19;
VAR26:=VAR16 - VAR17;
VAR27:=VAR14 - VAR15;
VAR28:=VAR12 - VAR13;
VAR29:=VAR12 + VAR14;
VAR30:=VAR13 + VAR15;
VAR31:=VAR29 + VAR30;
VAR32:=VAR28 + VAR27;
DRAWRECTABS(30,15,80,30,1),COLOR808000;
DRAWRECTABS(80,15,130,30,1),COLOR008080;
DRAWRECTABS(80,17,IF(30 + VAR32/100 <= 100,80 + VAR32/100,100),28,1710731),COLOR1A1A8B;
DRAWRECTABS(80,19,IF(30 + VAR32/100 <= 100,80 + VAR32/100,100),26,2500301),COLOR2626CD;
DRAWRECTABS(80,21,IF(30 + VAR32/100 <= 100,80 + VAR32/100,100),24,2895086),COLOR2C2CEE;
DRAWRECTABS(80,23,IF(30 + VAR32/100 <= 100,80 + VAR32/100,100),22,3158271),COLOR3030FF;
DRAWTEXTABS(5,15,'主力 '),COLORRED;
DRAWTEXTABS(140,15,NUMTOSTRN(VAR32,2) + '元'),COLORRED;
DRAWRECTABS(30,32,80,47,1),COLOR808000;
DRAWRECTABS(80,32,130,47,1),COLOR008080;
DRAWRECTABS(80,34,IF(30 + VAR28/100 <= 100,80 + VAR28/100,100),45,9147648),COLOR8B8600;
DRAWRECTABS(80,36,IF(30 + VAR28/100 <= 100,80 + VAR28/100,100),43,13485312),COLORCDCD50;
DRAWRECTABS(80,38,IF(30 + VAR28/100 <= 100,80 + VAR28/100,100),41,15656192),COLOREEE500;
DRAWRECTABS(80,40,IF(30 + VAR28/100 <= 100,80 + VAR28/100,100),39,16774400),COLORFFF500;
DRAWTEXTABS(5,33,'特户 '),COLORCYAN;
DRAWTEXTABS(140,33,NUMTOSTRN(VAR28,2) + '元'),COLORCYAN;
DRAWRECTABS(30,50,80,65,1),COLOR808000;
DRAWRECTABS(80,50,130,65,1),COLOR008080;
DRAWRECTABS(80,52,IF(30 + VAR27/100 <= 100,80 + VAR27/100,130),63,23179),COLOR005A8B;
DRAWRECTABS(80,54,IF(30 + VAR27/100 <= 100,80 + VAR27/100,130),61,34253),COLOR0085CD;
DRAWRECTABS(80,56,IF(30 + VAR27/100 <= 100,80 + VAR27/100,130),59,39662),COLOR009AEE;
DRAWRECTABS(80,58,IF(30 + VAR27/100 <= 100,80 + VAR27/100,130),57,42495),COLOR00A5FF;
DRAWTEXTABS(5,51,'大户 '),COLORYELLOW;
DRAWTEXTABS(140,51,NUMTOSTRN(VAR27,2) + '元'),COLORYELLOW;
DRAWRECTABS(30,68,80,83,1),COLOR808000;
DRAWRECTABS(80,68,130,83,1),COLOR008080;
DRAWRECTABS(80,70,IF(30 + VAR26/100 <= 100,80 + VAR26/100,130),81,3816075),COLOR3A3A8B;
DRAWRECTABS(80,72,IF(30 + VAR26/100 <= 100,80 + VAR26/100,130),79,5592525),COLOR5555CD;
DRAWRECTABS(80,74,IF(30 + VAR26/100 <= 100,80 + VAR26/100,130),77,6513646),COLOR6363EE;
DRAWRECTABS(80,76,IF(30 + VAR26/100 <= 100,80 + VAR26/100,130),75,6974207),COLOR6A6AFF;
DRAWTEXTABS(5,69,'中户 '),COLOR8080FF;
DRAWTEXTABS(140,69,NUMTOSTRN(VAR26,2) + '元'),COLOR8080FF;
DRAWRECTABS(30,86,80,101,1),COLOR808000;
DRAWRECTABS(80,86,130,101,1),COLOR008080;
DRAWRECTABS(80,88,IF(30 + VAR25/100 <= 100,80 + VAR25/100,130),99,5245579),COLOR500A8B;
DRAWRECTABS(80,90,IF(30 + VAR25/100 <= 100,80 + VAR25/100,130),97,7737549),COLOR7610CD;
DRAWRECTABS(80,92,IF(30 + VAR25/100 <= 100,80 + VAR25/100,130),95,8983278),COLOR8912EE;
DRAWRECTABS(80,94,IF(30 + VAR25/100 <= 100,80 + VAR25/100,130),93,9639167),COLOR9314FF;
DRAWTEXTABS(5,87,'散户 '),COLORMAGENTA;
DRAWTEXTABS(140,87,NUMTOSTRN(VAR25,2) + '元'),COLORMAGENTA;

大智慧寂寞线主图指标公式

 

相关文章