在线检测未来函数

通达信专杀疯狗器指标公式

来源:Internet,编辑:股旁网,2016-06-17

{蓝灰底
买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);
STICKLINE(买线>=卖线,HHV(H,60),LLV(L,60),5,0),COLOR000045;
STICKLINE(买线<卖线,HHV(H,60),LLV(L,60),5,0),COLOR004500;}
{叠加CCI}
低1:=LLV(L,50);
低:REFDATE(低1,DATE)DOTLINE,COLORLIGRAY;
零轴:=低;
STICKLINE(C>0,1.05*零轴,0.95*零轴,4,0),COLORGRAY;
RTYP:=(HIGH+LOW+CLOSE)/3;
CCI14:=(RTYP-MA(RTYP,14))/(0.015*AVEDEV(RTYP,14))/2;
CCI84:=(RTYP-MA(RTYP,84))/(0.015*AVEDEV(RTYP,84))/2;
CCI:=零轴+CCI14 /100,COLORCYAN;
{叠加RS1}
LC:=REF(C,1);
RS1:=SMA(MAX(C-LC,0),12,1)/SMA(ABS(C-LC),12,1)+C;
见神就杀:=HHV(FORCAST(RS1,3),14),COLORLIBLUE;
DRAWBAND(RS1,RGB(218, 165, 32),见神就杀,RGB(0,2*40,0));
DRAWTEXT(ISLASTBAR,见神就杀,' --见神就杀'),COLORGREEN;
DRAWTEXT(ISLASTBAR,RS1,'-------RS1'),COLORGREEN;
A7:=EMA(CLOSE,9);
TH:=EMA(CLOSE,12);
B7:=EMA(A7,26);
T1H:=EMA(TH,26);
DEA1:=EMA(TH-(T1H-TH),2),COLORWHITE,;
DIFF1:=DEA1-EMA(((A7-B7)-(TH-T1H)),1)*6,COLORYELLOW,;
DRAWBAND(DEA1,RGB(159 ,139 ,153),DIFF1,RGB(0 ,140 ,199));
DRAWBAND(RS1,RGB(0,2*40,0),RS1,RGB(0,2*40,0));
DRAWBAND(见神就杀,RGB(0,2*40,0),见神就杀,RGB(0,2*40,0));
{叠加KDJ}
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1),;
D:=SMA(K,3,1),;
J:=3*K-2*D;
RSV1:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9));
RSV2:=(RSV1-0.5)/5*EMA(C,21);
RSVK:=SMA(RSV2,3,1);
RSVD:=SMA(RSVK,3,1);
RSVJ:=RSVK*3-RSVD*2;
KJ:RSVK+EMA(C,21),COLORWHITE,LINETHICK1,;
DJ:RSVD+EMA(C,21),COLORYELLOW,LINETHICK1;
JJ:RSVJ+EMA(C,21),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,KJ,' --K'),COLORWHITE;
DRAWTEXT(ISLASTBAR,DJ,' --D'),COLORYELLOW;
DRAWKLINE(H,O,L,C);
{叠加获利比例}
比例:=INTPART(WINNER(CLOSE)*100+0.5),COLOR00EEEE;
DRAWTEXT(CURRBARSCOUNT=5,CONST((C+O)/2),STRCAT('获利比例:',CON2STR(比例,2))),COLORWHITE;
{停牌天数>10}
停:=DATETODAY(DATE) - DATETODAY(REF(DATE,1));
DRAWTEXT(停>10,O,VARCAT('停',VAR2STR(停,0))),COLORGREEN;
DRAWTEXT(停>10,O,'停 天'),COLORGREEN;
{叠加MACD}
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACDZ:=(DIF-DEA)*2,COLORSTICK;
DRAWTEXT_FIX(1,0.45,0.98,0,'见神就杀之 专杀疯狗利器 CCI RS1 KDJ 获利比例 MACD 五合一主图 小鱼特别制作')COLORYELLOW;
RCC:低;
STICKLINE((RCC+MACDZ)>RCC AND (RCC+MACDZ)<=REF(RCC+MACDZ,1),RCC,RCC+MACDZ,1,1),COLORMAGENTA;
STICKLINE((RCC+MACDZ)>RCC AND (RCC+MACDZ)>REF(RCC+MACDZ,1),RCC,RCC+MACDZ,1,1),COLORRED;
STICKLINE((RCC+MACDZ)<=RCC AND (RCC+MACDZ)<=REF(RCC+MACDZ,1),RCC,RCC+MACDZ,1,1),COLORCYAN;
STICKLINE((RCC+MACDZ)<=RCC AND (RCC+MACDZ)>REF(RCC+MACDZ,1),RCC,RCC+MACDZ,1,1),COLORLICYAN;
DRAWTEXT(ISLASTBAR,低,'---MACD'),COLORGREEN;
零轴+CCI14 /100,COLORCYAN;
{======================================================};
Z1A:=STRCAT(HYBLOCK,' ');
Z2A:=STRCAT(Z1A,FGBLOCK);
Z3A:=STRCAT(Z2A,DYBLOCK);
Z4A:=STRCAT(Z3A,' ');
DRAWTEXT_FIX(ISLASTBAR,0.38,0.08,0,STRCAT(Z4A,GNBLOCK)),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0.45,0.04,0,STRCAT(STRCAT(+STKNAME,' '),STRCAT(CODE,' '))),COLORYELLOW;
{======================================================};
DRAWTEXT(CURRBARSCOUNT=1,CONST(CCI),STRCAT('CCI:',CON2STR(CCI,2))),COLORCYAN;
DRAWTEXT(CURRBARSCOUNT=1,CONST(JJ),STRCAT('J:',CON2STR(J,2))),COLORMAGENTA;

通达信专杀疯狗器指标公式

 

相关文章