在线检测未来函数

通达信色量色谱指标公式

来源:Internet,编辑:股旁网,2016-06-17

M3:=MA(CLOSE,3),COLORRED;
M13:=MA(CLOSE,13),COLORRED;
M34:=MA(CLOSE,34),COLORRED;
X:=BARSLAST(REF(CROSS(C,MA(C,120)),1)) AND CROSS(MA(C,20),MA(C,120));
STICKLINE(M3>=M13 AND M34>=REF(M34,1),8,9,2,0 ),COLORRED;
STICKLINE(M3<M13 AND M34>=REF(M34,1),8,9,2,0 ),COLORYELLOW;
STICKLINE(M3<M13 AND M34<REF(M34,1),8,9,2,0 ),COLORGREEN;
STICKLINE(M3>=M13 AND M34<REF(M34,1),8,9,2,0 ),COLORMAGENTA;
MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;
牛线:=(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+16*REF(MID,4)+15*REF(MID,5)+14*REF(MID,6)+13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+7*REF(MID,13)+6*REF(MID,14)+5*REF(MID,15)+4*REF(MID,16)+3*REF(MID,17)+2*REF(MID,18)+REF(MID,20))/210,COLORGREEN{COLORRED};
马线:=MA(牛线,6),COLORMAGENTA{COLORYELLOW};
STICKLINE(C>牛线,6,7,8,0),COLORRED{COLORGREEN},LINETHICK2;
STICKLINE(C<马线,6,7,8,0),COLORGREEN{COLORRED},LINETHICK2;
STICKLINE(牛线>=C AND C>=马线,6,7,8,0),COLORGREEN{COLORMAGENTA}{COLORYELLOW},LINETHICK2;
A:=MAX(MA(C,60),MA(C,120));
B:=MIN(MA(C,60),MA(C,120));
STICKLINE(C>=A,4,5,8,0),COLORRED{COLORGREEN},LINETHICK2;
STICKLINE(C<=B,4,5,8,0),COLORGREEN{COLORRED},LINETHICK2;
STICKLINE(A>=C AND C>=B,4,5,8,0),COLORGREEN{COLORMAGENTA}{COLORYELLOW},LINETHICK2;
E:=MAX(MA(C,45),MA(C,90));
F:=MIN(MA(C,45),MA(C,90));
STICKLINE(C>E,2,3,8,0),COLORRED{COLORGREEN},LINETHICK2;
STICKLINE(C<F,2,3,8,0),COLORGREEN{COLORRED},LINETHICK2;
STICKLINE(E>=C AND C>=F,2,3,8,0),COLORGREEN{COLORMAGENTA}{COLORYELLOW},LINETHICK2;
J:=MAX(MA(C,30),MA(C,60));
K:=MIN(MA(C,30),MA(C,60));
STICKLINE(C>J,0,1,8,0),COLORRED{COLORGREEN},LINETHICK2;
STICKLINE(C<K,0,1,8,0),COLORGREEN{COLORRED},LINETHICK2;
STICKLINE(J>=C AND C>=K,0,1,8,0),COLORGREEN{COLORMAGENTA}{COLORYELLOW},LINETHICK2;

通达信色量色谱指标公式

 

相关文章