在线检测未来函数

通达信抱牛不放指标公式

来源:Internet,编辑:股旁网,2016-06-21

VAR1:=MA((HIGH+LOW+2*CLOSE)/4,5);
VAR2:=EMA(VAR1,10)-EMA(VAR1,30);
VAR3:=EMA(VAR2,5);
VAR4:=(VAR2-VAR3)*5;
VAR5:=IF(VAR4<=VAR1,VAR1,VAR4);
动向:= FORCAST(FORCAST(VAR5,10),10),LINETHICK1;
趋势: IF(VAR5>动向,VAR5,VAR1),COLORYELLOW;
强势: MA(VAR1,5),COLORRED;
弱势:= MA(HHV(VAR1,10),5),COLORWHITE;
主力: SMA(CLOSE,10,1),COLORFFFF00;
疯牛: DMA(MA(CLOSE+REF(CLOSE,5)/CLOSE*0.098,90),VOL),LINETHICK2,COLORRED;
年线: DMA(MA(CLOSE+REF(CLOSE,5)/CLOSE*0.098,250),VOL),LINETHICK2,POINTDOT,COLOR30CC00;
VAR6:=EMA(CLOSE,5);
VAR7:=EMA(CLOSE,10);
VAR8:=EMA(CLOSE,20);
VAR9:=EMA(CLOSE,30);
VARA:=EMA(CLOSE,60);
VARB:=EMA(CLOSE,90);
VARC:=EMA(CLOSE,125);
VARD:=EMA(CLOSE,250);
VAR10:=1.809*LLV(LOW,250);
VAR11:=MA(CLOSE,10)-EMA(CLOSE,10)*100;
VAR12:=MA(VAR11,5);
VAR13:=3*(VAR12-VAR11);
VAR14:=((CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*200-100)/2-REF(CLOSE,5);
VAR15:=SMA(SMA(VAR14,5,1),5,1);
VAR16:=MA(MA(VAR15,5),5);
VAR17:=3*VAR16-5*VAR15;
VAR18:=EMA(VAR17,10);
VAR19:=MA(CLOSE,20)/MA(CLOSE,20)-REF(CLOSE,20)/CLOSE*100;
VAR1A:=DMA(SMA(EMA(VAR19,5),5,1),VOL/REF(VOL,5));
VAR1B:=SMA(EMA(VAR19,10),5,1);
VAR1C:=(-100)*(HHV(HIGH,13)-CLOSE)/(HHV(HIGH,13)-LLV(LOW,13));
VAR1D:=(-100)*(HHV(HIGH,8)-CLOSE)/(HHV(HIGH,8)-LLV(LOW,8));
VAR1E:=SMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),14,1);
VAR1F:=HIGH-REF(HIGH,1);
VAR20:=REF(LOW,1)-LOW;
VAR21:=SMA(IF(VAR1F>0 AND VAR1F>VAR20,VAR1F,0),14,1);
VAR22:=SMA(IF(VAR20>0 AND VAR20>VAR1F,VAR20,0),14,1);
VAR23:=VAR21*100/VAR1E;
VAR24:=VAR22*100/VAR1E;
VAR25:=SMA(ABS(VAR24-VAR23)/(VAR24+VAR23)*100,14,1);
VAR26:=(VAR25+REF(VAR25,6))/2;
DRAWTEXT(CROSS(VAR13,50) AND VAR6>VAR7 AND VAR7>VAR8 AND VAR8>VAR9 AND VAR9>VARA AND VARA>VARB AND VARB>VARC AND VARC>VARD AND 疯牛>VARD AND VAR19>VAR1A AND VAR1A>VAR1B AND VAR1B>-100 AND VAR1C>-20 AND VAR1D>-20 AND -30>VAR18 AND VAR18>VAR17 AND VAR23>VAR25 AND VAR25>VAR26 AND VAR26>VAR24,年线,'宝典'),COLORYELLOW;
DRAWTEXT(CROSS(VAR13,200) AND VAR6>VAR7 AND VAR7>VAR8 AND VAR8>VAR9 AND VAR9>VARA AND VARA>VARB AND VARB>VARC AND VARC>VARD AND VARD>年线 AND 年线>VAR10 AND VAR19>VAR1A AND VAR1A>VAR1B AND VAR1B>-100 AND VAR1C>-20 AND VAR1D>-20 AND VAR23>VAR25 AND VAR25>VAR26 AND VAR26>VAR24,年线,'疯牛'),COLORYELLOW;

通达信抱牛不放指标公式

 

相关文章