在线检测未来函数

通达信二姨妈主图指标公式

来源:Internet,编辑:股旁网,2016-06-23

{叠加CCI}
低1:=LLV(L,50);
低:REFDATE(低1,DATE)DOTLINE,COLORLIGRAY;
零轴:=低;
STICKLINE(C>0,1.05*零轴,0.95*零轴,4,0),COLORGRAY;
RTYP:=(HIGH+LOW+CLOSE)/3;
CCI14:=(RTYP-MA(RTYP,14))/(0.015*AVEDEV(RTYP,14))/2;
CCI84:=(RTYP-MA(RTYP,84))/(0.015*AVEDEV(RTYP,84))/2;
CCI:=零轴+CCI14 /100,COLORCYAN;
{叠加MACD}
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACDZ:=(DIF-DEA)*2,COLORSTICK;
RCC:低;
STICKLINE((RCC+MACDZ)>RCC AND (RCC+MACDZ)<=REF(RCC+MACDZ,1),RCC,RCC+MACDZ,1,1),COLORMAGENTA;
STICKLINE((RCC+MACDZ)>RCC AND (RCC+MACDZ)>REF(RCC+MACDZ,1),RCC,RCC+MACDZ,1,1),COLORRED;
STICKLINE((RCC+MACDZ)<=RCC AND (RCC+MACDZ)<=REF(RCC+MACDZ,1),RCC,RCC+MACDZ,1,1),COLORCYAN;
STICKLINE((RCC+MACDZ)<=RCC AND (RCC+MACDZ)>REF(RCC+MACDZ,1),RCC,RCC+MACDZ,1,1),COLORLICYAN;
DRAWTEXT(ISLASTBAR,低,'---MACD'),COLORGREEN;
零轴+CCI14 /100,COLORCYAN;
DRAWKLINE(H,O,L,C);

通达信二姨妈主图指标公式

 

相关文章