在线检测未来函数

通达信大波段操作指标公式

来源:Internet,编辑:股旁网,2016-06-29

{用法:1.DIF线上穿DRA线(金叉),指标中显示“买入=1”、红三角形和“波谷”,买入;2.买入次日股价下破MA5日均线,止损;3.股价回踩MA5日均线不破,加仓;4.DIF线下破DRA线(死叉),指标中显示“波峰”,卖出;}

VAR1:=IF(DATE<1340830 AND DATE>900101,1,0);
VAR2:=IF(MONTH<12,1,100000);
VAR3:=(2*CLOSE+HIGH+LOW)/4;
VAR4:=LLV(LOW,34);
VAR5:=HHV(HIGH,34);
DIF:EMA((VAR3-VAR4)/(VAR5-VAR4)*100,13),LINETHICK2;
DEA:EMA(0.667*REF(DIF,1)+0.333*DIF,2),LINETHICK1;
QS:IF(CROSS(DIF,DEA) AND DIF<40,25,10),COLORRED;
买入:QS=25 AND CROSS(MA(CLOSE,5),MA(CLOSE,10)),LINETHICK0;
DRAWTEXT(CROSS(DIF,DEA) AND DIF<22,20,'波谷'),COLORGREEN;
DRAWICON(CROSS(DIF,DEA) AND DIF<22,25,1);
DRAWTEXT(CROSS(DIF,30) AND DEA<DIF,40,'初波段'),COLORWHITE;
DRAWICON(CROSS(DIF,30) AND DEA<DIF,35,1);
DRAWTEXT(CROSS(DIF,65) AND DEA<DIF,55,'中波段'),COLORFF00FF;
DRAWICON(CROSS(DIF,65) AND DEA<DIF,70,2);
DRAWTEXT(CROSS(DIF,75) AND DEA<DIF,67,'高波段'),COLORYELLOW;
DRAWICON(CROSS(DIF,75) AND DEA<DIF,80,2);
DRAWTEXT(CROSS(DEA,DIF) AND DEA>75,80,'波峰'),COLORRED;
DRAWICON(CROSS(DEA,DIF) AND DEA>75,85,2);

通达信大波段操作指标公式

 

相关文章