在线检测未来函数

通达信金榜王指标公式

来源:Internet,编辑:股旁网,2016-06-27

VAR1:=(C-MA(C,6))/MA(C,6)*100;
VAR2:=(C-MA(C,24))/MA(C,24)*100;
VAR3:=(C-MA(C,32))/MA(C,32)*100;
VAR4:=(VAR1+VAR2+VAR3)/3;
VAR5:=EMA(VAR4,5);
VAR6:=MA(100*(C-LLV(C,34))/(HHV(H,34)-LLV(L,34)),5)-20;
VAR7:=SMA(SMA(100-3*(C-LLV(C,75))/(HHV(H,75)-LLV(L,75))*100,20,1)+SMA(2*(C-LLV(C,75))/(HHV(H,75)-LLV(L,75))*100,20,1),15,1);
VAR8:=VAR7<REF(VAR7,1) AND V>REF(V,1) AND C>REF(C,1);
K:EMA(VAR5,5);
D:EMA(K,5),NODRAW,COLOR38B0DE;
J:K*3-D*2,COLORCC66FF;
MACDK:EMA(EMA(VAR1,5),5),COLORSTICK;
J02:=J-REF(J,1);
DRAWTEXT(J>K&&CROSS(0.5,J02),MACDK,'卖出1'),COLORGREEN;
MAK:=MACDK*1.5;
DRAWTEXT(J<K&&CROSS(J02,-0.5),MAK,'买1'),COLORMAGENTA;
MM1:=MA(CLOSE,5);
Q5:(MM1-REF(MM1,1))/REF(MM1,1)*100,NODRAW,COLORMAGENTA;
IF(J<REF(J,1),J,DRAWNULL),CIRCLEDOT,COLORGREEN;
IF(J>REF(J,1),J,DRAWNULL),CIRCLEDOT,COLORRED;
IF(J<K&&J02>-0.5,J,DRAWNULL),CIRCLEDOT,COLORMAGENTA;
IF(J<K&&J02<-0.5,J,DRAWNULL),CIRCLEDOT,COLORGREEN;
IF(J<K&&REF(J02,1)>-0.5&&J02<0.5,J,DRAWNULL),CIRCLEDOT,COLORGREEN;
IF(J>K&&J02>0.5,J,DRAWNULL),CIRCLEDOT,COLORRED;
IF(J>K&&J02<0.5,J,DRAWNULL),CIRCLEDOT,COLORGREEN;
J03:=J-K;
DRAWTEXT(EVERY(J>K,4)&&J03<2&&CROSS(J02,0.5),MACDK,'买2'),COLORMAGENTA;
DRAWTEXT(EVERY(J>K,4)&&K<0&&CROSS(J02,0.5),MACDK,'买3'),COLORMAGENTA;
STICKLINE(MACDK>REF(MACDK,1)&&MACDK<0,MACDK,0,2,1),COLORMAGENTA;
STICKLINE(MACDK<REF(MACDK,1)&&MACDK<0,MACDK,0,2,0),COLORGREEN;
STICKLINE(MACDK>REF(MACDK,1)&&MACDK>0,MACDK,0,2,0),COLORRED;
STICKLINE(MACDK<REF(MACDK,1)&&MACDK>0,MACDK,0,2,1),COLORGREEN;
AA:=BARSCOUNT(C);
AH:=HHV(H,200);
AL:=LLV(L,200);
A0:=(AH-AL)/40;
B1:=L-A0;
DRAWTEXT((AA+0)/34=FLOOR((AA+0)/34),K,'时间窗,变盘'),COLORWHITE;
RSVK:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 100);
KK:=SMA(RSVK,3,1);
DK:=SMA(KK,3,1);
JK:=3*KK-2*DK;
XK:=LLV(JK,2)=LLV(JK,8);
REK:=CROSS(JK,REF(JK+0.01,1)) AND XK AND JK<19;
DRAWTEXT(REK,K,'反弹1'),COLORYELLOW;
CSS:=((CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100);
HH:=CROSS(20,EMA(CSS,3));
CE:=REF(HH,1);
AAK:=REF(CLOSE,1);
BBB:=SMA(MAX(CLOSE-AAK,0),5,1)/SMA(ABS(CLOSE-AAK),5,1)*1000;
HHH:=BBB-LLV(BBB,10);
SS:=(MA(HHH,2)*3+HHH*13)/16;
短线买点:=IF(SS>13,MA(SS,2),SS)/6;
短线出击:=IF(CROSS(短线买点,1) AND (短线买点<30),30,1);
II:=短线出击=30;
DRAWTEXT(CE AND II,J,'短线反转'),COLORWHITE;

通达信金榜王指标公式

 

相关文章