在线检测未来函数

通达信张氏天数主图指标公式

来源:Internet,编辑:股旁网,2016-06-28

MA1:EMA(C,30),COLORYELLOW;
MA2:EMA(C,60),COLOR00FF00;
MA3:EMA(C,120),COLORF00FF0;
MA4:EMA(C,240),COLORWHITE;
A1:=MA(C,0);
A2:=MA(C,0);
A3:=(A1+A2)/2;
IF (A1>A2,A1,A3),COLORRED,LINETHICK2;
IF (A1>A2,A2,A3),COLORRED,LINETHICK2;
IF (A1<=A2,A1,A3),COLOR00FF00,LINETHICK2;
IF (A1<=A2,A2,A3),COLOR00FF00,LINETHICK2;
A3,COLORWHITE,LINETHICK2;
VAR31:=HHVBARS(ZIG(3, 19)>REF(ZIG(3,19),1)
AND REF(ZIG(3,19), 1)<REF(ZIG(3,19), 2),0);
STICKLINE(VAR31=2,L*0.95,L*0.98,3,0),COLOR0000FF;
DRAWTEXT(VAR31=2,L*0.95,'3天'),COLORYELLOW;
STICKLINE(VAR31=4,H*1.05,H*1.02,3,0),COLOR9966FF;
DRAWTEXT(VAR31=4,H*1.06,'5天'),COLORYELLOW;
STICKLINE(VAR31=7,L*0.95,L*0.98,3,0),COLOR00FFFF;
DRAWTEXT(VAR31=7,L*0.95,'8天'),COLORYELLOW;
STICKLINE(VAR31=12,H*1.05,H*1.02,3,0),COLORFF33FF;
DRAWTEXT(VAR31=12,H*1.06,'13天'),COLORYELLOW;
STICKLINE(VAR31=20,L*0.95,L*0.98,3,0),COLOR0066FF;
DRAWTEXT(VAR31=20,L*0.95,'21天'),COLORYELLOW;
STICKLINE(VAR31=33,H*1.05,H*1.02,3,0),COLORFFFF00;
DRAWTEXT(VAR31=33,H*1.06,'34天'),COLORYELLOW;
STICKLINE(VAR31=54,L*0.95,L*0.98,3,0),COLOR006600;
DRAWTEXT(VAR31=54,L*0.95,'55天'),COLORYELLOW;
STICKLINE(VAR31=88,H*1.05,H*1.02,3,0),COLOR00FF00;
DRAWTEXT(VAR31=88,H*1.06,'89天'),COLORYELLOW;
STICKLINE(VAR31=143,L*0.95,L*0.98,3,0),COLORCCFFFF;
DRAWTEXT(VAR31=143,L*0.95,'144天'),COLORYELLOW;
STICKLINE(VAR31=232 ,H*1.05,H*1.02,3,0),COLORFF0033;
DRAWTEXT(VAR31=232,H*1.06,'233天'),COLORYELLOW;
STICKLINE(VAR31=376,L*0.95,L*0.98,3,0),COLORFF9966;
DRAWTEXT(VAR31=376,L*0.95,'377天'),COLORYELLOW;

通达信张氏天数主图指标公式

 

相关文章