在线检测未来函数

通达信DMI简单化指标公式

来源:Internet,编辑:股旁网,2016-07-04

N:=14;MM:=6;
VAR1:=REF(MA(C,20),10);开:=O-VAR1;高:=H-VAR1;低:=L-VAR1;收:=C-VAR1;
DRAWBAND(0,RGB(0,103,163),20,RGB(0,103,163));
DRAWBAND(20,RGB(0,45,66),30,RGB(0,45,66));
DRAWBAND(30,RGB(0,74,111),100,RGB(0,74,111));
MTR:=EXPMEMA(MAX(MAX(高-低,ABS(高-REF(收,1))),ABS(REF(收,1)-低)),N);
HD :=高-REF(高,1);
LD :=REF(低,1)-低;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),N);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),N);
上升方向线: DMP*100/MTR,COLORRED;
下降方向线: DMM*100/MTR,COLORGREEN;
趋向平均值: EXPMEMA(ABS(下降方向线-上升方向线)/(下降方向线+上升方向线)*100,MM)COLORWHITE;
平衡平均值:HHV(FORCAST(趋向平均值,5),10)*0.93,COLORMAGENTA;
STICKLINE(趋向平均值>平衡平均值,平衡平均值,趋向平均值,2,0),COLORYELLOW;

通达信DMI简单化指标公式

 

相关文章