在线检测未来函数

通达信CCI叠加KDJ指标公式

来源:Internet,编辑:股旁网,2016-07-06

DRAWGBK(C>0, RGB(1,1,1),RGB(1,1,1),0,'0',0);
STICKLINE(C>0,80,100,28,0)COLOR242424;
STICKLINE(C>0,20,0,28,0)COLOR242424;
STICKLINE(C>0,50,50,28,-1)COLORWHITE;
STICKLINE(C>0,100/3+50,100/3+50,28,-1)COLORWHITE;
STICKLINE(C>0,-100/3+50,-100/3+50,28,-1)COLORWHITE;
DRAWTEXT(ISLASTBAR,50,' ██'),COLORBLACK;
DRAWTEXT(ISLASTBAR,50,' 0'),COLORWHITE;
DRAWTEXT(ISLASTBAR,100/3+50,' ███'),COLORBLACK;
DRAWTEXT(ISLASTBAR,100/3+50,' 100'),COLORWHITE;
DRAWTEXT(ISLASTBAR,-100/3+50,' ████'),COLORBLACK;
DRAWTEXT(ISLASTBAR,-100/3+50,' -100'),COLORWHITE;
N1:=9;M1:=3;M2:=3;
RSV:=(CLOSE-LLV(LOW,N1))/(HHV(HIGH,N1)-LLV(LOW,N1))*100;
K:SMA(RSV,M1,1)COLORCYAN,NODRAW;
D:SMA(K,M2,1)COLOR0080FF,NODRAW;
J:3*K-2*D,COLORRED,NODRAW;
DRAWBAND(J,RGB(200,50,50),D,RGB(0,50,150));
N:=14;
TYP:=(HIGH+LOW+CLOSE)/3;
真实CCI:(TYP-MA(TYP,N))/(0.015*AVEDEV(TYP,N)),COLORYELLOW,NODRAW;
真实CCI均线:EXPMA(真实CCI,5),COLORGREEN,NODRAW;
NOTEXT压缩:真实CCI/3+50,COLORYELLOW;
NOTEXT趋势:真实CCI均线/3+50,COLORGREEN;
DRAWTEXT_FIX(C>0,0.5,0,0,'红蓝彩条是KDJ,黄线CCI,绿色CCI均线'),COLORWHITE;

通达信CCI叠加KDJ指标公式

 

相关文章