在线检测未来函数

通达信我是高手指标公式

来源:Internet,编辑:股旁网,2016-07-07

VAR2:=1/WINNER(CLOSE);
VAR3:=MA(CLOSE,13);
VAR4:=100-ABS((CLOSE-VAR3)/VAR3*100);
VAR5:=LLV(LOW,75);
VAR6:=HHV(HIGH,75);
VAR7:=(VAR6-VAR5)/100;
VAR8:=SMA((CLOSE-VAR5)/VAR7,20,1);
VAR9:=SMA((OPEN-VAR5)/VAR7,20,1);
VARA:=3*VAR8-2*SMA(VAR8,15,1);
VARB:=3*VAR9-2*SMA(VAR9,15,1);
VARC:=100-VARB;
我是高手: (100-VARA),NODRAW,LINETHICK4,COLORRED ;
散户: MA(WINNER(CLOSE*0.95)*100,3), , COLORYELLOW;
庄家: (100-IF(VAR2>5,IF(VAR2<100,VAR2,VAR4-10),0)),COLORCYAN;
VARD:=散户>VAR4;
VARE:=REF(LOW,1)*0.9;
VARF:=LOW*0.9;
VAR10:=(VARF*VOL+VARE*(CAPITAL-VOL))/CAPITAL;
VAR11:=EMA(VAR10,30);
VAR12:=CLOSE-REF(CLOSE,1);
VAR13:=MAX(VAR12,0);
VAR14:=ABS(VAR12);
VAR15:=SMA(VAR13,7,1)/SMA(VAR14,7,1)*100;
VAR16:=SMA(VAR13,13,1)/SMA(VAR14,13,1)*100;
VAR17:=BARSCOUNT(CLOSE);
VAR18:=SMA(MAX(VAR12,0),6,1)/SMA(ABS(VAR12),6,1)*100;
VAR19:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;
VAR1A:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
VAR1B:=SMA((SMA(VAR1A,4,1)-50)*2,3,1);
VAR1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
VAR1D:=SMA(VAR1C,4,1);
VAR1E:=SMA(VAR1D,3,1);
VAR1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
VAR20:=VAR18<=25 AND VAR19<-95 AND VAR1F>20 AND VAR1B<-30 AND VAR1E<30 AND VAR11-CLOSE>=-0.25 AND VAR15<22 AND VAR16<28 AND VAR17>50;
VAR21:=(HIGH+LOW+CLOSE)/3;
VAR22:=(VAR21-MA(VAR21,14))/(0.015*AVEDEV(VAR21,14));
VAR23:=(VAR21-MA(VAR21,70))/(0.015*AVEDEV(VAR21,70));
VAR24:=IF(VAR22>=150 AND VAR22<200 AND VAR23>=150 AND VAR23<200,10,0);
VAR25:=IF(VAR22<=-150 AND VAR22>-200 AND VAR23<=-150 AND VAR23>-200,-10,VAR24);
(50%线): IF(VAR23>=200 AND VAR22>=150,15,IF(VAR23<=-200 AND VAR22<=-150,-15,VAR25))+50,LINETHICK2,COLORYELLOW,DOTLINE;
STICKLINE(VARD,VAR4,散户,5,0), , COLORRED;
STICKLINE(1,散户,0,1,0), ,COLORYELLOW,COLORCYAN;
STICKLINE(1,庄家,100,1,0), , COLORGREEN,COLORMAGENTA;
STICKLINE(VAR20,0,80,5,0),LINETHICK3,COLORRED,;
DRAWTEXT(CROSS(VAR20,0.5) AND COUNT(VAR20=1,10)=1,60,'战神出击!'),LINETHICK7 , COLORYELLOW;
DRAWTEXT(CROSS(VARD,0.5) AND COUNT(VARD=1,10)=1,70,'赚钱走人!'),LINETHICK7 , COLORRED;
VAR26:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
VAR27:=REVERSE(VAR26);
VAR28:=SMA(VAR26,3,1);
生命线: SMA(VAR28,3,1),LINETHICK2,COLORRED ;
魔鬼线: SMA(生命线,3,1),LINETHICK2 , COLORYELLOW;
你哭了: IF(CROSS(生命线,魔鬼线) AND 生命线<40,35,0),LINETHICK2 , COLORRED;
我笑了: IF(CROSS(魔鬼线,生命线) AND 魔鬼线>75,70,100),LINETHICK2 , COLORGREEN,COLORCYAN;
DRAWTEXT(CROSS(生命线,魔鬼线) AND 生命线<40,25,'高手出击!'),LINETHICK , COLORWHITE;
DRAWTEXT(CROSS(魔鬼线,生命线) AND 魔鬼线>75,85,'减'),LINETHICK;

通达信我是高手指标公式

 

相关文章