在线检测未来函数

通达信英雄二号主图指标公式

来源:Internet,编辑:股旁网,2016-07-11

DRAWBAND(REVERSE(IF(((H+L+O+C)/4)>MA(3*((H+L+O+C)/4)-2*SMA(((H+L+O+C)/4),2,1),12),((H+L+O+C)/4),MA(3*((H+L+O+C)/4)-2*SMA(((H+L+O+C)/4),2,1),12)))+2*MA(3*((H+L+O+C)/4)-2*SMA(((H+L+O+C)/4),2,1),12),RGB(155,0,255),LLV(C,420),RGB(0,190,255));
STICKLINE(C>=MA(C,45),MA(C,45),MA(C,45*0.78),4,0),COLOR4080FF;
STICKLINE(C<MA(C,45),MA(C,45),MA(C,45*0.78),4,0),COLORFF8000;
AAA:=(3*C+H+L+O)/6;
VAR1:(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)+4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36;
VAR6:(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,6))/3;
DRAWBAND(VAR1,RGB(255,0,255),VAR6,RGB(0,255,0));
DRAWKLINE(H,O,L,C);
支撑:REVERSE(IF(((H+L+O+C)/4)>MA(3*((H+L+O+C)/4)-2*SMA(((H+L+O+C)/4),2,1),12),((H+L+O+C)/4),MA(3*((H+L+O+C)/4)-2*SMA(((H+L+O+C)/4),2,1),12)))+2*MA(3*((H+L+O+C)/4)-2*SMA(((H+L+O+C)/4),2,1),12),COLOR00FF00,LINETHICK2;
每股公积:FINANCE(18)/1,NODRAW,COLORGREEN;
未分利润:FINANCE(32)/1,NODRAW,COLORGREEN;
所属板块:=STRCAT('所属板块: ',STRCAT(STRCAT(STRCAT('[行业]-',HYBLOCK),STRCAT(' [地域]-',DYBLOCK)),STRCAT(' [概念]-',GNBLOCK)));
总股本:=STRCAT(STRCAT('总股本: ',CON2STR(TOTALCAPITAL/1000000,2)),'亿');
流通盘:=STRCAT(STRCAT(' 流通盘: ',CON2STR(CAPITAL/1000000,2)),'亿');
全流通:=STRCAT(' 全流通: ',CON2STR((CAPITAL/1000000)/(TOTALCAPITAL/1000000),2));
市值:=STRCAT(STRCAT(' 流通市值: ',CON2STR((CAPITAL/1000000)*C,2)),'亿');
股本市值:=STRCAT('股本市值: ',STRCAT(STRCAT(STRCAT(总股本,流通盘),全流通),市值));
{业绩}
净资收益率:=STRCAT(' 净资收益率: ',CON2STR(FINANCE(29)/FINANCE(19)*100,2));
毛利率:=STRCAT(' 毛利率: ',CON2STR((FINANCE(20)-FINANCE(21))/FINANCE(20)*100,2));
主营利润率:=STRCAT(' 主营利润率 ',CON2STR(FINANCE(23)/FINANCE(20)*100,2));
当前业绩:=STRCAT('当前业绩: ',STRCAT(STRCAT(净资收益率,毛利率),主营利润率));
{主图显示}
DRAWTEXT_FIX(ISLASTBAR,0.005,0.0,0,所属板块),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0.005,0.04,0,股本市值),COLORGREEN;
DRAWTEXT_FIX(ISLASTBAR,0.005,0.08,0,当前业绩),COLORGREEN;

通达信英雄二号主图指标公式

 

相关文章