在线检测未来函数

通达信猎手之路主图指标公式

来源:Internet,编辑:股旁网,2016-07-13

猎手之路:IF(MA(C,5)>REF(MA(C,5),1),MA(C,5),DRAWNULL)COLORYELLOW,LINETHICK2;
LS01:=C>REF(C,1) AND C>REF(C,2);
LS02:=REF(LS01,1) AND C<=REF(C,1) AND C>=REF(C,2);
LS03:=REF(LS02,1) AND C>=REF(C,1) AND C<=REF(C,2);
LS04:=REF(LS03,1) AND C<=REF(C,1) AND C>=REF(C,2);
LS05:=REF(LS04,1) AND C>=REF(C,1) AND C<=REF(C,2);
LS06:=REF(LS05,1) AND C<=REF(C,1) AND C>=REF(C,2);
LS07:=REF(LS06,1) AND C>=REF(C,1) AND C<=REF(C,2);
LS08:=REF(LS07,1) AND C<=REF(C,1) AND C>=REF(C,2);
LS09:=REF(LS08,1) AND C>=REF(C,1) AND C<=REF(C,2);
LS10:=REF(LS09,1) AND C<=REF(C,1) AND C>=REF(C,2);
LS11:=REF(LS10,1) AND C>=REF(C,1) AND C<=REF(C,2);
LS12:=REF(LS11,1) AND C<=REF(C,1) AND C>=REF(C,2);
LS13:=C<REF(C,1) AND C<REF(C,2);
LS14:=REF(LS01 OR LS02 OR LS03 OR LS04 OR LS05 OR LS06 OR LS07 OR
LS08 OR LS09 OR LS10 OR LS11 OR LS12,1) AND LS13;
DRAWICON(LS14=1,H,2);
{多空平台}
LS15:=(L+H+C*2)/4;
LS16:=EMA(LS15,14);
LS17:=EMA(LS15,25);
LS18:=(LS16-REF(LS16,1))/REF(LS16,1)*100;
LS19:=(LS17-REF(LS17,1))/REF(LS17,1)*100;
看多平台:IF(LS18>=0 AND BARSLAST(CROSS(LS18,0))>0,REF((C+O)/2,BARSLAST(CROSS(LS18,0))),DRAWNULL)DOTLINE,COLORFF00FF;
看空平台:IF(LS18<0 AND BARSLAST(CROSS(0,LS18))>0,REF((C+O)/2,BARSLAST(CROSS(0,LS18))),DRAWNULL)DOTLINE,COLOR40FF00;
{猎手-飞哥自创逃顶--免费版}
猎枪:=IF(YEAR>=2099 AND MONTH>2,0,1);
猎户:=EMA((((2*C+H+L)/4)-LLV(L,5))/(HHV(H,4)-LLV(L,5))*100,4)*猎枪;
猎物:=EMA(0.667*REF(猎户,1)+0.333*猎户,2)*猎枪;
DRAWICON(CROSS(猎物,猎户) AND 猎户>70,H,2),COLORGREEN;
{预测当天最低价公式}
A1:=REF(O,1);
A2:=ABS((REF(C,1)-A1)/A1);
A3:=ABS((REF(H,1)-A1)/A1);
A4:=ABS((REF(L,1)-A1)/A1);
B1:=ABS((A2+A3+A4)/3);
B2:=O*B1;
预测低一:=O-B2;
预测高一:=O+B2;
今日保护价:(REF(C,2)+REF(C,1)+O)/3 ,COLOR4080FF,NODRAW;
开盘价1:=OPEN;
开盘价2:=REF(OPEN,1);
最高价1:=HIGH;
最高价2:=REF(HIGH,1);
最低价1:=LOW;
最低价2:=REF(LOW,1);
收盘价1:=CLOSE;
收盘价2:=REF(CLOSE,1);
AA:=最高价2;
BB:=最低价2;
CC:=开盘价2;
DD:=收盘价2;
EE:=(AA+BB+CC+2*DD)/5;
AAA:=EE+(AA-BB);
BBB:=2*EE-BB;
CCC:=2*EE-AA;
DDD:=EE-(AA-BB);
上升突破价:=AAA;
上升阻力价:=BBB;
下跌支撑价:=CCC;
下跌反转价:=DDD;
EEE:=(EE+上升突破价+上升阻力价+下跌支撑价+下跌反转价)/5;
心理价:=EEE;
FFF:=(EEE+开盘价1)/2;
GGG:=(预测低一+FFF)/2;
预测低二:=GGG;
{预测今日最高价公式}
预测高二:=MA(REF(HIGH,1)/REF(CLOSE,2),27)*REF(CLOSE,1);
DRAWTEXT_FIX(1,0.04,0.15,0,'预测低一:'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.10,0.15,0,CONST(预测低一)),COLORYELLOW;
DRAWTEXT_FIX(1,0.15,0.15,0,'元'),COLORYELLOW,LINETHICK1;
DRAWTEXT_FIX(1,0.04,0.20,0,'预测高一:'),COLORFFFFFF;
DRAWNUMBER_FIX(1,0.10,0.20,0,CONST(预测高一)),COLORFFFFFF;
DRAWTEXT_FIX(1,0.15,0.20,0,'元'),COLORFFFFFF,LINETHICK1;
DRAWTEXT_FIX(1,0.18,0.15,0,'预测低二:'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.24,0.15,0,CONST(预测低二)),COLORYELLOW;
DRAWTEXT_FIX(1,0.29,0.15,0,'元'),COLORYELLOW,LINETHICK1;
DRAWTEXT_FIX(1,0.18,0.20,0,'预测高二:'),COLORFFFFFF;
DRAWNUMBER_FIX(1,0.24,0.20,0,CONST(预测高二)),COLORFFFFFF;
DRAWTEXT_FIX(1,0.29,0.20,0,'元'),COLORFFFFFF,LINETHICK1;
买回价:=预测低二*1.015;
卖出价:=买回价*(1.03);
DRAWTEXT_FIX(1,0.04,0.10,0,'卖出价:'),COLOR8080FF,LINETHICK1;
DRAWNUMBER_FIX(1,0.10,0.10,0,CONST(卖出价)),COLOR8080FF;
DRAWTEXT_FIX(1,0.15,0.10,0,'元'),COLOR8080FF,LINETHICK1;
DRAWTEXT_FIX(1,0.18,0.10,0,'买回价:'),COLOR8080FF,LINETHICK1;
DRAWNUMBER_FIX(1,0.24,0.10,0,CONST(买回价)),COLOR8080FF;
DRAWTEXT_FIX(1,0.29,0.10,0,'元'),COLOR8080FF,LINETHICK1;
DRAWTEXT_FIX(1,0.01,0.02,0,'★ ======================================= ★'),COLORRED;
DRAWTEXT_FIX(1,0.12,0.05,0,'T+0 参考操作'),COLORFFFFFF;
DRAWTEXT_FIX(1,0.01,0.08,0,'三 '),COLOR0000FF;
DRAWTEXT_FIX(1,0.01,0.12,0,'思'),COLOR0000FF;
DRAWTEXT_FIX(1,0.01,0.16,0,'后'),COLOR0000FF;
DRAWTEXT_FIX(1,0.01,0.20,0,'行'),COLOR0000FF;
DRAWTEXT_FIX(1,0.32,0.08,0,'谨'),COLOR0000FF;
DRAWTEXT_FIX(1,0.32,0.12,0,'慎'),COLOR0000FF;
DRAWTEXT_FIX(1,0.32,0.16,0,'操'),COLOR0000FF;
DRAWTEXT_FIX(1,0.32,0.20,0,'作'),COLOR0000FF;
DRAWTEXT_FIX(1,0.01,0.24,0,'★ ======================================= ★'),COLORRED;
总额:=AMOUNT;
买:=IF(O=C AND (C-REF(C,1))/REF(C,1)*100>9.8,AMOUNT,AMOUNT/((H-L)*2-ABS(O-C))*(C-L));
买%:=买/AMOUNT*100;
流入:=AMOUNT*买%/10000000000;
流出:=AMOUNT/100000000-流入;
净流:=(流入-流出);
总额3:=SUM(AMOUNT,3);
流入3:=SUM(流入,3);
流出3:=SUM(流出,3);
净流3:=SUM(流入-流出,3);
总额5:=SUM(AMOUNT,5);
流入5:=SUM(流入,5);
流出5:=SUM(流出,5);
净流5:=SUM(流入-流出,5);
总额10:=SUM(AMOUNT,10);
流入10:=SUM(流入,10);
流出10:=SUM(流出,10);
净流10:=SUM(流入-流出,10);
画:=CONST(FINDHIGH(总额10,0,190,1));
DRAWTEXT_FIX(1,0.71,0.07,0,'净流(亿):'),COLOR8080FF,COLORWHITE;
DRAWTEXT_FIX(1,0.78,0.05,0,'1日'),COLOR8080FF,COLORWHITE;
DRAWTEXT_FIX(1,0.83,0.05,0,'3日'),COLOR8080FF,COLORWHITE;
DRAWTEXT_FIX(1,0.88,0.05,0,'5日'),COLOR8080FF,COLORWHITE;
DRAWTEXT_FIX(1,0.93,0.05,0,'10日'),COLOR8080FF,COLORWHITE;
DRAWNUMBER_FIX(1,0.78,0.10,0,CONST((净流))),COLORYELLOW;
DRAWNUMBER_FIX(1,0.83,0.10,0,CONST((净流3))),COLORYELLOW;
DRAWNUMBER_FIX(1,0.88,0.10,0,CONST((净流5))),COLORYELLOW;
DRAWNUMBER_FIX(1,0.93,0.10,0,CONST((净流10))),COLORYELLOW;

通达信猎手之路主图指标公式

 

相关文章