在线检测未来函数

同花顺鼎牛伏击涨停主图指标公式

来源:Internet,编辑:股旁网,2016-07-15

MA3D:=MA(C,3);
MA5D:=MA(C,5);
ZX:=(MA3D+MA5D)/2;
MA20D:=MA(C,20),NODRAW;
MA30D:=MA(C,30),NODRAW;
QSXS:=MA5D>=MA30D AND MA30D>REF(MA30D,1);
GD:=ZX>=REF(ZX,1) AND REF(ZX,1)<REF(ZX,2);
YB:=C>REF((O-C)/2+C,2);
买:=CROSS(C,ZX) AND (GD OR YB) AND QSXS,COLOR00FF00,POINTDOT,LINETHICK0;
{DRAWTEXT(买,L*0.99, '波段伏击'),COLOR00FF00;}
DRAWTEXT_FIX(CURRBARSCOUNT=60,0.4,0.01,0,''),colorgreen;
优:=买 AND MA5D>REF(MA5D,1),coloryellow,POINTDOT,LINETHICK0;
STICKLINE(买,H,L,0,1),COLOR00FF00,LINETHICK2;
STICKLINE(买,O,C,4.1,0),COLOR00FF00,LINETHICK2;
STICKLINE(优,H,L,0,1),coloryellow,LINETHICK2;
STICKLINE(优,O,C,4,0),coloryellow,LINETHICK2;
{STICKLINE(CLOSE<OPEN ,HIGH,LOW,0,0),COLOR555500;
STICKLINE(CLOSE<OPEN,CLOSE,OPEN,3.05,0),COLOR888800;
STICKLINE(CLOSE<OPEN ,CLOSE,OPEN,2.75,0),COLORAAAA00;
STICKLINE(CLOSE<OPEN,CLOSE,OPEN,2.05,0),COLORCCCC00;
STICKLINE(CLOSE<OPEN ,CLOSE,OPEN,1.75,0),COLOREEEE00;
STICKLINE(CLOSE<OPEN ,CLOSE,OPEN,1.05,0),COLORFFFF00;}
{STICKLINE(OPEN<CLOSE ,HIGH,LOW,0,0),COLOR000088;
STICKLINE(OPEN<CLOSE,CLOSE,OPEN,3.05,0),COLOR000088;
STICKLINE(OPEN<CLOSE ,CLOSE,OPEN,2.55,0),COLOR000099;
STICKLINE(OPEN<CLOSE ,CLOSE,OPEN,1.85,0),COLOR0000AA;
STICKLINE(OPEN<CLOSE ,CLOSE,OPEN,1.35,0),COLOR0000BB;
STICKLINE(OPEN<CLOSE ,CLOSE,OPEN,0.85,0),COLOR0000CC;
STICKLINE(OPEN<CLOSE ,CLOSE,OPEN,0.35,0),,COLOR0000DD;
}
MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;
红线上牛股起:(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+16*REF(MID,4)+15*REF(MID,5)+14*REF(MID,6)+13*REF(MID,7)+
12*REF(MID,8)+11*REF(MID,9)+10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+7*REF(MID,13)+6*REF(MID,14)+
5*REF(MID,15)+4*REF(MID,16)+3*REF(MID,17)+2*REF(MID,18)+REF(MID,20))/210,colorred
,LINETHICK2;
绿线下熊股出:MA(红线上牛股起,6),colorgreen
,LINETHICK2;
均价线:=AMOUNT/V/100,POINTDOT;
C2:=REF(C,1);
UPQK:=LOW-REF(HIGH,1);
STICKLINE(CLOSE>REF(CLOSE,1) AND UPQK>0,REF(HIGH,1),LOW,4,0),colorgray;
DOWNQK:=REF(LOW,1)-HIGH;
STICKLINE(CLOSE<REF(CLOSE,1) AND DOWNQK>0,REF(LOW,1),HIGH,3.05,0),colorblue;
N:=10;M:=9;
VAB0:=531;VAB1:=1510000;
VAB2:=VAB0 + VAB1;
A:=SMA(L,4,3) ;
B1:='┄┄┄┄┄';
VAB3:=IF(DATE > VAB2,0,1);
B3:='┄┄┄┄┄';
涨停:=IF(REF(C,1)*1.1*VAB3-C<0.01 ,1,0);
DRAWTEXT((O+C)/2 AND 涨停,(O+C)/2 ,B3),colormagenta;
B2:='┄┄┄┄┄';
DRAWTEXT(涨停,L,B2),colorgray;
MA5:=MA(C,5);
MA21:=MA(C,21);
涨停密码线:(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4,colorwhite;
LC:=REF(CLOSE,1);
第一操盘线:=SMA(MAX(CLOSE-LC,0),2,1)/SMA(ABS(CLOSE-LC),2,1)*100,colorwhite,LINETHICK2;
趋势线:=SMA(MAX(CLOSE-LC,0),14,1)/SMA(ABS(CLOSE-LC),14,1)*100,colorgray;
震仓线:=45,colormagenta;
震仓线2:=50,colorgray;
逃命线:=80,colorred;
抄底线:=20,colorgreen;
绝底线:=5,colorblue;
VARA12:=SMA(H,10,9)*VAB3;
VARA13:=SMA(L,10,9)*VAB3;
PP2:=第一操盘线<震仓线2 AND REF(第一操盘线,1)>震仓线2 ;
PP:=第一操盘线<震仓线 AND REF(第一操盘线,1)>震仓线 ;
PP3:=第一操盘线<抄底线 AND REF(第一操盘线,1)>抄底线;
HH:=COUNT(涨停,13)>=1;
HD:=COUNT(涨停,21)>=1;
A1:=SMA(H,N,M);
STICKLINE(A1 AND HD ,A1,A1*1.001,0.3,0),colorwhite;
A2:=SMA(L,N,M);
{STICKLINE(涨停,OPEN,CLOSE,3,0),colorred;
STICKLINE(涨停,OPEN,CLOSE,2,0),coloryellow;
STICKLINE(涨停,H,L,0,0),coloryellow;
STICKLINE(涨停,OPEN,CLOSE,1.9,0) ,COLOR1029FF;
STICKLINE(涨停,OPEN,CLOSE,2.3,0) ,COLOR1040FF;
STICKLINE(涨停,OPEN,CLOSE,2.0,0) ,COLOR1083FF;
STICKLINE(涨停,OPEN,CLOSE,1.6,0) ,COLOR10ABFF;
STICKLINE(涨停,OPEN,CLOSE,1,0) ,COLOR10D0FF;
STICKLINE(涨停,OPEN,CLOSE,0.2,0) ,COLOR10FFFF;}
STICKLINE(涨停,H,L,0,0),colorred;
STICKLINE(涨停,OPEN,CLOSE,3,0) ,colorred;
STICKLINE(涨停,(C+O)/2,C,2.5,0),COLOR10D0FF;
卖出全息价参考:VARA12,colorred,NODRAW;
补仓全息价参考:VARA13,colorgreen,NODRAW;
DRAWICON(优,L,11);
DRAWTEXT(优,L*0.99, '伏击涨停'),colorred;

同花顺鼎牛伏击涨停主图指标公式

 

相关文章