在线检测未来函数

大智慧金线不破主图指标公式

来源:Internet,编辑:股旁网,2016-07-15

IF(FINANCE2(37)/10000>=100) THEN BEGIN
DRAWTEXTREL(0,950,'【超大盘0.7%】 流通A股'+FINANCE2(37)/10000+'亿股'),LINETHICK2,ColorFF00FF; end;
IF(FINANCE2(37)/10000<100 and FINANCE2(37)/10000>=10) THEN BEGIN
DRAWTEXTREL(0,950,'【大盘股9.0%】 流通A股'+FINANCE2(37)/10000+'亿股'),LINETHICK2,ColorFF00FF; end;
IF(FINANCE2(37)/10000<10 and FINANCE2(37)/10000>=5) THEN BEGIN
DRAWTEXTREL(0,950,'【中盘股12.7%】 流通A股'+FINANCE2(37)/10000+'亿股'),LINETHICK2,ColorFF00FF; end;
IF(FINANCE2(37)/10000<5 and FINANCE2(37)/10000>=1) THEN BEGIN
DRAWTEXTREL(0,950,'【小盘股55.3%】 流通A股'+FINANCE2(37)/10000+'亿股'),LINETHICK2,ColorFF00FF; end;
IF(FINANCE2(37)/10000<1) THEN BEGIN
DRAWTEXTREL(0,950,'【超小盘22.3%】 流通A股'+FINANCE2(37)/10000+'亿股'),LINETHICK2,ColorFF00FF; end;
AA1:=AMOUNT/V;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5)*1.5;
FF1:=BB1 AND CC1 AND DD1 AND EE1;
DRAWTEXT(ff1,(LOW* 0.99),'↖鼠'),Color4080FF;
STICKLINE(ff1,O,C,6,0),COLORyellow;
STICKLINE(ff1,O,C,2.5,0),COLORred;
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
买:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);
DRAWTEXT(filter(买=1,5),LOW-0.08,'↖低') ,COLORAAAAFF;
STICKLINE(filter(买=1,5),O,C,6,0),COLORyellow;
STICKLINE(filter(买=1,5),O,C,2.5,0),COLORred;
cc:=(h-c)/(c-o)<0.33;
dd:=(c/ref(c,1)-1)>=0.0502 and c>ref(c,1) and (o-l)/(c-o)>=1.48 and l<ref(l,1) and l<ref(l,2);
ee:=(c/ref(c,1)-1)>=0.08;
aa:=VOL>REF(VOL,1)*1.9 and c>ref(c,1) and c/ref(c,1)-1>=0.049 and cc;
bb:=(c/ref(c,1)-1)>=0.0502 and c>ref(c,1) and v>ref(v,1) and VOL>REF(VOL,1)*2.5 and cc;
DRAWTEXT(FILTER(aa or bb or dd or ee,34),l,'↖异动'),COLOrffff00;
STICKLINE(FILTER(aa or bb or dd or ee,34),O,C,6,0),COLORyellow;
STICKLINE(FILTER(aa or bb or dd or ee,34),O,C,2.5,0),COLORRED;
AAA:=(3*C+H+L+O)/6;
VAR41:=(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)+4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36;
TJ1:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>VAR41;
立桩量:=FILTER(TJ1,5);
TJ2:=IF(BARSLAST(立桩量)=1 AND CLOSE>REF(HIGH,1),1,IF(BARSLAST(立桩量)=2 AND CLOSE>REF(HIGH,2),1,IF(BARSLAST(立桩量)=3 AND CLOSE>REF(HIGH,3),1,0)));
突破:=TJ2=1;
TJ3:=IF(BARSLAST(立桩量)=1 AND CLOSE>REF(LOW,1),1,IF(BARSLAST(立桩量)=2 AND CLOSE>REF(LOW,2),1,IF(BARSLAST(立桩量)=3 AND CLOSE>REF(LOW,3),1,0)));
三天法则:=TJ3=1;
成立:=三天法则 AND 突破;
条件成立:=FILTER(成立,3);
DRAWTEXT(条件成立,L*0.97,'↖立桩量'),COLORYELLOW;
VAR1111:=BACKSET(REF(HIGH,2)=HHV(HIGH,5),3);
VAR2222:=CROSS(VAR1111,0.9);
压力:= REF(HIGH,BARSLAST(VAR2222));
STICKLINE(CLOSE,REF(HIGH,BARSLAST(VAR2222)),REF(HIGH,BARSLAST (VAR2222)),0.5,1),COLOREA91B5,LINETHICK1;
STICKLINE(CLOSE<OPEN and ref(CLOSE,1)>ref(OPEN,1),ref(close,1),ref(close,1),33,0),COLORwhite,LINETHICK1;
DD:=FINANCE2(35);
SS:=FINANCE2(37);
GG:=FINANCE2(3);
TH:=DYNAINFO(39);
DRAWTEXTREL(0,70,'总股本:'+NUMTOSTRn(DD,0)+'万股' +' 流通A股:'+NUMTOSTRn(SS,0)+'万股'+' 市盈率:'+NUMTOSTRn(TH,2)+' 倍'+' 每股收益:'+NUMTOSTRn(GG,3)+' 元'),ColorFFFF00;
gj:=if(c=INDEXC,(INDEXC+INDEXh+INDEXl+INDEXO)/4,AMOUNT/(v+0.01)/100);
明日阻力:=l+(gj-l)+(c-l);
明日支撑:=l+(c-gj);
今日阻力:=REF(明日阻力 , 1);
今日支撑:=REF(明日支撑 , 1);
STICKLINE(DISPSTATUS=2 and c>=今日阻力,今日阻力,今日阻力,20,0),Color0000FF;
STICKLINE(DISPSTATUS=2 and c<今日阻力,今日阻力,今日阻力,20,0),Color00FF00;
STICKLINE(DISPSTATUS=2 and c>=今日支撑,今日支撑,今日支撑,20,0),ColorFF00FF;
STICKLINE(DISPSTATUS=2 and c<今日支撑,今日支撑,今日支撑,20,0),ColorFF9900;
DRAWTEXTREL(850,890,'今日支撑:'+NUMTOSTRN(今日支撑 ,2 )),Colorred;
DRAWTEXTREL(850,950,'今日阻力:'+NUMTOSTRN(今日阻力 ,2 )),ColorGREEN;
DRAWTEXTREL(0,20,'所属板块:'+BKNAME),ColorRED;
DRAWTEXTREL(0,120,'每股收益:'+NUMTOSTRN(FINANCE2(3),3)+'元'+' 市盈率:'+NUMTOSTRN(DYNAINFO(39),2)+'元'+' 市净率:'+NUMTOSTRN((CLOSE / FINANCE2(4)),2)+'元'+' 净资产:'+NUMTOSTRN(FINANCE2(4),2)+'元'),Color00C0FF;
DRAWTEXTREL(0,270,'历史最高价:'+HHV(HIGH,0)),Colorred;
DRAWTEXTREL(160,270,'历史最低价:'+LLV(LOW,0)),ColorAFFF00;
销售毛利率:=FINANCE2(12);
主营收入同比:=FINANCE2(11);
净利润同比增长:=FINANCE2(10);
DRAWTEXTREL(0,170,'销售毛利率:'+NUMTOSTRN(销售毛利率,2)+'%'),LINETHICK1,COLORff00ff;
DRAWTEXTREL(180,170,'主营收入同比增长:'+NUMTOSTRN(主营收入同比,2)+'%'),LINETHICK1,ColorYELLOW;
DRAWTEXTREL(0,220,'净利润同比增长:'+NUMTOSTRN(净利润同比增长,2)+'%'),LINETHICK1,COLOR00FF00;
LJL07:=(3*C+L+O+H)/6;
金钱:(20*LJL07+19*REF(LJL07,1)+18*REF(LJL07,2)+17*REF(LJL07,3)+16*REF(LJL07,4)+15*REF(LJL07,5)+14*REF(LJL07,6)+13*REF(LJL07,7)+12*REF(LJL07,8)+11*REF(LJL07,9)+10*REF(LJL07,10)+9*REF(LJL07,11)+8*REF(LJL07,12)+7*REF(LJL07,13)+6*REF(LJL07,14)+5*REF(LJL07,15)+4*REF(LJL07,16)+3*REF(LJL07,17)+2*REF(LJL07,18)+REF(LJL07,20))/210,COLORgreen,LINETHICK4;
银线:EMA(CLOSE,6),COLORff00ff,LINETHICK4;

大智慧金线不破主图指标公式

 

相关文章