在线检测未来函数

通达信MACD推演优化指标公式

来源:Internet,编辑:股旁网,2016-07-15

0,COLORRED;
DIFF1:((EMA(CLOSE,12) - EMA(CLOSE,26)))/EMA(C,26)*100,COLORWHITE,LINETHICK2;
DEA:EMA(DIFF1,9),COLORYELLOW;
MACD:2*(DIFF1-DEA), COLORSTICK;
STICKLINE(((MACD>REF(MACD,1)) AND (MACD>0)),0,MACD,1,0),COLORMAGENTA,LINETHICK4;
STICKLINE(((MACD<REF(MACD,1)) AND (MACD<0)),0,MACD,1,0),COLORCYAN,LINETHICK4;
HJ1:=CROSS(DIFF1,0);
HJ2:=CROSS(0,DIFF1);
DRAWTEXT(HJ1,DIFF1,'▲')COLORBLUE;
DRAWTEXT(HJ2,DIFF1,'▼')COLORBLUE;
X_1:=IF(DATE<1191130,1,0);
DIF:IF(X_1=1,MACD.DIF,0),LINETHICK0;
X_2:=BARSLAST(REF(MACD,1)<0 AND MACD>0);
X_3:=LLVBARS(MACD,X_2+20);
X_4:=IF(X_3>X_2,REF(MACD,X_3),0);
X_5:=MACD<0 AND MACD>X_4 AND LOW=LLV(LOW,X_2+20) AND X_4<0;
X_6:=REF(X_5,1)=1 AND MACD>REF(MACD,1) AND REF(DIF,X_3)<0 AND MACD<0;
低背:DRAWLINE(X_4=X_3,MACD,X_6,MACD,0),COLORRED,LINETHICK1;
DRAWICON(X_6,MACD*1.2,26);
X_7:=HHVBARS(MACD,X_2+20);
X_8:=IF(X_7>X_2,REF(MACD,X_7),0);
X_9:=MACD>0 AND MACD<X_8 AND HIGH=HHV(HIGH,X_2+20) AND X_8>0;
X_10:=REF(X_9,1)=1 AND MACD>REF(MACD,1) AND REF(DIF,X_7)>0;
顶背:DRAWLINE(X_8=X_7,MACD,X_10,MACD,0),COLORGREEN,LINETHICK1;
DRAWICON(X_10,MACD*1.2,15);
X_11:=CLOSE/MA(CLOSE,40)*100<78;
X_12:=CLOSE/MA(CLOSE,60)*100<74;
X_13:=HIGH>LOW*1.051;
X_14:=X_13 AND COUNT(X_13,5)>1;
X_15:=IF(X_14 AND (X_11 OR X_12),2,0);
X_16:=CLOSE/REF(CLOSE,25)<=1.1;
X_17:=SMA(MAX(CLOSE-REF(CLOSE,2),0),7,1)/SMA(ABS(CLOSE-REF(CLOSE,2)),7,1)*100<15;
X_18:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
X_19:=SMA(X_18,2,1);
X_20:=SMA(X_19,2,1);
X_21:=IF(X_19>REF(X_19,1) AND REF(X_19,1)<REF(X_19,2) AND X_19<23,1.5,0);
抄底:X_16 AND X_15 AND X_17 AND X_21 AND X_1=1,COLORWHITE;
X_22:=100-100*(HHV(HIGH,5*8)-CLOSE)/(HHV(HIGH,5*8)-LLV(LOW,5*8));
X_23:=MA(CLOSE,5);
X_24:=IF(CLOSE>SAR(10,2,20),1,0);
X_25:=IF(CLOSE<SAR(10,2,20),(-1),0);
X_26:=ATAN((X_23/REF(X_23,1)-1)*100)*180/3.1416;
X_27:=IF(X_26>30,1,0);
X_28:=IF(X_26<(-30),(-1),0);
X_29:=X_24+X_27+X_25+X_28;

通达信MACD推演优化指标公式

 

相关文章