在线检测未来函数

通达信动力线主图指标公式

来源:Internet,编辑:股旁网,2016-07-20

VAR1:=EMA((C-(LLV(L,25)))/((HHV(H,25))-(LLV(L,25)))*100,5);
VAR2:=VAR1,COLORRED,LINETHICK2;
VAR3:=MA((V-REF(V,1))/REF(V,1),5);
VAR4:=(C-MA(C,24))/MA(C,24)*100;
VAR5:=VAR4*(1+VAR3);
VAR6:=REF(VOL,1);
VAR7:=SMA(MAX(VOL-VAR6,0),6,1)/SMA(ABS(VOL-VAR6),6,1)*100;
VAR8:=VAR5>REF(VAR5,1) AND VAR2<REF(VAR2,1) AND VAR7>REF(VAR7,1);
VAR9:=VAR5<REF(VAR5,1) AND VAR2>REF(VAR2,1) AND VAR7>REF(VAR7,1);
VAR10:=VAR5>REF(VAR5,1) AND VAR2<REF(VAR2,1) AND VAR7<REF(VAR7,1);
VAR11:=VAR5<REF(VAR5,1) AND VAR2>REF(VAR2,1) AND VAR7<REF(VAR7,1);
VAR12:=VAR5>REF(VAR5,1);
VAR13:=VAR5<REF(VAR5,1);
VAR14:=L<HHV(H,60)*0.6 OR L<HHV(H,50)*0.65 OR L<HHV(H,40)*0.7 OR L<HHV(H,30)*0.75 OR L<HHV(H,20)*0.8 OR L<HHV(H,10)*0.85
AND (H-L)/REF(C,1)>0.08
AND V>MA(V,135)
AND VAR2<40
AND VAR5>REF(VAR5,1);
VAR15:=H<MA(C,20) OR CROSS(MA(C,5),MA(C,10));
VAR16:=SUM(MAX(0,HIGH-(REF(HIGH+LOW,1)/2)),26)/SUM(MAX(0,(REF(HIGH+LOW,1)/2)-LOW),26)*100<40
OR 100*((SUM(IF(CLOSE>REF(CLOSE,1),VOL,0),26))*2+(SUM(IF(CLOSE=REF(CLOSE,1),VOL,0),26)))/((SUM(IF(CLOSE<REF(CLOSE,1),VOL,0),26))*2+(SUM(IF(CLOSE=REF(CLOSE,1),VOL,0),26)))<40
OR SUM(MAX(0,HIGH-REF(CLOSE,1)),26)/SUM(MAX(0,REF(CLOSE,1)-LOW),26)*100<40
OR SUM(HIGH-OPEN,26)/SUM(OPEN-LOW,26)*100<40;
VAR17:=CROSS(82,SMA(MAX(C-(REF(C,1)),0),6,1)/SMA(ABS(C-(REF(C,1))),6,1)*100);
VAR18:=CROSS((SMA(MAX(CLOSE-(REF(CLOSE,1)),0),6,1)/SMA(ABS(CLOSE-(REF(CLOSE,1))),6,1)*100),20);
动力线:C*(VAR2/90),COLORBLUE,LINETHICK2;
DRAWICON(VAR14 AND VAR15 OR VAR18,LOW*0.95,9);
DRAWTEXT(VAR16,LOW*0.95,'★底'),COLORRED;
DRAWTEXT(VAR17,HIGH*1.05,'▼顶'),COLOR00FFFF;
STICKLINE(VAR8=1,LOW,HIGH,0,0),COLORRED;
STICKLINE(VAR8=1,CLOSE,OPEN,2,0),COLORRED;
STICKLINE(VAR9=1,LOW,HIGH,0,0),COLORRED;
STICKLINE(VAR9=1,CLOSE,OPEN,2,0),COLORRED;
STICKLINE(VAR12=1,LOW,HIGH,0,0),COLORRED;
STICKLINE(VAR12=1,CLOSE,OPEN,2,0),COLORRED;
STICKLINE(VAR10=1,LOW,HIGH,0,0),COLORGREEN;
STICKLINE(VAR10=1,CLOSE,OPEN,2,0),COLORGREEN;
STICKLINE(VAR11=1,LOW,HIGH,0,0),COLORGREEN;
STICKLINE(VAR11=1,CLOSE,OPEN,2,0),COLORGREEN;
STICKLINE(VAR13=1,LOW,HIGH,0,0),COLORGREEN;
STICKLINE(VAR13=1,CLOSE,OPEN,2,0),COLORGREEN;

通达信动力线主图指标公式

 

相关文章