在线检测未来函数

通达信玄黄天神指标公式

来源:Internet,编辑:股旁网,2016-07-20

VAR1:=1;
VAR2:=(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100))*200;
VAR3:=SMA(VAR2,3,1);
VAR4:=SMA(VAR3,3,1);
VAR5:=3*VAR3-2*VAR4;
VAR6:=LLV(LOW,5);
VAR7:=HHV(HIGH,5);
VAR8:=EMA((CLOSE-VAR6)/(VAR7-VAR6)*100,4)*2;
VAR9:=EMA(0.667*REF(VAR8,1)+0.333*VAR8,2);
VARA:=3*VAR8-2*VAR9;
VARB:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);
VARC:=POW(MA(LOW,5),2)+MA(LOW,5);
VARD:=POW(MA(HIGH,5),2)+MA(HIGH,5);
VARE:=(VARB-LLV(VARC,64))/(HHV(VARD,64)-LLV(VARC,64))*150+65-10;
VARF:=SMA(VARE,3,1)*1.5-100;
VAR10:=SMA(VARF,3,1);
VAR11:=3*VARF-2*VAR10;
VAR12:=(HIGH+LOW+CLOSE*2)/4;
VAR13:=EMA(VAR12,13);
VAR14:=STD(VAR12,13);
VAR15:=(VAR12-VAR13)*100/VAR14;
VAR16:=EMA(VAR15,5);
VAR17:=EMA(VAR16,13);
VAR18:=EMA(VAR16,13)+200-100;
VAR19:=EMA(VAR18,10);
VAR1A:=3*VAR18-2*VAR19;
VAR1B:=VAR3+VAR8+VARF+VAR18;
VAR1C:=VAR4+VAR9+VAR10+VAR19;
VAR1D:=VAR5+VARA+VAR11+VAR1A;
VAR1E:=(HIGH+LOW+CLOSE)/3;
VAR1F:=AMOUNT/VOL/100;
VAR20:=SUM(AMOUNT,5)/SUM(VOL,5)/100;
VAR21:=(VAR1E-MA(VAR1E,34))/(0.015*AVEDEV(VAR1E,34));
VAR22:=DMA(AMOUNT/VOL/100,VOL/CAPITAL);
VAR23:=(HIGH+LOW+CLOSE+VAR1E)/4;
VAR24:=EMA(VAR23,24);
VAR25:=STD(VAR23,24);
VAR26:=(VAR23-VAR24)/VAR25*100;
VAR27:=(VAR1E-MA(VAR1E,24))/(0.015*AVEDEV(VAR1E,24));
VAR28:=EMA(VAR26,5);
VAR29:=(VAR1F-MA(VAR1F,21))/(0.015*AVEDEV(VAR1F,21));
VAR2A:=(VAR20-MA(VAR20,90))/(0.015*AVEDEV(VAR20,90));
VAR2B:=((VAR2A+VAR29+VAR28+VAR27+VAR21)/5+165)/4*VAR1;
VAR2C:=(EMA(EMA(EMA(VAR2B,15),10),5)-25)*2+VAR22*VAR1;
VAR2D:=(VAR1B+VAR1C+VAR1D*30)/32/5-15*VAR1;
VAR2E:=EMA(VAR2D,13)*VAR1;
VAR2F:=(VAR2B+VAR2D)/2/1.1*VAR1;
天神: VAR2F*VAR1,COLOR00FF00,,LINETHICK2;
MMA1: (VAR2C+VAR2E)/2*VAR1,COLORRED,LINETHICK2;
0,CROSSDOT,COLOR00FF00;
100,CROSSDOT,COLORRED;
50,POINTDOT;
DRAWTEXT(CROSS(MMA1,天神) AND 天神>50? ,天神+2,'风险加大'),COLORYELLOW;
DRAWICON(CROSS(MMA1,天神) AND 天神>50,天神,2);
DRAWTEXT(CROSS(天神,0) ,天神+2,'机遇来临'),COLORF00FF0;
DRAWICON(CROSS(天神,0) ,天神,1);

通达信玄黄天神指标公式

 

相关文章