在线检测未来函数

通达信共振点出击指标公式

来源:Internet,编辑:股旁网,2016-07-22

N:=5; N1:=21;
VAR1:=4*SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1)-
3*SMA(SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1),3.2,1),COLORYELLOW,LINETHICK1;
VARO1:=LLV(LOW,27);
VARO2:=HHV(HIGH,34);
CD1:=(HHV(H,9)-C)/(HHV(H,9)-LLV(L,9))-0.7;
CD2:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9));
CD3:=SMA(SMA(CD2,3,1),3,1);
CD4:=(CD3-SMA(CD1,9,1))-0.5;
CD5:=IF(CD4>0.00,CD4,0.00);
CD6:=REF(CD5,1);
VAR81:=MA(C,9),COLORRED;
VAR1A:=(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100-70;
VAR2A:=SMA(VAR1A,9,1)+100;
VAR3A:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR4A:=SMA(VAR3A,3,1);
VAR5A:=SMA(VAR4A,3,1)+100;
VAR6A:=VAR5A-VAR2A;
出击1:=IF(VAR6A>N1,VAR6A-N1,0),COLORLIRED;
出击:IF(CROSS(出击1,0.01),60,0),COLOR0000CC,COLORCYAN;
DRAWICON(出击>0,63,26),COLORCYAN;
DRAWTEXT(出击,78,'出击'),COLORCYAN;
VAR200:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
VAR300:=SMA(SMA(VAR200,3,1),3,1)/28.57;
VAR400:=EMA(VAR300,5);
共振2号:=3*VAR300-2*VAR400;
A1:=CROSS(共振2号,VAR300) AND VAR300<2.1 AND C>O;
STICKLINE(A1,30,0,4,0),COLOR00FFFF;
STICKLINE(A1,30,0,3,0),COLORFFFF00;
STICKLINE(A1,30,0,4,0),COLOR00FFFF;
STICKLINE(A1,30,0,2,0),COLOR0099FF;
STICKLINE(A1,30,0,1,0),COLOR0000FF;
DRAWTEXT(A1,43,'共振2号'),COLORYELLOW;
RV:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
RG:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100;
J0:=(HIGH+LOW)/2;QJ:=EMA(J0,3);
J1:=IF(CLOSE>QJ,VOL,0);
J2:=IF(CLOSE<QJ,VOL,0);
VAR44:=SMA(RV,3,1);
VAR55:=SMA(VAR44,3,1);
KK:=EMA(SMA(RG,3,1),2),COLORFFFFFF;
DD:=SMA(KK,3,1),COLOR00FFFF;
DRAWTEXT(CROSS(VAR44,VAR55) AND CROSS(KK,DD),51,'共振1号'),COLOR00FFFF,COLORLIBLUE;
共振1号:=(CROSS(VAR44,VAR55) AND CROSS(KK,DD));
STICKLINE(共振1号>0,0,40,2,0),COLOR33FF33;
STICKLINE(共振1号>0,0,40,1.5,0),COLORFF6633;
STICKLINE(共振1号>0,0,40,0.8,0),COLORFFCC33;
STICKLINE(共振1号>0,0,40,0.3,0),COLORFF0066;

通达信共振点出击指标公式

 

相关文章