在线检测未来函数

通达信青翼蝠王主图指标公式

来源:Internet,编辑:股旁网,2016-07-27

N:=18;
M:=14;
I:=26;
VAR01:=REF(CLOSE,5);
VAR02:=MA(CLOSE,30);
VAR03:=((VOL)/(CAPITAL))*(100);
XJYY1:=(VAR01<VAR02) AND (CLOSE<VAR02);
XJYY2:=(((CROSS(MA(CLOSE,3),MA(CLOSE,10)) AND CROSS(CLOSE,VAR02) OR CROSS(MA(CLOSE,5),MA(CLOSE,20)) AND CROSS(CLOSE,VAR02)) OR (MA(CLOSE,5)>MA(CLOSE,20)) AND CROSS(CLOSE,VAR02)) OR (MA(CLOSE,3)>MA(CLOSE,10)) AND CROSS(CLOSE,VAR02));
XJYY3:=((HIGH-OPEN)/(ABS(OPEN-CLOSE))>5) AND (VAR03>2.5) AND (CLOSE>MA(CLOSE,5)) AND (CLOSE>VAR02);
XJYY4:=(((CLOSE-MA(CLOSE,10))/(MA(CLOSE,10)))*(100)>15);
XJYY5:=(((VAR03>3.5) AND (((OPEN-CLOSE)/(CLOSE))*(100)>4) OR (((CLOSE-MA(CLOSE,5))/(MA(CLOSE,5)))*(100)>20)) OR (VAR03>10) AND (((OPEN-CLOSE)/(CLOSE))*(100)>8));
STICKLINE(XJYY1,OPEN,CLOSE,3,0),COLOR00FFFF;
STICKLINE(XJYY2,OPEN,CLOSE,3,0),COLOR0000FF;
STICKLINE(XJYY3,OPEN,CLOSE,3,0),COLORFF0000;
STICKLINE(XJYY4,OPEN,CLOSE,3,0),COLORFFFFFF;
STICKLINE(XJYY5,OPEN,CLOSE,3,0),COLOR00FF00;
MA13:MA(CLOSE,13),COLOR00FF00;
MA55:MA(CLOSE,55),COLOR0000FF;
MA120:MA(CLOSE,120),COLORF0F000;
MA250:MA(CLOSE,250),COLORF00FF0;
VAR1:=('H000001$VOL')*('H000001$CLOSE');
VAR2:=(EMA(VAR1,5))/(EMA('H000001$VOL',5));
VAR3:=(('H000001$CLOSE'-VAR2)/(VAR2))*(100);
VAR4:=(VAR3<=(-1.5)) AND (VAR3>(-100));
VAR5:=(SUM((VAR4>0),N))/(SUM((VAR4=0),N));
VAR6:=(VAR5<5) AND (VAR5>=0.25);
VAR7:=(LOW+HIGH+CLOSE)/(3);
VAR8:=(VAR7-MA(VAR7,M))/((0.015)*(AVEDEV(VAR7,M)));
VAR9:=EMA(VAR8,3);
VARA:=(HIGH+LOW+CLOSE)/(3);
VARB:=((SUM(MAX(0,HIGH-REF(VARA,1)),I))/(SUM(MAX(0,REF(VARA,1)-LOW),I)))*(100);
VARC:=REF(MA(VARB,3),2.2);
VARD:=REF(MA(VARB,13),6.2);
VARE:=REF(MA(VARB,89),36.6);
VARF:=CROSS(VARC,VARB) AND (VARB>150);
DRAWTEXT(VAR6 AND CROSS(VAR8,VAR9),LOW,'抄底'),COLOR00FFFF;
DRAWTEXT(VARF,HIGH,'逃顶'),COLORFF00FF;
VAR10:=MA(CLOSE,5);
VAR11:=MA(CLOSE,10);
VAR12:=((VAR10-CLOSE)/(CLOSE)>0.03);
VAR13:=((VAR11-VAR10)/(VAR10)>0.03);
VAR14:=(LLV(CLOSE,30)=LLV(CLOSE,120));
DRAWICON(VAR12 AND VAR13 AND VAR14,(LOW)*(0.99),5),COLOR00FF00;
VAR15:=(LLV(LOW,5)=LLV(LOW,45)) AND (CLOSE>=(OPEN)*(1.04));
VAR16:=(CLOSE>(REF(HIGH,1)+REF(LOW,1))/(2));
VAR17:=VAR15 AND VAR16;
DRAWTEXT(VAR17,LOW,' 买点 '),COLORFFFFFF;
DRAWICON(CROSS((REF(HIGH,1)+REF(LOW,1))/(2),MA(CLOSE,20)+(2)*(STD(CLOSE,20))),(HIGH)*(1.015),4),COLORFFFF00;

通达信青翼蝠王主图指标公式

 

相关文章