在线检测未来函数

通达信财星计量指标公式

来源:Internet,编辑:股旁网,2016-08-03

N:=1;
M:=3;
求:=IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL),NODRAW;
测换:求/FINANCE(7)*10000,COLOR0099FF;
换手:SUM(((VOL/CAPITAL)*100),N),COLOR0099FF;
{VAR1:=DYNAINFO(17)*REF(MA(VOL,5),1);
VAR2:=DYNAINFO(7)=CLOSE AND DYNAINFO(10)=AMOUNT;
测量:IF(DYNAINFO(7)=CLOSE AND DYNAINFO(10)=AMOUNT,VAR1,VAR2),COLORYELLOW;}
总量:SUM(VOL,N),COLORRED,NODRAW;
值:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
正:=IF(CLOSE>OPEN,值*(HIGH-LOW),IF(CLOSE<OPEN,值*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)),COLORRED,NODRAW;
负:=IF(CLOSE>OPEN,0-值*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-值*(HIGH-LOW),0-VOL/2)),COLORGREEN,NODRAW;
入:SUM(正,N),COLORYELLOW,NODRAW;
出:SUM(负,N),COLORGREEN,NODRAW;
相差±:出+入,COLOR0099FF,NODRAW;
出入±%:(入+出)/(入-出)*100,COLOR0099FF,NODRAW;
成交金额:AMOUNT/100,COLORRED,NODRAW;
{测量线}{STICKLINE(IF(DYNAINFO(7)=CLOSE AND DYNAINFO(10)=AMOUNT,VAR1,VAR2),VAR1,0,2,1),CIRCLEDOT,COLORYELLOW;}
{测量柱}{STICKLINE(VAR2,VAR1,0,3,1),COLORYELLOW;}
STICKLINE(VOL>0,VOL,0,2,1),COLORRED;
STICKLINE(入,入,0,2,0),COLORRED;
STICKLINE(入>0 AND 入>REF(入,1),入*4/5,0,1,0),COLOR00AFFF;
STICKLINE(入>0 AND 入>REF(入,1),入*2/5,0,1,0),COLOR10FFFF;
{STICKLINE(入>0 AND 入<REF(入,1),入,0,1,0),COLORMAGENTA;}
STICKLINE(入>0 AND 入<REF(入,1),入*4/5,0,1,0),COLORCA3DB5;
{STICKLINE(入>0 AND 入<REF(入,1),入*2/5,0,1,0),COLORFF99CC;}
STICKLINE(出,出*(+1),0,2,0),COLOR66FF00;
{STICKLINE(出,出*(+0.75),0,1,1),COLOR66DD00;
STICKLINE(出,出*(+0.75),0,1,0),COLOR66BB00;
STICKLINE(出,出*(+0.65),0,1,0),COLOR669900;
STICKLINE(出,出*(+0.55),0,1,0),COLOR667700;
STICKLINE(出,出*(+0.45),0,1,0),COLOR665500;
STICKLINE(出,出*(+0.35),0,1,0),COLOR663300;}
多:=IF(CLOSE>REF(CLOSE,1),VOL,0);
空:=IF(CLOSE<REF(CLOSE,1),VOL,0);
上穿蓝短买:EMA(MA(多,1),M),COLORRED,LINETHICK2;
上穿白短卖:EMA(MA(空,1),M),COLORCYAN,LINETHICK2;

通达信财星计量指标公式

 

相关文章