在线检测未来函数

通达信寻底彩带指标公式

来源:Internet,编辑:股旁网,2016-08-03

N:=5;
绝对A:=40/100,COLORLIMAGENTA,LINETHICK1,;
绝对B:=30/100,COLORCYAN,LINETHICK1,;
绝对C:=50/100,LINETHICK1,;
VAR1:=HHV(HIGH,N);
猎熊HIGH:=(VAR1-LOW)/VAR1;
猎熊OPEN:=(VAR1-OPEN)/VAR1;
猎熊LOW:=(VAR1-HIGH)/VAR1;
猎熊CLOSE:=(VAR1-CLOSE)/VAR1;
南熊线:=猎熊HIGH,COLORLIGREEN,LINETHICK2;
阻力线:=MA(LLV(猎熊LOW,N),21),LINETHICK3,COLORCYAN;
TR1:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),14);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),14);
PDI:= DMP*100/TR1;
MDI:= DMM*100/TR1;
ADX:= EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,6);
基本超跌线:= MA(HHV(猎熊LOW,N),21),LINETHICK3,COLORYELLOW;
GD1:=MAX(CONST(HHV(南熊线,90)),CONST(HHV(基本超跌线,90)));
GD2:=MAX(CONST(HHV(GD1,90)),CONST(HHV(EMA((MA(DMP,3)-MA(DMM,3)),3)/3+0.125,90)));
GD:=MAX(CONST(HHV(GD2,90)),CONST(基本超跌线*(1+0.382)));
DRAWBAND(GD,RGB( 0,100,100),0,RGB(0,0,0));
西熊线:=EMA(COUNT(CLOSE>REF(CLOSE,1),12),3 )/24,COLORCYAN,LINETHICK2;
北熊线:=ADX*HHV(南熊线,60)/HHV(ADX,60),LINETHICK2,COLORMAGENTA;
反弹线:(基本超跌线*(0.618+1)/2+基本超跌线)/2,POINTDOT,LINETHICK4,COLORLIGREEN;
减持线:基本超跌线*(0.382+0.191)/2,POINTDOT,LINETHICK4,COLORRED;
六一八线:基本超跌线*0.618,POINTDOT,LINETHICK4,COLORLIBLUE;
超跌上线1:基本超跌线*(1+0.191),POINTDOT,LINETHICK4,COLORWHITE;
超跌上线2:基本超跌线*(1+0.382),POINTDOT,LINETHICK4,COLORGRAY;
DRAWBAND(基本超跌线,RGB(0,80,50),0,RGB(0,0,0));
DRAWBAND(反弹线,RGB(0,60,40),0,RGB(0,0,0));
DRAWBAND(六一八线,RGB(0,40,30),0,RGB(0,0,0));
DRAWBAND(减持线,RGB(0,30,20),0,RGB(0,0,0));
0.125,COLORYELLOW;
T:=ABS(IF(北熊线+南熊线-西熊线*2>0,北熊线+南熊线-西熊线*2,0));
点熊线:=EMA(T,3),COLORLIGREEN;
点熊辅线:=(SLOPE (点熊线,7)+1)*REF(点熊线,1),COLORBROWN;
STICKLINE(点熊线>0 ,0,点熊线,1,0),COLORRED;
STICKLINE(点熊辅线>0 ,0,点熊辅线,2,0),COLORYELLOW;
DRAWBAND(EMA((MA(DMP,3)-MA(DMM,3))*1.1,3)/2+0.125,RGB(255,00,00),EMA((DMP-DMM)*1.1,3)/2+0.125,RGB(0,255,255));
猎熊K线:DRAWKLINE( 猎熊HIGH,猎熊OPEN,猎熊LOW,猎熊CLOSE);
完美理想:DRAWICON(猎熊LOW >=0.5 AND 基本超跌线>=0.5 AND 猎熊LOW >基本超跌线 ,阻力线+0.1,13),COLORCYAN;
第一理想:DRAWICON(完美理想=0 AND 猎熊LOW>绝对A AND 基本超跌线>绝对A AND 猎熊LOW>基本超跌线,阻力线+0.05,23),COLORCYAN;
残缺理想:DRAWICON(猎熊LOW>0.3 AND 基本超跌线>0.3 AND猎熊LOW>基本超跌线 AND 第一理想=0 AND 完美理想=0,阻力线,1),COLORCYAN;
DRAWICON(北熊线=南熊线, 南熊线,2);
点熊成金:DRAWICON(点熊线>基本超跌线 AND CROSS(点熊辅线,点熊线)AND 点熊辅线>REF(点熊辅线,1),点熊线+0.04,9);
捕获小熊:DRAWICON(CROSS(点熊线,0.125),点熊线+0.04,14);
EMA((MA(DMP,3)-MA(DMM,3))*1.1,3)/2+0.125;
EMA((DMP-DMM)*1.1,3)/2+0.125;

通达信寻底彩带指标公式

 

相关文章